net-news/snownews: 1.5.13 version bump
authorFrederic Culot <culot@FreeBSD.org>
Fri, 27 Jul 2018 08:49:23 +0000 (10:49 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 20 Aug 2018 14:56:36 +0000 (16:56 +0200)
Closes: https://bugs.gentoo.org/662238
Closes: https://github.com/gentoo/gentoo/pull/9361

net-news/snownews/Manifest
net-news/snownews/metadata.xml
net-news/snownews/snownews-1.5.13.ebuild [new file with mode: 0644]

index c6d9102e3cfa2dea67387618823a3132f1014b9c..f2829ac4529c52bb60583090effb52783075c95c 100644 (file)
@@ -1 +1,2 @@
 DIST snownews-1.5.12.tar.gz 167944 BLAKE2B c629bfa53860a031a6afd3a82d44747e61780b03e5a74bb9db4b8c22b441870a8345317d901ddaf42de62aee54685d6329c49343821005ea211c1e17932bf755 SHA512 7a7ccd5ea57f8bbb73f1429ab931a38203e858c74a383c5347e66088b84f6a7240feeee99e179687ce0a7a89c6c1406ce20d6c5d6771d25a0a0301fa5526e220
+DIST snownews-1.5.13.tar.gz 199931 BLAKE2B 1e68fb46a0fdcea67281adb5334b4e90cb4b520b9d54dafc05e181c5f3ea1f552b80d4835fb0d0d00d2efc8d8cecf0554b547a4e029de49ecc01fb7dc2722c0e SHA512 dd91968141a44f4277eb9f333a5fe06c60805aae6fe36900cde55b85afc254aaca48d06e86b1e9d65b6bcaea76ca162d75d2160f46cb15539776a3f29f990963
index 6f49eba8f49693023f393161560b3a2d9e2717c5..e8523f5eab1899465b8ec746438c658af6004a27 100644 (file)
@@ -1,5 +1,12 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<!-- maintainer-needed -->
+       <maintainer type="person">
+               <email>gentoo@culot.org</email>
+               <name>Frederic Culot</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
 </pkgmetadata>
diff --git a/net-news/snownews/snownews-1.5.13.ebuild b/net-news/snownews/snownews-1.5.13.ebuild
new file mode 100644 (file)
index 0000000..8fe9ca3
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Command-line RSS feed reader"
+HOMEPAGE="https://github.com/kouya/snownews"
+SRC_URI="https://github.com/kouya/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="unicode"
+
+COMMON_DEPEND="
+       >=dev-libs/libxml2-2.5.6
+       >=sys-libs/ncurses-5.3:0=[unicode?]
+       dev-libs/openssl:0=
+"
+RDEPEND="
+       ${COMMON_DEPEND}
+       dev-perl/XML-LibXML
+       dev-perl/libwww-perl
+"
+
+DEPEND="
+       ${COMMON_DEPEND}
+       virtual/pkgconfig
+"
+
+src_prepare() {
+       default
+       tc-export PKG_CONFIG
+       sed -i 's|-lncurses|`\\$(PKG_CONFIG) --libs '"$(usex unicode ncursesw ncurses)"'`|' configure || die
+       sed -i 's|$(INSTALL) -s snownews|$(INSTALL) snownews|' Makefile || die
+}
+
+src_configure() {
+       # perl script, not autotools based
+       ./configure --prefix="${EPREFIX}/usr" || die
+}
+
+src_compile() {
+       emake \
+               CC="$(tc-getCC)" \
+               EXTRA_CFLAGS="${CFLAGS}" \
+               EXTRA_LDFLAGS="${LDFLAGS}"
+}