dev-util/source-highlight: bump up tu 3.1.9
authorSergei Trofimovich <slyfox@gentoo.org>
Fri, 29 Nov 2019 20:36:40 +0000 (20:36 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Fri, 29 Nov 2019 20:37:13 +0000 (20:37 +0000)
Closes: https://bugs.gentoo.org/683402
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-util/source-highlight/Manifest
dev-util/source-highlight/source-highlight-3.1.9.ebuild [new file with mode: 0644]

index bdc185bc2be1bf05a67159d679de3eb46033a6b7..659d0fb87a7fad1e280b7c1d6c43d0850727a683 100644 (file)
@@ -1 +1,2 @@
 DIST source-highlight-3.1.8.tar.gz 1648351 BLAKE2B 1ce1590c86f7aed9d27bb21bce6b0869828b28068d71404410e080b85f6354eb6f520cec8c81d1e9170dd90b158dc4536e5287a04bf2d271fa26354fb853ea32 SHA512 00a49ab180460750614b38be9a569478d1d34d01f601ebc7452a4fee8475a19faf9bb9fb2f256c6b40d43fbc3d34962a77ba8b9833483345c4e4a42faad6976c
+DIST source-highlight-3.1.9.tar.gz 1717234 BLAKE2B 6eb40b2274df0772c4a241504e5db5dfdaac600549e0b11aba726f7b4d5ab600c3849a8815bc782ad1bb1f99b69766527645dd202731bde4b2466c663842c47c SHA512 d8e154e9a5d62c77807e4e5d36c0faed5ce2964291be5f8b83e2968a6de52229503689a4ca2109a717ae2632a14b63ec937ca0430c91684c72063f6bc0294195
diff --git a/dev-util/source-highlight/source-highlight-3.1.9.ebuild b/dev-util/source-highlight/source-highlight-3.1.9.ebuild
new file mode 100644 (file)
index 0000000..1b8ae59
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 flag-o-matic
+
+DESCRIPTION="Generate highlighted source code as an (x)html document"
+HOMEPAGE="https://www.gnu.org/software/src-highlite/source-highlight.html"
+SRC_URI="mirror://gnu/src-highlite/${P}.tar.gz"
+LICENSE="GPL-3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+SLOT="0"
+IUSE="doc static-libs"
+
+RDEPEND=">=dev-libs/boost-1.62.0:=[threads]
+       dev-util/ctags"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+src_configure() {
+       # required as rev-dep of dev-libs/boost-1.62.0
+       # https://wiki.gentoo.org/wiki/Project:C%2B%2B/Maintaining_ABI
+       append-cxxflags -std=c++14
+
+       econf \
+               --with-boost="${EPREFIX}/usr" \
+               --with-boost-regex="boost_regex" \
+               --without-bash-completion \
+               $(use_enable static-libs static)
+}
+
+src_install () {
+       use doc && local HTML_DOCS=( doc/*.{html,css,java} )
+       default
+
+       # That's not how we want it
+       rm -rf "${ED%/}"/usr/share/{aclocal,doc} || die
+
+       # package provides .pc file
+       find "${D}" -name '*.la' -delete || die
+
+       dobashcomp completion/source-highlight
+}
+
+src_test() {
+       export LD_LIBRARY_PATH="${S}/lib/srchilite/.libs/"
+       # upstream uses the same temporary filenames in numerous places
+       # see https://bugs.gentoo.org/635100
+       emake -j1 check
+}