Cleaned up ebuild
authorPaul de Vrieze <pauldv@gentoo.org>
Wed, 14 Jan 2004 10:48:46 +0000 (10:48 +0000)
committerPaul de Vrieze <pauldv@gentoo.org>
Wed, 14 Jan 2004 10:48:46 +0000 (10:48 +0000)
app-office/openoffice-ximian/ChangeLog
app-office/openoffice-ximian/Manifest
app-office/openoffice-ximian/openoffice-ximian-1.1.49.2.ebuild

index 4ea6f819da03df662546d7606fd96d5cc53847b4..4dba40b8f5b742d9286a67b638bc099ca7c747f9 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for app-office/openoffice-ximian
 # Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/ChangeLog,v 1.11 2004/01/14 10:03:47 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/ChangeLog,v 1.12 2004/01/14 10:48:46 pauldv Exp $
+
+  14 Jan 2004; Paul de Vrieze <pauldv@gentoo.org>
+  openoffice-ximian-1.1.49.2.ebuild:
+  cleaned up ebuild. Not revision dumping as the time between commits is very
+  short
 
 *openoffice-ximian-1.1.49.2 (14 Jan 2004)
 
index 539475e7f656e64b50504644f75ffdaf76abccbb..5567bad616390a04bd81d6d0f0884375c166d32a 100644 (file)
@@ -1,10 +1,10 @@
 MD5 f7fab855281d6deb95f3b25c87345508 openoffice-ximian-1.1.0.ebuild 19444
-MD5 79a426d5563d999eed0333d7a24229ab openoffice-ximian-1.1.49.2.ebuild 18956
+MD5 40fb24362810e18af40372f5c62c4ca7 openoffice-ximian-1.1.49.2.ebuild 17889
 MD5 a38a74cf65d31f03797033ab918467be openoffice-ximian-1.1.48.ebuild 19079
 MD5 829041ef5297811d60cb8ba8349ccdac openoffice-ximian-1.1.0-r1.ebuild 18407
 MD5 d5388f5c0f400531795b31fd21d3c95b openoffice-ximian-1.1.47.3.ebuild 18716
 MD5 f3942f82433bf5ae16461240cbcc4984 metadata.xml 300
-MD5 1f9391e0cddb9f661697d52cc7de1076 ChangeLog 2663
+MD5 68a85960eef1e2d992d132e13a6056bd ChangeLog 2837
 MD5 1ec97d738c2ba40fe390d7af1fccdd87 openoffice-ximian-1.1.46.ebuild 18469
 MD5 4657a820e8c5914e37383fa3e014ab38 files/textdoc.desktop 1969
 MD5 4834c6f3d1bac4ab5567ba499c3a584e files/spreadsheet.desktop 1709
index 0d30a01a2ed954314f091e608a29ebed50b3c102..ac22cb1a3d0b109401e089b59b53b967791b4d89 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2004 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.1.49.2.ebuild,v 1.1 2004/01/14 10:03:47 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.1.49.2.ebuild,v 1.2 2004/01/14 10:48:46 pauldv Exp $
 
 # IMPORTANT:  This is extremely alpha!!!
 
 #   Get support going for installing a custom language pack.  Also
 #   need to be able to install more than one language pack.
 
-inherit flag-o-matic eutils kernel-mod
+inherit flag-o-matic eutils gcc virtualx
+
 # Compile problems with these ...
 filter-flags "-funroll-loops"
 filter-flags "-fomit-frame-pointer"
+filter-flags "-fprefetch-loop-arrays"
 append-flags "-fno-strict-aliasing"
 replace-flags "-O3" "-O2"
 replace-flags "-Os" "-O2"
 
-# Enable Bytecode Interpreter for freetype ...
-append-flags "-DTT_CONFIG_OPTION_BYTECODE_INTERPRETER"
-
-inherit gcc
 # We want gcc3 if possible!!!!
 export WANT_GCC_3="yes"
 
-inherit virtualx
-
 # Set $ECPUS to amount of processes multiprocessing build should use.
 # NOTE:  Setting this too high might cause dmake to segfault!!
 #        Setting this to anything but "1" on my pentium4 causes things
 #        to segfault :(
 [ -z "${ECPUS}" ] && export ECPUS="1"
 
-
 OO_VER=1.1.0
-XIMIAN_VER=${PV}
 PATCHLEVEL=OOO_1_1_0
 ICON_VER=OOO_1_1-7
 INSTDIR="/opt/Ximian-OpenOffice"
-PATCHDIR=${WORKDIR}/ooo-build-${XIMIAN_VER}
+PATCHDIR=${WORKDIR}/ooo-build-${PV}
 ICONDIR=${WORKDIR}/ooo-icons-${ICON_VER}
 S="${WORKDIR}/oo_${OO_VER/1.1.0/1.1}_src"
 DESCRIPTION="Ximian-ized version of OpenOffice.org, a full office productivity suite."
 SRC_URI="mirror://openoffice/stable/${OO_VER}/OOo_${OO_VER}_source.tar.bz2
-       http://ooo.ximian.com/packages/${PATCHLEVEL}/ooo-build-${XIMIAN_VER}.tar.gz
+       http://ooo.ximian.com/packages/${PATCHLEVEL}/ooo-build-${PV}.tar.gz
        http://ooo.ximian.com/packages/ooo-icons-${ICON_VER}.tar.gz"
 
 HOMEPAGE="http://ooo.ximian.com"
@@ -101,15 +95,9 @@ DEPEND="${RDEPEND}
        !app-office/openoffice-bin
        !app-office/openoffice
        >=sys-apps/findutils-4.1.20-r1
-       !app-arch/star
        dev-libs/libxslt
-       !=app-arch/tar-1.13.92-r1"
-
-# fix a bug with tcsh and dircolors
-#
-# Azarah -- 10 April 2002
-export LS_COLORS=""
-
+       net-ftp/curl
+       !dev-util/dmake"
 
 pkg_setup() {
 
@@ -243,7 +231,7 @@ src_unpack() {
        oo_setup
 
        cd ${WORKDIR}
-       unpack OOo_${OO_VER}_source.tar.bz2 ooo-build-${XIMIAN_VER}.tar.gz ooo-icons-${ICON_VER}.tar.gz
+       unpack OOo_${OO_VER}_source.tar.bz2 ooo-build-${PV}.tar.gz ooo-icons-${ICON_VER}.tar.gz
 
        #Still needed: The STLport patch
        cd ${S}
@@ -327,18 +315,8 @@ src_compile() {
        export CC="$(gcc-getCC)"
        export CXX="$(gcc-getCXX)"
 
-       # Enable ccache for this build (Az)
-       if [ "${FEATURES/-ccache/}" = "${FEATURES}" -a \
-            "${FEATURES/ccache/}" != "${FEATURES}" -a \
-            -d /usr/bin/ccache -a -x /usr/bin/ccache/ccache ]
-       then
-               # Build uses its own env with $PATH, etc, so
-               # we take the easy way out. (Az)
-               export CC="/usr/bin/ccache/ccache ${CC}"
-               export CXX="/usr/bin/ccache/ccache ${CXX}"
-
        # Enable new ccache for this build
-       elif [ "${FEATURES/-ccache/}" = "${FEATURES}" -a \
+       if [ "${FEATURES/-ccache/}" = "${FEATURES}" -a \
             "${FEATURES/ccache/}" != "${FEATURES}" -a \
             -x /usr/bin/ccache -a ! -d /usr/bin/ccache ]
        then
@@ -385,6 +363,7 @@ src_compile() {
                --enable-fontconfig \
                --with-system-zlib \
                --with-system-freetype \
+               --with-system-curl \
                --disable-java || die
 
        cd ${S}
@@ -539,7 +518,7 @@ src_install() {
        # Setup virtualmake
        export maketype="./setup"
        # We need X to install...
-       virtualmake "-v -noexit -r:${T}/autoresponse"
+       virtualmake "-v -noexit -r:${T}/autoresponse" || die "virtualmake failed"
 
        echo
        einfo "Removing build root from registry..."
@@ -567,14 +546,11 @@ src_install() {
        sed -e "s|<pv>|${OO_VER}|g" \
                ${FILESDIR}/${OO_VER}/ooffice-wrapper-1.3 > ${T}/ooffice
        doexe ${T}/ooffice
+
        # Component symlinks
-       dosym ooffice /usr/bin/oocalc
-       dosym ooffice /usr/bin/oodraw
-       dosym ooffice /usr/bin/ooimpress
-       dosym ooffice /usr/bin/oomath
-       dosym ooffice /usr/bin/oowriter
-       dosym ooffice /usr/bin/ooweb
-       dosym ooffice /usr/bin/oosetup
+       for app in calc draw impress html math writer setup; do
+               dosym ooffice /usr/bin/oo${app}
+       done
 
        # Install ximian icons
        cd ${PATCHDIR}/desktop/
@@ -594,15 +570,8 @@ src_install() {
                doins ${FILESDIR}/*.desktop
        fi
 
-
-       # Unneeded, as they get installed into /usr/share...
-       # They are needed else user installation fails.
-#      rm -rf ${D}${INSTDIR}/share/{cde,gnome,kde}
+       # Remove unneeded stuff
        rm -rf ${D}${INSTDIR}/share/cde
-#
-#      for f in ${D}/usr/share/gnome/apps/OpenOffice.org/* ; do
-#              echo 'Categories=Application;Office;' >> ${f}
-#      done
 
        # Make sure these do not get nuked.
        keepdir ${INSTDIR}/user/registry/res/en-us/org/openoffice/{Office,ucb}
@@ -621,8 +590,5 @@ pkg_postinst() {
        einfo
        einfo "   oocalc, oodraw, ooimpress, oomath, ooweb or oowriter"
        einfo
-       einfo " If the fonts appear garbled in the user interface refer to "
-       einfo " Bug 8539, or http://www.openoffice.org/FAQs/fontguide.html#8"
-       einfo
        einfo "******************************************************************"
 }