app-emacs/matlab: Generate autoload file.
authorUlrich Müller <ulm@gentoo.org>
Fri, 18 Oct 2019 18:05:15 +0000 (20:05 +0200)
committerUlrich Müller <ulm@gentoo.org>
Fri, 18 Oct 2019 18:05:49 +0000 (20:05 +0200)
Closes: https://bugs.gentoo.org/698006
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-emacs/matlab/files/50matlab-gentoo-3.3.6.el [new file with mode: 0644]
app-emacs/matlab/matlab-3.3.6_pre20191010-r1.ebuild [moved from app-emacs/matlab/matlab-3.3.6_pre20191010.ebuild with 79% similarity]

diff --git a/app-emacs/matlab/files/50matlab-gentoo-3.3.6.el b/app-emacs/matlab/files/50matlab-gentoo-3.3.6.el
new file mode 100644 (file)
index 0000000..499ac3d
--- /dev/null
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "matlab-load" nil t)
similarity index 79%
rename from app-emacs/matlab/matlab-3.3.6_pre20191010.ebuild
rename to app-emacs/matlab/matlab-3.3.6_pre20191010-r1.ebuild
index 42573b3e47ca3259df1239704725321acaa58c8d..33487fa8e1bba1e34036f71b4f375e786b69eca5 100644 (file)
@@ -14,5 +14,10 @@ SLOT="0"
 KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
 
 S="${WORKDIR}/matlab-emacs-src"
-SITEFILE="50${PN}-gentoo.el"
+SITEFILE="50${PN}-gentoo-3.3.6.el"
 DOCS="README.org INSTALL ChangeLog*"
+
+src_compile() {
+       elisp-compile *.el
+       elisp-make-autoload-file matlab-load.el
+}