media-gfx/kphotoalbum: Fix build with GCC-8
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 19 Aug 2018 08:20:47 +0000 (10:20 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 19 Aug 2018 08:26:44 +0000 (10:26 +0200)
Package-Manager: Portage-2.3.47, Repoman-2.3.10

media-gfx/kphotoalbum/files/kphotoalbum-5.3-gcc8.patch [new file with mode: 0644]
media-gfx/kphotoalbum/kphotoalbum-5.3.ebuild

diff --git a/media-gfx/kphotoalbum/files/kphotoalbum-5.3-gcc8.patch b/media-gfx/kphotoalbum/files/kphotoalbum-5.3-gcc8.patch
new file mode 100644 (file)
index 0000000..ce52589
--- /dev/null
@@ -0,0 +1,29 @@
+From 47f4c00adaa442cd03b02d44517b5503718f2813 Mon Sep 17 00:00:00 2001
+From: Christophe Giboudeaux <christophe@krop.fr>
+Date: Tue, 12 Jun 2018 22:52:06 +0200
+Subject: Fix build with Qt 5.11.
+
+Summary: 'id' is an int, it doesn't need qPrintable.
+
+Reviewers: johanneszarl
+
+Differential Revision: https://phabricator.kde.org/D13329
+---
+ RemoteControl/RemoteConnection.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/RemoteControl/RemoteConnection.cpp b/RemoteControl/RemoteConnection.cpp
+index 1dacb72..8bc18d0 100644
+--- a/RemoteControl/RemoteConnection.cpp
++++ b/RemoteControl/RemoteConnection.cpp
+@@ -105,7 +105,7 @@ void RemoteConnection::dataReceived()
+             std::unique_ptr<RemoteCommand> command = RemoteCommand::create(static_cast<CommandType>(id));
+             command->decode(stream);
+             protocolDebug() << qPrintable(QTime::currentTime().toString(QString::fromUtf8("hh:mm:ss.zzz")))
+-                               << ": Received " << qPrintable(id);
++                               << ": Received " << id;
+             emit gotCommand(*command);
+         }
+-- 
+cgit v0.11.2
index ad95715accd9d69263f2041a23af8c81c2fe7eec..c5416d5f9a77fd7b9a5153e92524045da1560aee 100644 (file)
@@ -52,6 +52,8 @@ RDEPEND="${COMMON_DEPEND}
 
 DOCS=( ChangeLog README )
 
+PATCHES=( "${FILESDIR}/${P}-gcc8.patch" )
+
 src_configure() {
        append-ldflags -fuse-ld=gold #bug #623566