dev-python/pymilter: Python interface to sendmail milter API
authorRalph Seichter <github@seichter.de>
Sun, 7 Apr 2019 19:48:40 +0000 (21:48 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Fri, 7 Jun 2019 18:52:58 +0000 (20:52 +0200)
Python extension module to enable python scripts to attach to
Sendmail's libmilter API (also used by Postfix), enabling filtering
of messages as they arrive.

Signed-off-by: Ralph Seichter <gentoo@seichter.de>
Closes: https://bugs.gentoo.org/533272
Package-Manager: Portage-2.3.62, Repoman-2.3.11
Closes: https://github.com/gentoo/gentoo/pull/11633
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-python/pymilter/Manifest [new file with mode: 0644]
dev-python/pymilter/metadata.xml [new file with mode: 0644]
dev-python/pymilter/pymilter-1.0.4.ebuild [new file with mode: 0644]

diff --git a/dev-python/pymilter/Manifest b/dev-python/pymilter/Manifest
new file mode 100644 (file)
index 0000000..0718600
--- /dev/null
@@ -0,0 +1 @@
+DIST pymilter-1.0.4.tar.gz 1023222 BLAKE2B 1e5ce42af76ae1ac2f7cda87d40bdce404ed7e9fce9e88909572ec065f05e2c9effc8bc62d4fad113753ff7dc7e87c790515a9116615191745097cb2c3390042 SHA512 b356a10ffc0ba0172cdb228e4e15034e67c0fd82b4b8bbe1193e54e45e518626fd647033d824f2cd5a9d456154c528027726977d3ad2f2c2fe0e0155ad50d294
diff --git a/dev-python/pymilter/metadata.xml b/dev-python/pymilter/metadata.xml
new file mode 100644 (file)
index 0000000..2db73a8
--- /dev/null
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>gentoo@seichter.de</email>
+               <name>Ralph Seichter</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <longdescription>
+               A python extension module to enable python scripts to attach
+               to sendmail’s libmilter functionality. Additional python
+               modules provide for navigating and modifying MIME parts, and
+               sending DSNs or doing CBVs.
+       </longdescription>
+       <upstream>
+               <remote-id type="github">sdgathman/pymilter</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/pymilter/pymilter-1.0.4.ebuild b/dev-python/pymilter/pymilter-1.0.4.ebuild
new file mode 100644 (file)
index 0000000..3a205f2
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to sendmail milter API"
+HOMEPAGE="https://github.com/sdgathman/pymilter"
+SRC_URI="https://github.com/sdgathman/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}/${PN}-${P}"
+
+python_test() {
+       "${EPYTHON}" -m unittest discover -v || die
+}