app-shells/zsh: version bump to 5.1.1
authorTim Harder <radhermit@gentoo.org>
Thu, 17 Sep 2015 03:07:27 +0000 (23:07 -0400)
committerTim Harder <radhermit@gentoo.org>
Thu, 17 Sep 2015 03:07:27 +0000 (23:07 -0400)
app-shells/zsh/Manifest
app-shells/zsh/zsh-5.1.1.ebuild [new file with mode: 0644]
app-shells/zsh/zsh-9999.ebuild

index a7f03ef4e9159489ec373d8b896860a6b808385c..782f83d52dbd19ae8f864933d639b09d027be75d 100644 (file)
@@ -4,3 +4,5 @@ DIST zsh-5.0.7-doc.tar.bz2 3005587 SHA256 43e8665ba9d9eca8370c64e2d4846e84f9111c
 DIST zsh-5.0.7.tar.bz2 3181030 SHA256 544e27de81740286b916d1d77c9f48ad7c26ad7943ed96d278abee67cf6704b3 SHA512 e309863b41c9f92996fb9301d96d1aa43270ef8a04626c946703675b16a0a2ac9fddc959184cd8c639bd061fc2dd21902b21515550f639faacccdabd59e256e5 WHIRLPOOL f7cfbc41a2c990f702fee4ee158db79ebaad794479a62ff0ccd1d466077556e93b5e563575f9fd25dde1cb5e3c3610a14c997155ea76d86293d0a08168a3a418
 DIST zsh-5.0.8-doc.tar.bz2 3204865 SHA256 0ee5088c47fa5ceac6e087c7e00f2ede3f5920a03d32220772342ce980339e40 SHA512 86f75cfa16a2d0acbd75dc11d16a9bd4813ea2f0c6e323ed6fd73e66250420333fe0be2dbd62171a36aa479b5b5b423777f7ca369afb29d0f456fb7ed68926f6 WHIRLPOOL 1b25a455e7617cf624f8656eef2064e35a3c7798aec3d2822522bb89cad11441e1658966c467ecd758fa9e02ffcc235ee036830fd00757a04c3ff8e1b21fc434
 DIST zsh-5.0.8.tar.bz2 3250542 SHA256 8079cf08cb8beff22f84b56bd72bb6e6962ff4718d816f3d83a633b4c9e17d23 SHA512 79e438e32802c030749fd1bfff07fb3e5e7f7864e5106233c6f51ea477aa5a8471449e22f262f03bf69f42e66bf39e3b8a93295a247436ce97c66409b582ceae WHIRLPOOL 3ed95b2763bd3e486104a9f935efc89fd9ff1b3d745c1c3a93181a511c2986246e4f14c6d15fd88dd735c006127523ce423150813147250343871c9e2f40f413
+DIST zsh-5.1.1-doc.tar.xz 3061616 SHA256 f5944f29ec77100afdc3634f0bb8ffc4328a2d03147f23d1aa6280b6aa7d622f SHA512 868444662ca9b1cc91f2ecff56ce0944e5e75fc5f5a349eb538ca23a8eb8fb4ebaa8efc2ba1d8581424f25b0009305ed7a6f08ca06db1ecde467eeb5d6b71621 WHIRLPOOL c72760d754e19e7fe1f501bd395becc13877d4b0ba20fbf1f08855be5affb78aac07e2c14e779c1b554e21e29d8bfd5203dd41da5d3f21020dac7033510a4662
+DIST zsh-5.1.1.tar.xz 2788676 SHA256 74e9453b5470b3c0970f9f93cfd603d241c3d7b1968adc0e4b3951073e8d3dec SHA512 732f183a03125e83da11a38c638ca54a667326a23ca19418b0df27b1d5b3b1f360383d84f66bde064911effaa2ce9cbb9b6ab86deddb92f80e8f601af8a82b3e WHIRLPOOL 55199e45557c2667e8f9b7564af44b32b610fe09db451493bd64642c2987e12a638b2b96d6530a16427ba17a6ca8c20e73f88013cf47996eea24e5e1595691e7
diff --git a/app-shells/zsh/zsh-5.1.1.ebuild b/app-shells/zsh/zsh-5.1.1.ebuild
new file mode 100644 (file)
index 0000000..695369a
--- /dev/null
@@ -0,0 +1,212 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic multilib prefix
+
+if [[ ${PV} == 9999* ]] ; then
+       inherit git-r3 autotools
+       EGIT_REPO_URI="git://git.code.sf.net/p/zsh/code"
+else
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+       SRC_URI="http://www.zsh.org/pub/${P}.tar.xz
+               doc? ( http://www.zsh.org/pub/${P}-doc.tar.xz )"
+fi
+
+DESCRIPTION="UNIX Shell similar to the Korn shell"
+HOMEPAGE="http://www.zsh.org/"
+
+LICENSE="ZSH gdbm? ( GPL-2 )"
+SLOT="0"
+IUSE="caps debug doc examples gdbm maildir pcre static unicode"
+
+RDEPEND="
+       >=sys-libs/ncurses-5.1:0
+       static? ( >=sys-libs/ncurses-5.7-r4:0=[static-libs] )
+       caps? ( sys-libs/libcap )
+       pcre? (
+               >=dev-libs/libpcre-3.9
+               static? ( >=dev-libs/libpcre-3.9[static-libs] )
+       )
+       gdbm? ( sys-libs/gdbm )
+"
+DEPEND="sys-apps/groff
+       ${RDEPEND}"
+PDEPEND="
+       examples? ( app-doc/zsh-lovers )
+"
+if [[ ${PV} == 9999* ]] ; then
+       DEPEND+=" app-text/yodl
+               doc? (
+                       sys-apps/texinfo
+                       app-text/texi2html
+                       virtual/latex-base
+               )"
+fi
+
+src_prepare() {
+       # fix zshall problem with soelim
+       ln -s Doc man1
+       mv Doc/zshall.1 Doc/zshall.1.soelim
+       soelim Doc/zshall.1.soelim > Doc/zshall.1
+
+       epatch "${FILESDIR}"/${PN}-init.d-gentoo-r1.diff
+
+       cp "${FILESDIR}"/zprofile-1 "${T}"/zprofile || die
+       eprefixify "${T}"/zprofile || die
+       if use prefix ; then
+               sed -i -e 's|@ZSH_PREFIX@||' -e '/@ZSH_NOPREFIX@/d' "${T}"/zprofile || die
+       else
+               sed -i -e 's|@ZSH_NOPREFIX@||' -e '/@ZSH_PREFIX@/d' -e 's|""||' "${T}"/zprofile || die
+       fi
+
+       if [[ ${PV} == 9999* ]] ; then
+               sed -i "/^VERSION=/s/=.*/=${PV}/" Config/version.mk || die
+               eautoreconf
+       fi
+}
+
+src_configure() {
+       local myconf=()
+
+       if use static ; then
+               myconf+=( --disable-dynamic )
+               append-ldflags -static
+       fi
+       if use debug ; then
+               myconf+=(
+                       --enable-zsh-debug
+                       --enable-zsh-mem-debug
+                       --enable-zsh-mem-warning
+                       --enable-zsh-secure-free
+                       --enable-zsh-hash-debug
+               )
+       fi
+
+       if [[ ${CHOST} == *-darwin* ]]; then
+               myconf+=( --enable-libs=-liconv )
+               append-ldflags -Wl,-x
+       fi
+
+       econf \
+               --bindir="${EPREFIX}"/bin \
+               --libdir="${EPREFIX}"/usr/$(get_libdir) \
+               --enable-etcdir="${EPREFIX}"/etc/zsh \
+               --enable-runhelpdir="${EPREFIX}"/usr/share/zsh/${PV%_*}/help \
+               --enable-fndir="${EPREFIX}"/usr/share/zsh/${PV%_*}/functions \
+               --enable-site-fndir="${EPREFIX}"/usr/share/zsh/site-functions \
+               --enable-function-subdirs \
+               --with-tcsetpgrp \
+               $(use_enable maildir maildir-support) \
+               $(use_enable pcre) \
+               $(use_enable caps cap) \
+               $(use_enable unicode multibyte) \
+               $(use_enable gdbm ) \
+               "${myconf[@]}"
+
+       if use static ; then
+               # compile all modules statically, see Bug #27392
+               # removed cap and curses because linking failes
+               sed -e "s,link=no,link=static,g" \
+                       -e "/^name=zsh\/cap/s,link=static,link=no," \
+                       -e "/^name=zsh\/curses/s,link=static,link=no," \
+                       -i "${S}"/config.modules || die
+               if ! use gdbm ; then
+                       sed -i '/^name=zsh\/db\/gdbm/s,link=static,link=no,' \
+                               "${S}"/config.modules || die
+               fi
+       fi
+}
+
+src_compile() {
+       default
+
+       if [[ ${PV} == 9999* ]] && use doc ; then
+               emake -C Doc everything
+       fi
+}
+
+src_test() {
+       addpredict /dev/ptmx
+       local i
+       for i in C02cond.ztst V08zpty.ztst X02zlevi.ztst Y01completion.ztst Y02compmatch.ztst Y03arguments.ztst ; do
+               rm "${S}"/Test/${i} || die
+       done
+       emake check
+}
+
+src_install() {
+       emake DESTDIR="${D}" install install.info
+
+       insinto /etc/zsh
+       doins "${T}"/zprofile
+
+       keepdir /usr/share/zsh/site-functions
+       insinto /usr/share/zsh/${PV%_*}/functions/Prompts
+       newins "${FILESDIR}"/prompt_gentoo_setup-1 prompt_gentoo_setup
+
+       local i
+
+       # install miscellaneous scripts (bug #54520)
+       sed -e "s:/usr/local/bin/perl:${EPREFIX}/usr/bin/perl:g" \
+               -e "s:/usr/local/bin/zsh:${EPREFIX}/bin/zsh:g" \
+               -i {Util,Misc}/* || die
+       for i in Util Misc ; do
+               insinto /usr/share/zsh/${PV%_*}/${i}
+               doins ${i}/*
+       done
+
+       # install header files (bug #538684)
+       insinto /usr/include/zsh
+       doins config.h Src/*.epro
+       for i in Src/{zsh.mdh,*.h} ; do
+               sed -e 's@\.\./config\.h@config.h@' \
+                       -e 's@#\(\s*\)include "\([^"]\+\)"@#\1include <zsh/\2>@' \
+                       -i "${i}"
+               doins "${i}"
+       done
+
+       dodoc ChangeLog* META-FAQ NEWS README config.modules
+
+       if use doc ; then
+               pushd "${WORKDIR}/${PN}-${PV%_*}" >/dev/null
+               dohtml -r Doc/*
+               insinto /usr/share/doc/${PF}
+               doins Doc/zsh.{dvi,pdf}
+               popd >/dev/null
+       fi
+
+       docinto StartupFiles
+       dodoc StartupFiles/z*
+}
+
+pkg_postinst() {
+       if [[ -z ${REPLACING_VERSIONS} ]] ; then
+               echo
+               elog "If you want to enable Portage completions and Gentoo prompt,"
+               elog "emerge app-shells/gentoo-zsh-completions and add"
+               elog "  autoload -U compinit promptinit"
+               elog "  compinit"
+               elog "  promptinit; prompt gentoo"
+               elog "to your ~/.zshrc"
+               echo
+               elog "Also, if you want to enable cache for the completions, add"
+               elog "  zstyle ':completion::complete:*' use-cache 1"
+               elog "to your ~/.zshrc"
+               echo
+               elog "Note that a system zprofile startup file is installed. This will override"
+               elog "PATH and possibly other variables that a user may set in ~/.zshenv."
+               elog "Custom PATH settings and similar overridden variables can be moved to ~/.zprofile"
+               elog "or other user startup files that are sourced after the system zprofile."
+               echo
+               elog "If PATH must be set in ~/.zshenv to affect things like non-login ssh shells,"
+               elog "one method is to use a separate path-setting file that is conditionally sourced"
+               elog "in ~/.zshenv and also sourced from ~/.zprofile. For more information, see the"
+               elog "zshenv example in ${EROOT}/usr/share/doc/${PF}/StartupFiles/."
+               echo
+               elog "See https://wiki.gentoo.org/wiki/Zsh/HOWTO for more introduction documentation."
+               echo
+       fi
+}
index 90f8bbe85f969ab2b6d56c97dfb3e93384b3ca2f..695369ab8bfcc20b2fae69b4c782c1ac9fdfc7dd 100644 (file)
@@ -11,8 +11,8 @@ if [[ ${PV} == 9999* ]] ; then
        EGIT_REPO_URI="git://git.code.sf.net/p/zsh/code"
 else
        KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-       SRC_URI="http://www.zsh.org/pub/${P}.tar.bz2
-               doc? ( http://www.zsh.org/pub/${P}-doc.tar.bz2 )"
+       SRC_URI="http://www.zsh.org/pub/${P}.tar.xz
+               doc? ( http://www.zsh.org/pub/${P}-doc.tar.xz )"
 fi
 
 DESCRIPTION="UNIX Shell similar to the Korn shell"
@@ -23,11 +23,13 @@ SLOT="0"
 IUSE="caps debug doc examples gdbm maildir pcre static unicode"
 
 RDEPEND="
-       >=sys-libs/ncurses-5.1
+       >=sys-libs/ncurses-5.1:0
        static? ( >=sys-libs/ncurses-5.7-r4:0=[static-libs] )
        caps? ( sys-libs/libcap )
-       pcre? ( >=dev-libs/libpcre-3.9
-               static? ( >=dev-libs/libpcre-3.9[static-libs] ) )
+       pcre? (
+               >=dev-libs/libpcre-3.9
+               static? ( >=dev-libs/libpcre-3.9[static-libs] )
+       )
        gdbm? ( sys-libs/gdbm )
 "
 DEPEND="sys-apps/groff