dev-libs/re2: fix tests on 32-bit platforms
authorMike Gilbert <floppym@gentoo.org>
Sat, 23 May 2020 20:16:47 +0000 (16:16 -0400)
committerMike Gilbert <floppym@gentoo.org>
Sat, 23 May 2020 20:16:47 +0000 (16:16 -0400)
Closes: https://bugs.gentoo.org/724404
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
dev-libs/re2/files/0.2020.05.01-test-memory-budget.patch [new file with mode: 0644]
dev-libs/re2/re2-0.2020.05.01.ebuild

diff --git a/dev-libs/re2/files/0.2020.05.01-test-memory-budget.patch b/dev-libs/re2/files/0.2020.05.01-test-memory-budget.patch
new file mode 100644 (file)
index 0000000..3e62934
--- /dev/null
@@ -0,0 +1,27 @@
+From bde1ea09550a61b4a092cdf0e3ba8dca4200947a Mon Sep 17 00:00:00 2001
+From: Paul Wankadia <junyer@google.com>
+Date: Sun, 10 May 2020 07:12:35 -0700
+Subject: [PATCH] Lower the memory budget in TestCompile.InsufficientMemory.
+
+Fixes #256.
+
+Change-Id: I975c5f6f7a12dc86fedc0f3ab35f16295c18a7e8
+Reviewed-on: https://code-review.googlesource.com/c/re2/+/56150
+Reviewed-by: Paul Wankadia <junyer@google.com>
+---
+ re2/testing/compile_test.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/re2/testing/compile_test.cc b/re2/testing/compile_test.cc
+index 4598aa64..2096e2f0 100644
+--- a/re2/testing/compile_test.cc
++++ b/re2/testing/compile_test.cc
+@@ -236,7 +236,7 @@ TEST(TestCompile, InsufficientMemory) {
+       "^(?P<name1>[^\\s]+)\\s+(?P<name2>[^\\s]+)\\s+(?P<name3>.+)$",
+       Regexp::LikePerl, NULL);
+   EXPECT_TRUE(re != NULL);
+-  Prog* prog = re->CompileToProg(920);
++  Prog* prog = re->CompileToProg(850);
+   // If the memory budget has been exhausted, compilation should fail
+   // and return NULL instead of trying to do anything with NoMatch().
+   EXPECT_TRUE(prog == NULL);
index c0c9da9e15fc598ad36af9fcf226c54f07b9b25f..45f70cb10908d05e2a1a88c4cbec18f0f1c6bd60 100644 (file)
@@ -31,6 +31,9 @@ DOCS=( AUTHORS CONTRIBUTORS README doc/syntax.txt )
 HTML_DOCS=( doc/syntax.html )
 
 src_prepare() {
+       local PATCHES=(
+               "${FILESDIR}"/0.2020.05.01-test-memory-budget.patch
+       )
        default
        grep -q "^SONAME=${SONAME}\$" Makefile || die "SONAME mismatch"
        if use icu; then