dev-libs/gmime: bump to 3.2.7
authorMart Raudsepp <leio@gentoo.org>
Sat, 21 Mar 2020 13:06:48 +0000 (15:06 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sat, 21 Mar 2020 16:22:03 +0000 (18:22 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
dev-libs/gmime/Manifest
dev-libs/gmime/gmime-3.2.7.ebuild [new file with mode: 0644]

index f5cb5653fd979db2c7d9d4ee0584655b2b3a8bff..4297c10e841cab5066875a6f9295ba665a178fa2 100644 (file)
@@ -2,3 +2,4 @@ DIST gmime-2.6.23.tar.xz 5216588 BLAKE2B e173a7dbd418663ebbc55b856359bf9286c3791
 DIST gmime-3.2.4.tar.xz 2219876 BLAKE2B 210941d10dd5c0ce8a638a54a51da9000b4638ae2cc8a37be757fb331c0c2360fc497d7bcf2101ed6bf22de668fe0b779984e83ab40d00d551a5b2971d7a5dcd SHA512 34592e89a2f923dacc37ac535da785918c2c0d6a63b0f2ec1d86393264aace44d1060e8ef4a77e60fd57e97475435f8e79d87e46b269ae332db9b9aaf98bf61b
 DIST gmime-3.2.5.tar.xz 2220348 BLAKE2B 677a5cf88633b0d437a86ed3189399ee9ae4a23704f2b92ba6224e395309bea69cee419e39dde69d14f689df737319946eaed6460cc22c529c18f8d3b68872c6 SHA512 37488da84f1befb37a0dff9465e9f786670dfb7248adbbc1f227dcc0e80bcd4ee7cd239abeab2b52e8ded6ea7f8aa432bcc0461b379282dacd6ee4f867aa049d
 DIST gmime-3.2.6.tar.xz 2225796 BLAKE2B 899762dc74b43273e1cf2f277ca624207a2ef9ac62d09bff5972404c315e5498b1476ea19cf4c8c71fdec99702d9d69ac33bdda33a79d2b3db12840a4f1cd5ed SHA512 a60d3f9f1aa8490865c22cd9539544e9c9f3ceb4037b9749cf9e5c279f97aa88fc4cd077bf2aff314ba0db2a1b7bbe76f9b1ca5a17fffcbd6315ecebc5414a3d
+DIST gmime-3.2.7.tar.xz 2227048 BLAKE2B 7fba57640038f34bd45ecba1067b6db131705310b62a74da1fa3d575993bbc6cc1dce4e3d219dd42033775e0a90f2b2acc86b1094f96f03a7532eae1b69e63ae SHA512 2c8fecd6eb74c9e956c419ce111bef6280916ea3756a534b6b800a273f0fff260717cda7fefd4bd4c6ddb27973112ec6e73fa971fa74bb9aa04cfe587d45f10b
diff --git a/dev-libs/gmime/gmime-3.2.7.ebuild b/dev-libs/gmime/gmime-3.2.7.ebuild
new file mode 100644 (file)
index 0000000..704fb43
--- /dev/null
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+
+inherit flag-o-matic gnome2 vala
+
+DESCRIPTION="Utilities for creating and parsing messages using MIME"
+HOMEPAGE="http://spruce.sourceforge.net/gmime/ https://developer.gnome.org/gmime/stable/"
+
+SLOT="3.0"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="crypt doc idn static-libs test vala"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-libs/glib-2.32.0:2
+       sys-libs/zlib
+       crypt? ( >=app-crypt/gpgme-1.8.0:1= )
+       idn? ( net-dns/libidn2:= )
+       vala? (
+               $(vala_depend)
+               >=dev-libs/gobject-introspection-1.30.0:= )
+"
+DEPEND="${RDEPEND}
+       >=dev-util/gtk-doc-am-1.8
+       virtual/libiconv
+       virtual/pkgconfig
+       doc? ( app-text/docbook-sgml-utils )
+       test? ( app-crypt/gnupg )
+"
+# gnupg is needed for tests if --enable-cryptography is enabled, which we do unconditionally
+
+src_prepare() {
+       gnome2_src_prepare
+       use vala && vala_src_prepare
+}
+
+src_configure() {
+       if [[ ${CHOST} == *-solaris* ]]; then
+               # bug #???, why not use --with-libiconv
+               append-libs iconv
+       fi
+
+       gnome2_src_configure \
+               $(use_enable crypt crypto) \
+               $(use_enable static-libs static) \
+               $(use_enable vala) \
+               $(use_with idn libidn) \
+               $(usex doc "" DB2HTML=)
+}
+
+src_compile() {
+       gnome2_src_compile
+       if use doc; then
+               emake -C docs/tutorial html
+       fi
+}
+
+src_install() {
+       gnome2_src_install
+
+       if use doc ; then
+               docinto tutorial
+               dodoc -r docs/tutorial/html/
+       fi
+}