Revbump the snapshot, and let it depend on rubygems 0.9.0-r1 so to fix bug #143974...
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Wed, 1 Nov 2006 18:00:53 +0000 (18:00 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Wed, 1 Nov 2006 18:00:53 +0000 (18:00 +0000)
Package-Manager: portage-2.1.2_rc1-r2

dev-ruby/ruby-postgres/ChangeLog
dev-ruby/ruby-postgres/files/digest-ruby-postgres-0.7.1.20051221-r1 [new file with mode: 0644]
dev-ruby/ruby-postgres/ruby-postgres-0.7.1.20051221-r1.ebuild [new file with mode: 0644]
dev-ruby/ruby-postgres/ruby-postgres-0.7.1.ebuild

index 89c329acb1e2bf687d552a91a3a3773b05df22b9..0cdd947e1519bf6eb51a782304a4c40ed39b55ad 100644 (file)
@@ -1,6 +1,15 @@
 # ChangeLog for dev-ruby/ruby-postgres
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ChangeLog,v 1.11 2006/08/07 12:00:02 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ChangeLog,v 1.12 2006/11/01 18:00:53 flameeyes Exp $
+
+*ruby-postgres-0.7.1.20051221-r1 (01 Nov 2006)
+
+  01 Nov 2006; Diego Pettenò <flameeyes@gentoo.org>
+  ruby-postgres-0.7.1.ebuild, -ruby-postgres-0.7.1.20051221.ebuild,
+  +ruby-postgres-0.7.1.20051221-r1.ebuild:
+  Revbump the snapshot, and let it depend on rubygems 0.9.0-r1 so to fix bug
+  #143974 for everyone. Also change dependency on libpq rather than full blown
+  postgresql, thanks to Matt Michalowski in bug #153642.
 
 *ruby-postgres-0.7.1.20051221 (07 Aug 2006)
 
diff --git a/dev-ruby/ruby-postgres/files/digest-ruby-postgres-0.7.1.20051221-r1 b/dev-ruby/ruby-postgres/files/digest-ruby-postgres-0.7.1.20051221-r1
new file mode 100644 (file)
index 0000000..c2c6a6e
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 5b53d6baf4c6a73377f1169fbcf7ab54 ruby-postgres-0.7.1.2005.12.21.gem 45568
+RMD160 dcc4c1c8580fa27476e662c791456679e9435ae5 ruby-postgres-0.7.1.2005.12.21.gem 45568
+SHA256 a4dff24a1a2ebb0c34a935e6377cf826a61da03329c8c79a3ea509200759ec7a ruby-postgres-0.7.1.2005.12.21.gem 45568
diff --git a/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.20051221-r1.ebuild b/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.20051221-r1.ebuild
new file mode 100644 (file)
index 0000000..8363f1f
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.20051221-r1.ebuild,v 1.1 2006/11/01 18:00:53 flameeyes Exp $
+
+inherit ruby gems
+
+MY_P=ruby-postgres-0.7.1.2005.12.21.gem
+
+DESCRIPTION="An extension library to access a PostgreSQL database from Ruby"
+HOMEPAGE="http://ruby.scripting.ca/postgres"
+SRC_URI="http://ruby.scripting.ca/postgres/archive/$MY_P"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+USE_RUBY="ruby18"
+
+RDEPEND=">=dev-db/libpq-6.4"
+DEPEND="${RDEPEND}
+       >=dev-ruby/rubygems-0.9.0-r1"
index 24b28f73c27f84171fdf14de4d3451236376a95a..d02a0aea0557f52e27a8a20894a824c4183e35c6 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.ebuild,v 1.12 2006/06/06 16:53:42 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.ebuild,v 1.13 2006/11/01 18:00:53 flameeyes Exp $
 
 inherit ruby
 
@@ -12,4 +12,4 @@ SLOT="0"
 KEYWORDS="alpha amd64 hppa ia64 mips ppc sparc x86 ~x86-fbsd"
 IUSE=""
 USE_RUBY="ruby18"
-DEPEND=">=dev-db/postgresql-6.4"
+DEPEND=">=dev-db/libpq-6.4"