net-misc/socat: Version bump by Marek Behun (bug #607478).
authorJeroen Roovers <jer@gentoo.org>
Sun, 29 Jan 2017 09:33:17 +0000 (10:33 +0100)
committerJeroen Roovers <jer@gentoo.org>
Sun, 29 Jan 2017 09:34:27 +0000 (10:34 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

net-misc/socat/Manifest
net-misc/socat/socat-1.7.3.2.ebuild [new file with mode: 0644]

index 7622d70f75c194adc973dde5b7d30a149db0fb85..3a32dc6c647c8a8d55b2dfd4673a579a94eb6331 100644 (file)
@@ -1,2 +1,3 @@
 DIST socat-1.7.3.1.tar.bz2 488467 SHA256 d2da659540c38139f388e9437bfaae16bb458d174d056cb3228432a8f489fbaa SHA512 463340f578d4d1d54458b8ef9573ad3eff51dbcc736205e1b62e9a4782770d4bb76e6a07506350fd35405b130660559aaa79dfa2664c53ea268d7d64231f9b32 WHIRLPOOL 09f0fc537eaad194cac97cce73971c9f69047c648f03788fa69ac3444673ff73f143b2657d0ed28d082e2cfc36829304ed7bf0ff79c7ed75e96c991292f94dd4
+DIST socat-1.7.3.2.tar.bz2 493324 SHA256 e3561f808739383eb10fada1e5d4f26883f0311b34fd0af7837d0c95ef379251 SHA512 9ed4911deb09c36955b62a2efbcdfdff0e9d963fa30110e32396e49133d395afd7e61a19ca6a1a23e6e98ded4f603bcbb68c8eb3da4ce870f1450b8b6f7dd293 WHIRLPOOL d5b25ee77fd9ac77fd2a0dd33c39ae636cfe380608b8cee0d14f4d2e042bd53f9269edb466ae6c5403ccd5f5e2bff48b5f1ab15504957419f5ec759fc84a84f4
 DIST socat-2.0.0-b9.tar.bz2 516673 SHA256 49efb0a5c66b94b279014addc2851faf8ebbd1ec4b7e31c1de7e912d7b4983d2 SHA512 f728bd634feeeacd2f0e4020c1c6aafdadaef3ba9da818d9ae1195e9f48fb693b2bea8dbbb208af8daddd8d6405217113d5ce31d05c2e9b27f5d2fba6b1cc834 WHIRLPOOL e293f9da0fed9573a02658b79ae87c24e2d88c57f6d8b1ddaeecd52e035b5012eaebbfa82da80f8442da666114d14e1c2767cf929e57b634f762e198ed4e3b50
diff --git a/net-misc/socat/socat-1.7.3.2.ebuild b/net-misc/socat/socat-1.7.3.2.ebuild
new file mode 100644 (file)
index 0000000..8c61f2e
--- /dev/null
@@ -0,0 +1,71 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/"
+MY_P=${P/_beta/-b}
+S="${WORKDIR}/${MY_P}"
+SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="bindist libressl ssl readline ipv6 tcpd"
+
+DEPEND="
+       ssl? (
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl:= )
+       )
+       readline? ( sys-libs/readline:= )
+       tcpd? ( sys-apps/tcp-wrappers )
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test
+       ssl? ( readline? ( bindist ) )"
+
+DOCS=(
+       BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY
+)
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.7.3.0-filan-build.patch
+)
+
+pkg_setup() {
+       # bug #587740
+       if use readline && use ssl; then
+               elog "You are enabling both readline and openssl USE flags, the licenses"
+               elog "for these packages conflict. You may not be able to legally"
+               elog "redistribute the resulting binary."
+       fi
+}
+
+src_prepare() {
+       default
+
+       eautoreconf
+}
+
+src_configure() {
+       filter-flags '-Wno-error*' #293324
+       tc-export AR
+       econf \
+               $(use_enable ssl openssl) \
+               $(use_enable readline) \
+               $(use_enable ipv6 ip6) \
+               $(use_enable tcpd libwrap)
+}
+
+src_install() {
+       default
+
+       docinto html
+       dodoc doc/*.html doc/*.css
+}