dev-python/txrequests: Version bump, adds python-3.8
authorBrian Dolbec <dolsen@gentoo.org>
Fri, 8 May 2020 17:27:23 +0000 (10:27 -0700)
committerBrian Dolbec <dolsen@gentoo.org>
Fri, 8 May 2020 20:34:14 +0000 (13:34 -0700)
metadata.xml: take maintainership

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
dev-python/txrequests/Manifest
dev-python/txrequests/metadata.xml
dev-python/txrequests/txrequests-0.9.6.ebuild [new file with mode: 0644]

index b5adb449064ad9f2585987dff3e75ebc392ac996..2dd55ad38a31e0303b198d82b49f2d959263384b 100644 (file)
@@ -1 +1,2 @@
 DIST txrequests-0.9.5.tar.gz 5265 BLAKE2B e5e3cf66abc394ae5c457b0d5144fdd1d09af5fce651f888bd44f0e48d6d1386fdfd2ca1d350ba1abc856102d051270867a2da96b781fbacf53de01f80158f3d SHA512 e9f527eb2fed0038d7e68b5bd74d0a0e58a1d7cc3e181068423dce871ff10b2d5f1ae92e44248e75b4ad8d44b32366ee9eb6cf8fdd114a562baa6b35fab6eb7b
+DIST txrequests-0.9.6.tar.gz 5306 BLAKE2B c1b55835c360f27c519371834de6cce0760e201a746d960425d7bef98e10cdb421d4db90b93bccdfa05b1fa2d5d6258fea4cce93fe62c7e9ad75780f1a5a89e6 SHA512 3892e121417b8346a2a2db02f8f4143b8f87c060cb4d48dbd07fa77559cfb0caf5742b257377ec0a746f2b995eba36f419a1a5b19d83a0c343cd39057dd34fb1
index 4e91cd94a1af58aa081caa14de666a4230f1d4a0..ebb1ddf6b5d392883933150124251874d3d2c159 100644 (file)
@@ -1,7 +1,10 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-       <!--maintainer-needed-->
+       <maintainer type="project">
+               <email>dolsen@gentoo.org</email>
+               <name>Brian Dolbec</name>
+       </maintainer>
        <upstream>
                <maintainer>
                        <email>tardyp@gmail.com</email>
diff --git a/dev-python/txrequests/txrequests-0.9.6.ebuild b/dev-python/txrequests/txrequests-0.9.6.ebuild
new file mode 100644 (file)
index 0000000..c3e3311
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7,8})
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="Asynchronous Python HTTP for Humans"
+HOMEPAGE="https://github.com/tardyp/txrequests"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       >=dev-python/requests-1.2.0[${PYTHON_USEDEP}]
+       dev-python/twisted[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"