x11-apps/mesa-progs: Sync ebuilds.
authorMatt Turner <mattst88@gentoo.org>
Fri, 28 Aug 2015 23:46:47 +0000 (16:46 -0700)
committerMatt Turner <mattst88@gentoo.org>
Fri, 28 Aug 2015 23:57:44 +0000 (16:57 -0700)
x11-apps/mesa-progs/mesa-progs-8.2.0.ebuild
x11-apps/mesa-progs/mesa-progs-9999.ebuild

index 0b5692dc44bbcaf21a80249ada3c3d246975dda9..81090edea198f1372e3666696a819b8b239374c9 100644 (file)
@@ -19,22 +19,24 @@ DESCRIPTION="Mesa's OpenGL utility and demo programs (glxgears and glxinfo)"
 HOMEPAGE="http://mesa3d.sourceforge.net/"
 if [[ ${PV} == 9999* ]]; then
        SRC_URI=""
+       KEYWORDS=""
 else
        SRC_URI="ftp://ftp.freedesktop.org/pub/${MY_PN/-//}/${PV}/${MY_P}.tar.bz2"
+       KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
 fi
 
 LICENSE="LGPL-2"
 SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
 IUSE="egl gles1 gles2"
 
 RDEPEND="
-       media-libs/freeglut
-       media-libs/glew
        media-libs/mesa[egl?,gles1?,gles2?]
        virtual/opengl
        x11-libs/libX11"
 DEPEND="${RDEPEND}
+       egl? ( media-libs/glew )
+       gles1? ( media-libs/glew )
+       gles2? ( media-libs/glew )
        virtual/glu
        x11-proto/xproto"
 
@@ -49,7 +51,7 @@ src_unpack() {
 src_prepare() {
        base_src_prepare
 
-       eautoreconf
+       [[ $PV = 9999* ]] && eautoreconf
 }
 
 src_compile() {
index 4ecd9ec8818ab0eb82d77b9d7f1a51b934ab9100..657291fc1e391145453f6d271963f1b59241a082 100644 (file)
@@ -30,13 +30,13 @@ SLOT="0"
 IUSE="egl gles1 gles2"
 
 RDEPEND="
-       egl? ( media-libs/glew )
-       gles1? ( media-libs/glew )
-       gles2? ( media-libs/glew )
        media-libs/mesa[egl?,gles1?,gles2?]
        virtual/opengl
        x11-libs/libX11"
 DEPEND="${RDEPEND}
+       egl? ( media-libs/glew )
+       gles1? ( media-libs/glew )
+       gles2? ( media-libs/glew )
        virtual/glu
        x11-proto/xproto"
 
@@ -51,25 +51,11 @@ src_unpack() {
 src_prepare() {
        base_src_prepare
 
-       eautoreconf
-}
-
-src_configure() {
-       # We're not using the complete buildsystem if we only want to build
-       # glxinfo and glxgears.
-       if use egl || use gles1 || use gles2; then
-               default_src_configure
-       fi
+       [[ $PV = 9999* ]] && eautoreconf
 }
 
 src_compile() {
-       if ! use egl && ! use gles1 && ! use gles2; then
-               tc-export CC
-               emake LDLIBS='-lX11 -lGL' src/xdemos/glxinfo
-               emake LDLIBS='-lX11 -lGL -lm' src/xdemos/glxgears
-       else
-               emake -C src/xdemos glxgears glxinfo
-       fi
+       emake -C src/xdemos glxgears glxinfo
 
        if use egl; then
                emake LDLIBS="-lEGL" -C src/egl/opengl/ eglinfo