dev-ros/bondpy: Bump to 1.8.3.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 21 Aug 2018 15:14:59 +0000 (17:14 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 22 Aug 2018 09:31:55 +0000 (11:31 +0200)
Package-Manager: Portage-2.3.48, Repoman-2.3.10

dev-ros/bondpy/Manifest
dev-ros/bondpy/bondpy-1.8.3.ebuild [new file with mode: 0644]

index 5d26e20993a70fc58382539da24ea8e8a9c4f0d2..193fd273b710af91ecd4e18f7f7be32f4ea621c5 100644 (file)
@@ -5,3 +5,4 @@ DIST bond_core-1.7.19.tar.gz 31455 BLAKE2B 86b21d44624c0be8c9445b53d46541785d47f
 DIST bond_core-1.8.0.tar.gz 32199 BLAKE2B 8b5f308c3ff4ee3cf4d969ffa7cc05433ab0b992865a782b9c63d8b27615a158fe1885302703aa357f486ea4409e9e07aa3b43bbef6d41fbd127a8bc2c7252cc SHA512 5519d5366d94403862f34ff16e06ead099a164e43987a113c5ec3d62a8d32430b81fc3bee557513dac05ce6bdb39e6bc3c1a3477573de74610217ea92d373526
 DIST bond_core-1.8.1.tar.gz 32283 BLAKE2B d9d99891507106bff4f4ef7beb80ef878c9ddbbbcb073ea5bbeba11c0d21a7f94dc12a9fc3daea26c4f7585c991bb6283244af8852cee47162185136e0a2d694 SHA512 767d47d7d69bf2a1e6ce5d403f1e0f248c9414998a077f9a0815976975c6ed071eb0338543b9947285b30f5135e410fc273ad4243e5478819286a96e94f4584c
 DIST bond_core-1.8.2.tar.gz 32541 BLAKE2B d2c3000dcd92399f8349f9fbcffbfb432f6f98128365296071ce478c41e9754def757ab26cc89a7e00a0c503ae037792cf494ab53a315fe95de9a56803b2d1ab SHA512 6cb0d5f7af42d1e558772a06ec62a8f31ec8716c72c4d04927301b222de0a67df246e288e777d2ebc9c78000d3bd0c4efe494ea184beb3c906343e83e443c844
+DIST bond_core-1.8.3.tar.gz 32831 BLAKE2B d0c71488436340eff92930006d995ecdd0e98248606b3a6588b36a057584ccc325f751cc170443d21212138bfca2d34c47bd88d4a8a0b719cce81de7bab3218f SHA512 9f9bb71b431199582a36da6ec53806f25fd28fcdfe42e34d60a759f07de98ec86e3f156bc95dc218f3c517e66be426fc30510e111ade9459dfefd74a9555943a
diff --git a/dev-ros/bondpy/bondpy-1.8.3.ebuild b/dev-ros/bondpy/bondpy-1.8.3.ebuild
new file mode 100644 (file)
index 0000000..4440f46
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/bond_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Python implementation of bond, a mechanism for checking when another process has terminated"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/bond[${PYTHON_USEDEP}]
+       dev-ros/rospy[${PYTHON_USEDEP}]
+       dev-ros/smclib
+       sys-apps/util-linux
+"
+DEPEND="${RDEPEND}"