dev-python/pillow: fix broken tests
authorVirgil Dupras <vdupras@gentoo.org>
Wed, 2 Jan 2019 01:36:43 +0000 (20:36 -0500)
committerVirgil Dupras <vdupras@gentoo.org>
Wed, 2 Jan 2019 01:36:43 +0000 (20:36 -0500)
Starting with pytest 3.10, Pillow test suite breaks badly at collect
time. It seems to be related to the way pytest was invoked. Bringing
invocation closer to upstream's, that is, without specifying test unit
files, makes test run alright.

I fixed the invocation in 5.3 and, since 5.2 is already stabilized,
added a version constraint on pytest. The newly bumped v5.4 already has
a correct pytest invocation.

Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-python/pillow/pillow-5.2.0.ebuild
dev-python/pillow/pillow-5.3.0.ebuild

index 5099bb0a2777a642761867823ea2896f3e9aec39..8a22a6354a30358a99380771fefc49462a26a0fe 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -39,7 +39,7 @@ DEPEND="${RDEPEND}
                dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
        )
        test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
+               <dev-python/pytest-3.10[${PYTHON_USEDEP}]
                media-gfx/imagemagick[png]
        )
 "
index d05df3d9e900035aec729f86cb3cfa4374b1d44f..a878b774c31f6d99e8b0831afd7b8a7a448f9846 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -75,7 +75,7 @@ python_compile_all() {
 python_test() {
        "${PYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
        # no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
-       virtx pytest -vx Tests/test_*.py -p no:relaxed
+       virtx pytest -vv -p no:relaxed
 }
 
 python_install() {