x11-wm/metacity: bump to 3.34.1
authorMart Raudsepp <leio@gentoo.org>
Sun, 1 Mar 2020 09:13:49 +0000 (11:13 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sun, 1 Mar 2020 16:17:36 +0000 (18:17 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
x11-wm/metacity/Manifest
x11-wm/metacity/metacity-3.34.1.ebuild [new file with mode: 0644]

index fc14f9aea695a5d0386925b96760de1c8b470f4a..fb5b2559632b45106644a7d8de841ee79fc7cfb7 100644 (file)
@@ -1 +1,2 @@
 DIST metacity-3.32.0.tar.xz 2055388 BLAKE2B c8ed41e44b0a4890129fe7e79e2dcd486c986541c6b19b8873264f2c179b98c17095f19fbd93290ad253571d0c9ae5f5367df1fe1ba2ac68685139680a2e3afd SHA512 2260411b9ab07fcd1aee8152d700f1e2aa7f1f0753cae6dab82a55cac2cac186a5c9f42377a311a6f90a53ba8ba200d9f5d73a770abc76b558896cd58c30abde
+DIST metacity-3.34.1.tar.xz 2055708 BLAKE2B c1bac27f83d26718fa3d02f777a627324efc3e3eaffbf385a84dd97960adc30e84090f511500fe96a4fbbb373da80a38eaba4c5e14910fbcf8783857c0767ef2 SHA512 e9234ad0aee9fe27cf1c2030e31d8f2c292ae2ee2e9b8546ed86e396152faa9dc4cc67fa8321a0c3d3bf577a83bc143111c6ac225f423db243347a6a760695ee
diff --git a/x11-wm/metacity/metacity-3.34.1.ebuild b/x11-wm/metacity/metacity-3.34.1.ebuild
new file mode 100644 (file)
index 0000000..bc7f217
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="GNOME Flashback window manager"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/metacity/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+libcanberra vulkan xinerama"
+KEYWORDS="~amd64"
+
+# TODO: libgtop could be optional, but no knob
+RDEPEND="
+       >=dev-libs/glib-2.44.0:2
+       >=x11-libs/gtk+-3.22.0:3[X]
+       >=x11-libs/pango-1.2.0[X]
+       >=x11-libs/libXcomposite-0.3
+       >=gnome-base/gsettings-desktop-schemas-3.3.0
+       x11-libs/libXfixes
+       x11-libs/libXrender
+       x11-libs/libXdamage
+       libcanberra? ( media-libs/libcanberra[gtk3] )
+       >=x11-libs/startup-notification-0.7
+       x11-libs/libXcursor
+       gnome-base/libgtop:2=
+       x11-libs/libX11
+       xinerama? ( x11-libs/libXinerama )
+       x11-libs/libXrandr
+       x11-libs/libXext
+       x11-libs/libICE
+       x11-libs/libSM
+       gnome-extra/zenity
+       vulkan? ( media-libs/vulkan-loader )
+"
+DEPEND="${RDEPEND}
+       vulkan? ( dev-util/vulkan-headers )
+       dev-util/glib-utils
+       >=sys-devel/gettext-0.19.4
+       x11-base/xorg-proto
+       virtual/pkgconfig
+" # autoconf-archive for eautoreconf
+
+src_configure() {
+       gnome2_src_configure \
+               --disable-static \
+               $(use_enable libcanberra canberra) \
+               $(use_enable xinerama) \
+               $(use_enable vulkan)
+}