dev-python/python-sqlparse: Remove py2
authorMichał Górny <mgorny@gentoo.org>
Fri, 6 Mar 2020 11:54:41 +0000 (12:54 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 6 Mar 2020 12:05:35 +0000 (13:05 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/python-sqlparse/python-sqlparse-0.2.3.ebuild
dev-python/python-sqlparse/python-sqlparse-0.2.4.ebuild
dev-python/python-sqlparse/python-sqlparse-0.3.0.ebuild

index 2a51bb0cf79d8800d7825ab4394384bbfb30d557..3f52bef28aa06d00b56e7b9b04ac3e1a98782681 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python2_7 python3_6 )
+PYTHON_COMPAT=( python3_6 )
 
 inherit distutils-r1
 
@@ -17,14 +17,11 @@ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
 SLOT="0"
 KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
 LICENSE="BSD-2"
-IUSE="doc test"
+IUSE="test"
 RESTRICT="!test? ( test )"
 
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
-
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
        test? (
                dev-python/pytest[${PYTHON_USEDEP}]
                dev-python/pytest-cov[${PYTHON_USEDEP}]
@@ -34,14 +31,6 @@ DISTUTILS_IN_SOURCE_BUILD=1
 
 S="${WORKDIR}"/${P#python-}
 
-pkg_setup() {
-       use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
-}
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
 python_test() {
        if python_is_python3; then
                2to3 -w --no-diffs -n tests/ sqlparse/
@@ -50,8 +39,3 @@ python_test() {
                py.test tests || die "testsuite failed under ${EPYTHON}"
        fi
 }
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/build/html/. )
-       distutils-r1_python_install_all
-}
index 3216f5eb6d67e430aa6e7715cc09784ef140fe27..36f895a3d44eb0a2923a4770742079e351498a49 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
 
 inherit distutils-r1
 
@@ -17,14 +17,11 @@ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
 SLOT="0"
 KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
 LICENSE="BSD-2"
-IUSE="doc test"
+IUSE="test"
 RESTRICT="!test? ( test )"
 
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
-
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
        test? (
                dev-python/pytest[${PYTHON_USEDEP}]
                dev-python/pytest-cov[${PYTHON_USEDEP}]
@@ -34,14 +31,6 @@ DISTUTILS_IN_SOURCE_BUILD=1
 
 S="${WORKDIR}"/${P#python-}
 
-pkg_setup() {
-       use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
-}
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
 python_test() {
        if python_is_python3; then
                2to3 -w --no-diffs -n tests/ sqlparse/
@@ -50,8 +39,3 @@ python_test() {
                py.test tests || die "testsuite failed under ${EPYTHON}"
        fi
 }
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/build/html/. )
-       distutils-r1_python_install_all
-}
index a0839ec0c23b1d75022922c156a422461739b175..33092e587e3cb2b9d4f66397cc68ae8dcd75abbf 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8} )
 inherit distutils-r1
 
 MY_PN="${PN##python-}"