dev-ml/ppx_fields_conv: initial import; ebuild by me
authorAlexis Ballier <aballier@gentoo.org>
Fri, 5 Feb 2016 18:12:16 +0000 (19:12 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 5 Feb 2016 20:59:02 +0000 (21:59 +0100)
Package-Manager: portage-2.2.27
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ml/ppx_fields_conv/Manifest [new file with mode: 0644]
dev-ml/ppx_fields_conv/metadata.xml [new file with mode: 0644]
dev-ml/ppx_fields_conv/ppx_fields_conv-113.24.00.ebuild [new file with mode: 0644]

diff --git a/dev-ml/ppx_fields_conv/Manifest b/dev-ml/ppx_fields_conv/Manifest
new file mode 100644 (file)
index 0000000..395c38e
--- /dev/null
@@ -0,0 +1 @@
+DIST ppx_fields_conv-113.24.00.tar.gz 59020 SHA256 ac77d3db7dafe877713f309bbc991a9c7dbc80a10184e395c1e11bee3b120028 SHA512 6f68be7001cc3a6e95b6ce5e098ba99bea17febf1f39ef1d12e51c5514a1b73a9115fb69ab0c990312394fcd13f141158f9ea1388e1f96239a64629e5369e972 WHIRLPOOL 4dd5bb25def6d9e3025852963f668c4a43c69345e4ab4111593049ee4b98cce5f5f5ded9453d1457a687e7b1c31bfde48bb231b5b9af2ae85928fb494d5e1d16
diff --git a/dev-ml/ppx_fields_conv/metadata.xml b/dev-ml/ppx_fields_conv/metadata.xml
new file mode 100644 (file)
index 0000000..ffac4d7
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+       <email>ml@gentoo.org</email>
+       <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ppx_fields_conv/ppx_fields_conv-113.24.00.ebuild b/dev-ml/ppx_fields_conv/ppx_fields_conv-113.24.00.ebuild
new file mode 100644 (file)
index 0000000..67db485
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="Generation of accessor and iteration functions for ocaml records"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+       dev-ml/ppx_tools:=
+       dev-ml/ppx_core:=
+       dev-ml/ppx_type_conv:=
+       dev-ml/fieldslib:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+       emake setup.exe
+       OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+       emake
+}
+
+src_install() {
+       opam-installer -i \
+               --prefix="${ED}/usr" \
+               --libdir="${D}/$(ocamlc -where)" \
+               --docdir="${ED}/usr/share/doc/${PF}" \
+               ${PN}.install || die
+       dodoc CHANGES.md
+}