dev-util/meson: 0.52.0 version bump
authorWilliam Hubbs <williamh@gentoo.org>
Sat, 19 Oct 2019 21:29:20 +0000 (16:29 -0500)
committerWilliam Hubbs <williamh@gentoo.org>
Sat, 19 Oct 2019 22:32:22 +0000 (17:32 -0500)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: William Hubbs <williamh@gentoo.org>
dev-util/meson/Manifest
dev-util/meson/meson-0.52.0.ebuild [new file with mode: 0644]

index 360ff9f5d8aa8384b24d2ed7e0b3ca9569ecba6e..09ec6d8a1e12b33b29b445663a7fe42a84cb23e2 100644 (file)
@@ -1,2 +1,3 @@
 DIST meson-0.51.1.tar.gz 1451234 BLAKE2B 8a925bfa3d622f75eb180226311a6531cde435a5a6573663f44ba67dbefa63f76b8bd17eb23d291594fe66a379ebc8aef5f1e680973a59b0b52c41fe09e4cdcf SHA512 535fb7c73a7e721a25ce4a0b9771bbb2c07fcd8f7b8f43542a093663291761370044f99b9109853b19201189881e64db1ba5a67c724ecff21000b22ca79f182c
 DIST meson-0.51.2.tar.gz 1453328 BLAKE2B 514995ba8db534ecd488e99fb1aed25d33de73ca65fdfaf18584bd8c113eca3602a73ac42f2ae5ddd4362f8989a02d3d3aa75487ba665706c75039e3f039056c SHA512 332fa0801accd91dc8f3cc1e4e701b1139fdb17c4ae8371fab419e83305ef41534e5f367fbd9323936afb6912d5c3e7cffa9cef658550fad0861ccca9812d5b0
+DIST meson-0.52.0.tar.gz 1507218 BLAKE2B d3d869cf4a992ba89f150960ed742ac5da2b63b60a3583f2c4c7cce1e2a86f5101a90a05f59000af70c7ada00c119268df87aaadc55ccee50b85c24e308c1d5c SHA512 b32206c5499580a74bb5442d21263b5328cc3302c3226452fb3a2434fdcf55d5fc16fc841102b09a85abc19dbd00e836a571f917833ef3d726d84524f89b2e1c
diff --git a/dev-util/meson/meson-0.52.0.ebuild b/dev-util/meson/meson-0.52.0.ebuild
new file mode 100644 (file)
index 0000000..6a59a76
--- /dev/null
@@ -0,0 +1,79 @@
+# Copyright 2016-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+if [[ ${PV} = *9999* ]]; then
+       EGIT_REPO_URI="https://github.com/mesonbuild/meson"
+       inherit git-r3
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+fi
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Open source build system"
+HOMEPAGE="http://mesonbuild.com/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       test? (
+               dev-libs/glib:2
+               dev-libs/gobject-introspection
+               dev-util/ninja
+               dev-vcs/git
+               sys-libs/zlib[static-libs(+)]
+               virtual/pkgconfig
+       )
+"
+
+python_prepare_all() {
+       # ASAN and sandbox both want control over LD_PRELOAD
+       # https://bugs.gentoo.org/673016
+       sed -i -e 's/test_generate_gir_with_address_sanitizer/_&/' run_unittests.py || die
+
+       # ASAN is unsupported on some targets
+       # https://bugs.gentoo.org/692822
+       sed -i -e 's/test_pch_with_address_sanitizer/_&/' run_unittests.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+src_test() {
+       tc-export PKG_CONFIG
+       if ${PKG_CONFIG} --exists Qt5Core && ! ${PKG_CONFIG} --exists Qt5Gui; then
+               ewarn "Found Qt5Core but not Qt5Gui; skipping tests"
+       else
+               # https://bugs.gentoo.org/687792
+               unset PKG_CONFIG
+               distutils-r1_src_test
+       fi
+}
+
+python_test() {
+       (
+               # test_meson_installed
+               unset PYTHONDONTWRITEBYTECODE
+
+               # test_cross_file_system_paths
+               unset XDG_DATA_HOME
+
+               ${EPYTHON} -u run_tests.py
+       ) || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       insinto /usr/share/vim/vimfiles
+       doins -r data/syntax-highlighting/vim/{ftdetect,indent,syntax}
+       insinto /usr/share/zsh/site-functions
+       doins data/shell-completions/zsh/_meson
+}