net-print/hplip-plugin: Remove old hplip-plugin-3.19.6.
authorDaniel Pielmeier <billie@gentoo.org>
Sun, 15 Dec 2019 18:13:01 +0000 (19:13 +0100)
committerDaniel Pielmeier <billie@gentoo.org>
Sun, 15 Dec 2019 18:13:32 +0000 (19:13 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
net-print/hplip-plugin/Manifest
net-print/hplip-plugin/hplip-plugin-3.19.6.ebuild [deleted file]

index 502a2cd7987714f902468aeb9ebbf9ff98dba62c..107899dd02df48f36c654ba01bfcf950906192fe 100644 (file)
@@ -1,3 +1,2 @@
 DIST hplip-3.18.12-plugin.run 10486821 BLAKE2B e48940b1b5fe94dc216383b63bee7807bce9ad265b7c454c201c0ed22ec1964e6c5adf653c3c230789c042cffaaf50bd604bae6f66f407a85f98248934307158 SHA512 82b90aa8245f787e088a1bebfa7892a7f2b97fd04b3702c46eed27306640e562aeec63b4b5b45c24943abe4672f2627d1821bdcdf58a5c1ac4e1d06c7270535f
 DIST hplip-3.19.11-plugin.run 11517119 BLAKE2B d7eefde4e579abbb019cfbb5bf7541360884b0d18240c87c0b532981ad3542a60dae139a623db0eaee3057d6fb5e805287ad5bddb2ec87df5b85ffd604f748f4 SHA512 9ef568aa297eb58370e7f01e54d83c53fbfb02494a0f4cfa3b9f92fd11bfae7b9f54d60516d5cf0436a882864505aab68f70b462b820e918a6ad4104987c9295
-DIST hplip-3.19.6-plugin.run 11517158 BLAKE2B c44707e29b104b45c110729c70ebeba1f392ad753eb98d8677657f735e547cdecfab357b348a30545274b51c18249ddb9102df49aa73d726a8e9145a302a8a0c SHA512 3636d655ba289331572f0762a5de2e0bf2f3108ac3f7ca9cb8bbec126942be954fe9c07c882bd8272e30ac46d67231d86a3c4249a6fe31e2d3e8d5e568bbbd8b
diff --git a/net-print/hplip-plugin/hplip-plugin-3.19.6.ebuild b/net-print/hplip-plugin/hplip-plugin-3.19.6.ebuild
deleted file mode 100644 (file)
index b497f4a..0000000
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit unpacker
-
-DESCRIPTION="Proprietary plugins and firmware for HPLIP"
-HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing/plugins"
-SRC_URI="https://developers.hp.com/sites/default/files/hplip-${PV}-plugin.run"
-LICENSE="hplip-plugin"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-RDEPEND="
-       ~net-print/hplip-${PV}
-       virtual/libusb:0
-       virtual/udev
-"
-DEPEND=""
-
-S=${WORKDIR}
-
-HPLIP_HOME=/usr/share/hplip
-
-# Binary prebuilt package
-QA_PRESTRIPPED="
-       /usr/share/hplip/fax/plugins/fax_marvell.so
-       /usr/share/hplip/prnt/plugins/hbpl1.so
-       /usr/share/hplip/prnt/plugins/lj.so
-       /usr/share/hplip/scan/plugins/bb_escl.so
-       /usr/share/hplip/scan/plugins/bb_marvell.so
-       /usr/share/hplip/scan/plugins/bb_soapht.so
-       /usr/share/hplip/scan/plugins/bb_soap.so
-"
-
-# License does not allow us to redistribute the "source" package
-RESTRICT="mirror"
-
-src_install() {
-       local hplip_arch
-       case "${ARCH}" in
-               amd64) hplip_arch="x86_64" ;;
-               arm)   hplip_arch="arm32"  ;;
-               x86)   hplip_arch="x86_32" ;;
-               *)     die "Unsupported architecture." ;;
-       esac
-
-       insinto "${HPLIP_HOME}"/data/firmware
-       doins *.fw.gz
-
-       for plugin in *-${hplip_arch}.so; do
-               local plugin_type=prnt
-               case "${plugin}" in
-                       fax_*) plugin_type=fax ;;
-                       bb_*)  plugin_type=scan ;;
-               esac
-
-               exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
-               newexe ${plugin} ${plugin/-${hplip_arch}}
-       done
-
-       insinto /var/lib/hp
-       newins - hplip.state <<-_EOF_
-               [plugin]
-               installed = 1
-               eula = 1
-               version = ${PV}
-       _EOF_
-}