Initial import. Ebuild by squinky86.
authorJeremy Huddleston <eradicator@gentoo.org>
Wed, 31 Mar 2004 02:36:58 +0000 (02:36 +0000)
committerJeremy Huddleston <eradicator@gentoo.org>
Wed, 31 Mar 2004 02:36:58 +0000 (02:36 +0000)
app-accessibility/speech-dispatcher/ChangeLog [new file with mode: 0644]
app-accessibility/speech-dispatcher/Manifest [new file with mode: 0644]
app-accessibility/speech-dispatcher/files/digest-speech-dispatcher-0.2 [new file with mode: 0644]
app-accessibility/speech-dispatcher/files/speech-dispatcher [new file with mode: 0644]
app-accessibility/speech-dispatcher/files/speech-dispatcher-0.2-gentoo.patch [new file with mode: 0644]
app-accessibility/speech-dispatcher/metadata.xml [new file with mode: 0644]
app-accessibility/speech-dispatcher/speech-dispatcher-0.2.ebuild [new file with mode: 0644]

diff --git a/app-accessibility/speech-dispatcher/ChangeLog b/app-accessibility/speech-dispatcher/ChangeLog
new file mode 100644 (file)
index 0000000..7f226f9
--- /dev/null
@@ -0,0 +1,11 @@
+# ChangeLog for app-accessibility/speech-dispatcher
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.1 2004/03/31 02:36:58 eradicator Exp $
+
+*speech-dispatcher-0.2 (30 Mar 2004)
+
+  30 Mar 2004; Jeremy Huddleston <eradicator@gentoo.org> metadata.xml,
+  speech-dispatcher-0.2.ebuild, files/speech-dispatcher,
+  files/speech-dispatcher-0.2-gentoo.patch:
+  Initial import.  Ebuild by squinky86.
+
diff --git a/app-accessibility/speech-dispatcher/Manifest b/app-accessibility/speech-dispatcher/Manifest
new file mode 100644 (file)
index 0000000..ffea8ee
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 ae838acbf96dc2a4a1376190f6771602 speech-dispatcher-0.2.ebuild 1287
+MD5 01eec208b334f4f8fae94b2c9139041e ChangeLog 507
+MD5 4f5d797c455932135181f0c31b5e71b2 metadata.xml 185
+MD5 078d5c317522b72b8d9aa82719ee3440 files/digest-speech-dispatcher-0.2 63
+MD5 6dc3b85b3d0bdff46846556206bbded1 files/speech-dispatcher-0.2-gentoo.patch 2251
+MD5 b1422164fb3fc4a49877739ada363aa4 files/speech-dispatcher 664
diff --git a/app-accessibility/speech-dispatcher/files/digest-speech-dispatcher-0.2 b/app-accessibility/speech-dispatcher/files/digest-speech-dispatcher-0.2
new file mode 100644 (file)
index 0000000..5031a08
--- /dev/null
@@ -0,0 +1 @@
+MD5 3671404d27c211e70f5411ca9ed7bf09 speechd-0.2.tar.gz 739792
diff --git a/app-accessibility/speech-dispatcher/files/speech-dispatcher b/app-accessibility/speech-dispatcher/files/speech-dispatcher
new file mode 100644 (file)
index 0000000..a32f5e1
--- /dev/null
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/files/speech-dispatcher,v 1.1 2004/03/31 02:36:58 eradicator Exp $
+
+depend() {
+       use alsasound esound festival speechd
+}
+
+start() {
+       ebegin "Starting speech-dispatcher"
+       start-stop-daemon --start --quiet --background --exec /usr/bin/speech-dispatcher -- -d
+       eend $?
+}
+
+stop() {
+       ebegin "Stopping speech-dispatcher"
+       start-stop-daemon --stop --quiet --pidfile /var/run/speech-dispatcher.pid
+       eend $?
+}
+
+restart() {
+       svc_stop || die
+       sleep 1
+       svc_start || die
+}
diff --git a/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.2-gentoo.patch b/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.2-gentoo.patch
new file mode 100644 (file)
index 0000000..8d3ca0b
--- /dev/null
@@ -0,0 +1,55 @@
+diff -Naur speechd-0.2.vanilla/config/speechd.conf.in speechd-0.2/config/speechd.conf.in
+--- speechd-0.2.vanilla/config/speechd.conf.in 2003-10-08 16:26:43.000000000 -0500
++++ speechd-0.2/config/speechd.conf.in 2004-03-30 19:09:14.133265136 -0600
+@@ -28,7 +28,7 @@
+ # Specify "stdout" for standard console output
+ # or a full path to some file which the log should be written to.
+-LogFile  "/var/log/speechd.log"
++LogFile  "/var/log/speech-dispatcher.log"
+ #LogFile  "stdout"
+ # CustomLogFile allows logging all messages of the given kind, regardless their
+@@ -164,5 +164,5 @@
+ # it should apply this settings (it does glob-style matching, you can use
+ # * to match any number of characters and ? to match one character)
+-# Include "clients/emacs.conf"
++Include "clients/emacs.conf"
+diff -Naur speechd-0.2.vanilla/configure.in speechd-0.2/configure.in
+--- speechd-0.2.vanilla/configure.in   2003-10-29 14:50:15.000000000 -0600
++++ speechd-0.2/configure.in   2004-03-30 19:08:00.153511768 -0600
+@@ -46,13 +46,13 @@
+ AC_SUBST(glib_include)
+ glib_libs=`pkg-config --libs glib-2.0`
+ AC_SUBST(glib_libs)
+-spdconfdir="$sysconfdir/speechd" 
++spdconfdir="$sysconfdir/speech-dispatcher" 
+ AC_SUBST(spdconfdir)
+-snddatadir="$datadir/sounds/speechd" 
++snddatadir="$datadir/sounds/speech-dispatcher" 
+ AC_SUBST(snddatadir)
+-modulebindir="$bindir/speechd-modules/" 
++modulebindir="$libdir/speech-dispatcher-modules/" 
+ AC_SUBST(modulebindir)
+-moduleconfdir="$sysconfdir/speechd/modules/" 
++moduleconfdir="$sysconfdir/speech-dispatcher/modules/" 
+ AC_SUBST(moduleconfdir)
+ AC_ARG_VAR(pidpath, Absolute path to a pid file)
+diff -Naur speechd-0.2.vanilla/src/server/speechd.c speechd-0.2/src/server/speechd.c
+--- speechd-0.2.vanilla/src/server/speechd.c   2003-10-15 16:03:05.000000000 -0500
++++ speechd-0.2/src/server/speechd.c   2004-03-30 19:08:00.155511464 -0600
+@@ -598,9 +598,9 @@
+     options_parse(argc, argv);
+     if (!strcmp(PIDPATH, ""))
+-        speechd_pid_file = strdup("/var/run/speechd.pid");
++        speechd_pid_file = strdup("/var/run/speech-dispatcher.pid");
+     else
+-        speechd_pid_file = strdup(PIDPATH"speechd.pid");
++        speechd_pid_file = strdup(PIDPATH"speech-dispatcher.pid");
+     if (create_pid_file() == -1) exit(1);
diff --git a/app-accessibility/speech-dispatcher/metadata.xml b/app-accessibility/speech-dispatcher/metadata.xml
new file mode 100644 (file)
index 0000000..523097f
--- /dev/null
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>accessibility</herd>
+<herd>sound</herd>
+</pkgmetadata>
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.2.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.2.ebuild
new file mode 100644 (file)
index 0000000..e6a33f4
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.2.ebuild,v 1.1 2004/03/31 02:36:58 eradicator Exp $
+
+inherit eutils libtool
+
+MY_PN="speechd"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="speech-dispatcher speech synthesis interface"
+HOMEPAGE="http://www.freebsoft.org/speechd"
+SRC_URI="http://www.freebsoft.org/pub/projects/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="dev-libs/dotconf
+       >=app-accessibility/flite-1.2
+       >=dev-libs/glib-2
+       media-libs/alsa-lib"
+
+DEPEND="${RDEPEND}
+       >=sys-devel/automake-1.7.8
+       >=sys-devel/autoconf-2.58"
+
+src_unpack() {
+       unpack ${A}
+
+       cd ${S}
+       export WANT_AUTOMAKE=1.7
+       export WANT_AUTOCONF=2.5
+
+       epatch ${FILESDIR}/speech-dispatcher-${PV}-gentoo.patch
+       autoreconf || die "Could not update configure script with autoconf/automake"
+       elibtoolize
+}
+
+src_install() {
+       make DESTDIR=${D} install || die
+
+       mv ${D}/usr/bin/speechd ${D}/usr/bin/speech-dispatcher
+
+       exeinto /etc/init.d
+       doexe ${FILESDIR}/speech-dispatcher
+}
+
+pkg_postinst() {
+       echo
+       einfo "To enable Festival support, you must install app-accessibility/festival-freebsoft-utils."
+       echo
+}