dev-embedded/platformio: New package
authorAlexey Shvetsov <alexxy@gentoo.org>
Thu, 14 Jun 2018 14:11:24 +0000 (17:11 +0300)
committerAlexey Shvetsov <alexxy@gentoo.org>
Thu, 14 Jun 2018 14:11:24 +0000 (17:11 +0300)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-embedded/platformio/Manifest [new file with mode: 0644]
dev-embedded/platformio/metadata.xml [new file with mode: 0644]
dev-embedded/platformio/platformio-3.5.3.ebuild [new file with mode: 0644]

diff --git a/dev-embedded/platformio/Manifest b/dev-embedded/platformio/Manifest
new file mode 100644 (file)
index 0000000..c7287f7
--- /dev/null
@@ -0,0 +1 @@
+DIST platformio-3.5.3.tar.gz 96791 BLAKE2B 4b17ccec4a192704cbd185ed42eb6214cfa54a072f6d089f96c608eec7815bd3046b12f7e84355055b5026600b22c4f1c720b12caea4e281479d4c381fe8ec4f SHA512 4c5b5b0a0c4d6942f91ffcb4317149cdbdba857f17b07ad3f47db9abd97615eafbd310d0f1a2c389b485922af1df6f3a6d7831bce1f92a53540b00998c859247
diff --git a/dev-embedded/platformio/metadata.xml b/dev-embedded/platformio/metadata.xml
new file mode 100644 (file)
index 0000000..086586c
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>alexxy@gentoo.org</email>
+               <name>Alexey Shvetsov</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/dev-embedded/platformio/platformio-3.5.3.ebuild b/dev-embedded/platformio/platformio-3.5.3.ebuild
new file mode 100644 (file)
index 0000000..4aa6907
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="An open source ecosystem for IoT development"
+HOMEPAGE="http://platformio.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+       >=dev-python/semantic_version-2.5.0[${PYTHON_USEDEP}]
+       >=dev-python/pyserial-3[${PYTHON_USEDEP}]
+       <dev-python/pyserial-4[${PYTHON_USEDEP}]
+       >=dev-python/lockfile-0.9.1[${PYTHON_USEDEP}]
+       <dev-python/lockfile-0.13[${PYTHON_USEDEP}]
+       dev-python/colorama[${PYTHON_USEDEP}]
+       >=dev-python/click-5[${PYTHON_USEDEP}]
+       <dev-python/click-6[${PYTHON_USEDEP}]
+       <dev-python/bottle-0.13[${PYTHON_USEDEP}]
+       <dev-python/arrow-1[${PYTHON_USEDEP}]"