app-vim/locateopen: EAPI 6 bump.
authorPatrice Clement <monsieurp@gentoo.org>
Wed, 29 Jun 2016 11:14:50 +0000 (11:14 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Wed, 29 Jun 2016 11:20:39 +0000 (11:20 +0000)
Package-Manager: portage-2.2.28

app-vim/locateopen/locateopen-1.3-r1.ebuild [new file with mode: 0644]

diff --git a/app-vim/locateopen/locateopen-1.3-r1.ebuild b/app-vim/locateopen/locateopen-1.3-r1.ebuild
new file mode 100644 (file)
index 0000000..1426846
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: open a file without supplying a path"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=858"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="${RDEPEND} sys-apps/mlocate"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides commands that hook vim into mlocate:
+\    :LocateEdit   filename
+\    :LocateSplit  filename
+\    :LocateSource filename
+\    :LocateRead   filename
+To configure:
+\    :let g:locateopen_ignorecase = 1    \" enable ignore case mode
+\    :let g:locateopen_smartcase = 0     \" disable smart case mode
+\    :let g:locateopen_alwaysprompt = 1  \" show menu for one match"