media-plugins/ir_lv2: version bump to 1.3.4
authorAlexander Tsoy <alexander@tsoy.me>
Thu, 6 Jun 2019 18:44:57 +0000 (21:44 +0300)
committerMiroslav Šulc <fordfrog@gentoo.org>
Wed, 25 Dec 2019 12:26:13 +0000 (13:26 +0100)
Closes: https://bugs.gentoo.org/417395
Closes: https://bugs.gentoo.org/655968
Signed-off-by: Alexander Tsoy <alexander@tsoy.me>
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
media-plugins/ir_lv2/Manifest
media-plugins/ir_lv2/files/ir_lv2-1.3.4-respect-flags.patch [new file with mode: 0644]
media-plugins/ir_lv2/ir_lv2-1.3.4.ebuild [new file with mode: 0644]
media-plugins/ir_lv2/metadata.xml

index 0ea65b36980f59d01fc2682ba78855c54e79dc99..d4129a6338cea8f449dde41f93ad35ebfd88548b 100644 (file)
@@ -1 +1,2 @@
 DIST ir.lv2-1.3.2.tar.gz 48698 BLAKE2B 2587fb8cae6d71c8a2e3586eaddba43f27282db2469a64f2441832c52f9f27ff9d0852acfce248b890ed4845281f4ef676581128321102e0fc655d0a91bb1266 SHA512 06443aeab05eaa0b1ff5c12fd479c3f1c874976a6d1f5874f6d150aa97c96a8a0b2c3abbc7d6db4882f5674aad8e53ab32bbe7da3873746d5a1e581d010bbae2
+DIST ir_lv2-1.3.4.tar.gz 126552 BLAKE2B 52f5b236c4680a759c0621ed0f9a394e6e82bdb9aaf4110b325902ae382d2f640a079c53d89c662a192a97d0e79349082cf100636c1a7d6c00738602ca652962 SHA512 6a9c8f906a07c6ed0daa53d8dc3693d535ec4cf63f07b5fcc62ab6638c66992ff7951918b0ce2ef8c65289b19988363be49bba9bb75a20b0463fa972b07ff58c
diff --git a/media-plugins/ir_lv2/files/ir_lv2-1.3.4-respect-flags.patch b/media-plugins/ir_lv2/files/ir_lv2-1.3.4-respect-flags.patch
new file mode 100644 (file)
index 0000000..cd664a6
--- /dev/null
@@ -0,0 +1,21 @@
+diff -urpN ir.lv2-1.3.4.orig/Makefile ir.lv2-1.3.4/Makefile
+--- ir.lv2-1.3.4.orig/Makefile 2018-06-21 11:14:03.000000000 +0300
++++ ir.lv2-1.3.4/Makefile      2019-12-24 16:26:06.102495896 +0300
+@@ -20,7 +20,7 @@ CC ?= gcc
+ CXX ?= g++
+ # change "-O2 -ffast-math" to "-g -O0" below if you want to debug the plugin
+-CPPFLAGS += -Wall -I. -I/usr/include `pkg-config --cflags gtk+-2.0` `pkg-config --cflags gthread-2.0` -D__STDC_FORMAT_MACROS -O2 -ffast-math
++CPPFLAGS += -Wall -I. -I/usr/include `pkg-config --cflags gtk+-2.0` `pkg-config --cflags gthread-2.0` -D__STDC_FORMAT_MACROS -ffast-math
+ LIBS += -lc -lm -lzita-convolver -lsamplerate -lsndfile `pkg-config --libs gthread-2.0` `pkg-config --libs gtk+-2.0`
+ ifeq ($(shell pkg-config --atleast-version='2.16' gtk+-2.0; echo $$?), 1)
+@@ -31,7 +31,7 @@ ifeq ($(shell pkg-config --atleast-versi
+    CPPFLAGS += -D_HAVE_GTK_ATLEAST_2_20
+ endif
+-C4CFLAGS = -Wall -I. -I/usr/include `pkg-config --cflags gthread-2.0` -O2 -ffast-math
++C4CFLAGS = -Wall -I. -I/usr/include `pkg-config --cflags gthread-2.0` -ffast-math
+ C4LIBS = -lsndfile `pkg-config --libs gthread-2.0`
+ all: ir.so ir_gui.so
diff --git a/media-plugins/ir_lv2/ir_lv2-1.3.4.ebuild b/media-plugins/ir_lv2/ir_lv2-1.3.4.ebuild
new file mode 100644 (file)
index 0000000..84fbbef
--- /dev/null
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs flag-o-matic multilib
+
+DESCRIPTION="LV2 convolver plugin especially for creating reverb effects"
+HOMEPAGE="https://tomszilagyi.github.io/plugins/ir.lv2/"
+SRC_URI="https://github.com/tomszilagyi/ir.lv2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S=${WORKDIR}/${PN/_/.}-${PV}
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="tools"
+
+RDEPEND="media-libs/libsamplerate
+       media-libs/libsndfile
+       media-libs/lv2
+       >=media-libs/zita-convolver-3:=
+       >=x11-libs/gtk+-2.16:2"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.3.4-respect-flags.patch
+)
+
+DOCS=( README.md sshot.png ChangeLog )
+
+src_compile() {
+       tc-export CC CXX
+       emake
+       use tools && emake convert4chan
+}
+
+src_install() {
+       emake INSTDIR="${D}/usr/$(get_libdir)/lv2" install
+       use tools && newbin convert4chan ir_convert4chan
+       einstalldocs
+}
+
+pkg_postinst() {
+       local latency_warn=0
+       local ver
+
+       if [[ -z ${REPLACING_VERSIONS} ]]; then
+               latency_warn=1
+       else
+               for ver in ${REPLACING_VERSIONS}; do
+                       if ver_test ${ver} -lt 1.3.0; then
+                               latency_warn=1
+                               break
+                       fi
+               done
+       fi
+
+       if [[ ${latency_warn} -eq 1 ]]; then
+               elog "This version works with automation at the expense of introducing extra buffering."
+               elog "For zero latency use 1.2* version instead."
+       fi
+}
index f79bb67acbd9bbd9e28b08f8c90ea42dd5a22a03..8632ae7d47f47a2e74f3f9bf8733416a018ca87a 100644 (file)
@@ -5,4 +5,7 @@
        <email>proaudio@gentoo.org</email>
        <name>Gentoo ProAudio Project</name>
 </maintainer>
+<use>
+       <flag name="tools">Build convert4chan tool</flag>
+</use>
 </pkgmetadata>