sys-kernel/linux-headers: EAPI=6: use eapply (didnt find epatch before!)
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Wed, 3 Oct 2018 21:32:50 +0000 (23:32 +0200)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Wed, 3 Oct 2018 21:33:11 +0000 (23:33 +0200)
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Package-Manager: Portage-2.3.50, Repoman-2.3.11

sys-kernel/linux-headers/linux-headers-4.14-r1.ebuild [moved from sys-kernel/linux-headers/linux-headers-4.14.ebuild with 92% similarity]
sys-kernel/linux-headers/linux-headers-4.15-r1.ebuild [moved from sys-kernel/linux-headers/linux-headers-4.15.ebuild with 92% similarity]
sys-kernel/linux-headers/linux-headers-4.16-r2.ebuild [moved from sys-kernel/linux-headers/linux-headers-4.16-r1.ebuild with 93% similarity]

similarity index 92%
rename from sys-kernel/linux-headers/linux-headers-4.14.ebuild
rename to sys-kernel/linux-headers/linux-headers-4.14-r1.ebuild
index 3f0f236b112e2cf818bf062bb7c3d8cb8958b566..48f732fede33bd0e6ea81c34800a12c9d074e282 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -27,7 +27,7 @@ src_unpack() {
 src_prepare() {
        default
 
-       [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/${PV}
+       [[ -n ${PATCH_VER} ]] && eapply "${WORKDIR}/${PV}"/*.patch
 }
 
 src_install() {
similarity index 92%
rename from sys-kernel/linux-headers/linux-headers-4.15.ebuild
rename to sys-kernel/linux-headers/linux-headers-4.15-r1.ebuild
index e85428405f31ec5d6a8563cfefbff583d06c031f..40da92cde1f3fa2c106f115da28aa6a2aa920e9d 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -27,7 +27,7 @@ src_unpack() {
 src_prepare() {
        default
 
-       [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/${PV}
+       [[ -n ${PATCH_VER} ]] && eapply "${WORKDIR}/${PV}"/*.patch
 }
 
 src_install() {
similarity index 93%
rename from sys-kernel/linux-headers/linux-headers-4.16-r1.ebuild
rename to sys-kernel/linux-headers/linux-headers-4.16-r2.ebuild
index 2a419772a98e587f603dd23a7e1cccb6b5a2d9b2..a8906fa89407ec647040dbd71ef805ce87e73bdb 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -30,7 +30,7 @@ src_unpack() {
 src_prepare() {
        default
 
-       [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/${PV}
+       [[ -n ${PATCH_VER} ]] && eapply "${WORKDIR}/${PV}"/*.patch
 }
 
 src_install() {