gnome-base/gvfs: elogind support, mtp unmount fix, other upstream patches
authorMart Raudsepp <leio@gentoo.org>
Mon, 8 Jan 2018 16:14:32 +0000 (18:14 +0200)
committerMart Raudsepp <leio@gentoo.org>
Mon, 8 Jan 2018 16:32:34 +0000 (18:32 +0200)
Grab all commits (except version bump to 1.32.2) from upstream gnome-3-24 branch
and mtp unmount fix from gnome-3-26 branch. Include patch for elogind support
and integrate it in the ebuild.

Closes: https://bugs.gentoo.org/599482
Closes: https://bugs.gentoo.org/641522
Package-Manager: Portage-2.3.19, Repoman-2.3.6

gnome-base/gvfs/Manifest
gnome-base/gvfs/gvfs-1.32.1-r1.ebuild [new file with mode: 0644]
gnome-base/gvfs/metadata.xml

index 6153cebeec7812c08e1129157aaa060fe66b35c5..e0b74591460a1c64be54a0b776a8fb1abefa419a 100644 (file)
@@ -1,2 +1,3 @@
 DIST gvfs-1.30.4.tar.xz 1895304 BLAKE2B 7e7dbcde464ac3afc982d6d04916ecbee4b0cfae9481d2f75e2195b4816e8f92a5fe3d434f630dbea684b4020721825133205f303d4bf527d8826033355b547e SHA512 305b2abc8cfcb4bdea1fb84f5a7df4aac9697494f5d63d40ce1eb234b547aed497deb4d88a2cb17f9ab4fc188d49ff56033993a17cbfebae6d65a33dc84a633a
+DIST gvfs-1.32.1-patches.tar.xz 53288 BLAKE2B 2394f0931927069b4aeab69769df74c823ebffca2e7e73245b3597e085f2fff5c98999e6eccd052fa3564339b75d764f2124592c0977fddd2eb4afeca819b965 SHA512 c3e9de02e013aaf707878f8ffab96c42ac558412020f8462f928d2c7bd8b9756aa980e6b8db50e6f0ff0ad91f250ef1a26358d80b5d1cdaa9234475ec3a3db4f
 DIST gvfs-1.32.1.tar.xz 1813212 BLAKE2B 4b349e968eaab75d75ac9e7b66087298754ad81668e415812c4db74e2e393ac2cddea1b55771656dcd67ffdca23e4cf1642afef101498d309c643519fcefcca3 SHA512 7bd4d137437c1704faf6a9c2712bddcc327284e752c552c2cc18c64beb5e6d291af321e92d02d4f09b619762121129cee82c13ec2a4ca39d045196ebeeb28dd8
diff --git a/gnome-base/gvfs/gvfs-1.32.1-r1.ebuild b/gnome-base/gvfs/gvfs-1.32.1-r1.ebuild
new file mode 100644 (file)
index 0000000..cef628d
--- /dev/null
@@ -0,0 +1,134 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+GNOME2_EAUTORECONF="yes"
+
+inherit gnome2 systemd
+
+DESCRIPTION="Virtual filesystem implementation for gio"
+HOMEPAGE="https://wiki.gnome.org/Projects/gvfs"
+SRC_URI="${SRC_URI} https://dev.gentoo.org/~leio/distfiles/${P}-patches.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="afp archive bluray cdda elogind fuse google gnome-keyring gnome-online-accounts gphoto2 gtk +http ios mtp nfs policykit samba systemd test +udev udisks zeroconf"
+REQUIRED_USE="
+       cdda? ( udev )
+       elogind? ( !systemd udisks )
+       google? ( gnome-online-accounts )
+       mtp? ( udev )
+       udisks? ( udev )
+       systemd? ( !elogind udisks )
+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+
+RDEPEND="
+       app-crypt/gcr:=
+       >=dev-libs/glib-2.51:2
+       dev-libs/libxml2:2
+       net-misc/openssh
+       afp? ( >=dev-libs/libgcrypt-1.2.2:0= )
+       archive? ( app-arch/libarchive:= )
+       bluray? ( media-libs/libbluray:= )
+       elogind? ( >=sys-auth/elogind-229:0= )
+       fuse? ( >=sys-fs/fuse-2.8.0:0 )
+       gnome-keyring? ( app-crypt/libsecret )
+       gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.7.1:= )
+       google? (
+               >=dev-libs/libgdata-0.17.7:=[crypt,gnome-online-accounts]
+               >=net-libs/gnome-online-accounts-3.17.1:= )
+       gphoto2? ( >=media-libs/libgphoto2-2.5.0:= )
+       gtk? ( >=x11-libs/gtk+-3.0:3 )
+       http? ( >=net-libs/libsoup-2.42:2.4 )
+       ios? (
+               >=app-pda/libimobiledevice-1.2:=
+               >=app-pda/libplist-1:= )
+       mtp? (
+               >=dev-libs/libusb-1.0.21
+               >=media-libs/libmtp-1.1.12 )
+       nfs? ( >=net-fs/libnfs-1.9.8 )
+       policykit? (
+               sys-auth/polkit
+               sys-libs/libcap )
+       samba? ( >=net-fs/samba-4[client] )
+       systemd? ( >=sys-apps/systemd-206:0= )
+       udev? (
+               cdda? ( dev-libs/libcdio-paranoia )
+               >=virtual/libgudev-147:=
+               virtual/libudev:= )
+       udisks? ( >=sys-fs/udisks-1.97:2 )
+       zeroconf? ( >=net-dns/avahi-0.6 )
+"
+DEPEND="${RDEPEND}
+       app-text/docbook-xsl-stylesheets
+       dev-libs/libxslt
+       >=sys-devel/gettext-0.19.4
+       virtual/pkgconfig
+       dev-util/gdbus-codegen
+       dev-util/gtk-doc-am
+       test? (
+               >=dev-python/twisted-core-12.3.0
+               || (
+                       net-analyzer/netcat
+                       net-analyzer/netcat6 ) )
+       !udev? ( >=dev-libs/libgcrypt-1.2.2:0 )
+"
+# libgcrypt.m4, provided by libgcrypt, needed for eautoreconf, bug #399043
+# test dependencies needed per https://bugzilla.gnome.org/700162
+
+# Tests with multiple failures, this is being handled upstream at:
+# https://bugzilla.gnome.org/700162
+RESTRICT="test"
+
+PATCHES=(
+       "${WORKDIR}"/${P}-patches/ #599482, 641522, gnome-3-24 backports
+       "${FILESDIR}"/${PN}-1.30.2-sysmacros.patch #580234
+)
+
+src_prepare() {
+       if ! use udev; then
+               sed -e 's/gvfsd-burn/ /' \
+                       -e 's/burn.mount.in/ /' \
+                       -e 's/burn.mount/ /' \
+                       -i daemon/Makefile.am || die
+       fi
+
+       gnome2_src_prepare
+}
+
+src_configure() {
+       # --enable-documentation installs man pages
+       # --disable-obexftp, upstream bug #729945
+       gnome2_src_configure \
+               --disable-gdu \
+               --enable-documentation \
+               --enable-gcr \
+               --with-dbus-service-dir="${EPREFIX}"/usr/share/dbus-1/services \
+               --with-systemduserunitdir="$(systemd_get_userunitdir)" \
+               $(use_enable afp) \
+               $(use_enable archive) \
+               $(use_enable bluray) \
+               $(use_enable cdda) \
+               $(use_enable elogind libelogind) \
+               $(use_enable fuse) \
+               $(use_enable gnome-keyring keyring) \
+               $(use_enable gnome-online-accounts goa) \
+               $(use_enable google) \
+               $(use_enable gphoto2) \
+               $(use_enable gtk) \
+               $(use_enable http) \
+               $(use_enable ios afc) \
+               $(use_enable mtp libmtp) \
+               $(use_enable mtp libusb) \
+               $(use_enable nfs) \
+               $(use_enable policykit admin) \
+               $(use_enable samba) \
+               $(use_enable systemd libsystemd-login) \
+               $(use_enable udev gudev) \
+               $(use_enable udev) \
+               $(use_enable udisks udisks2) \
+               $(use_enable zeroconf avahi)
+}
index 346074ac28ce39773aa401f5664713bebf6c3e93..d26195bc7e444f26054ba743ce5146dcd4ec1fff 100644 (file)
@@ -16,6 +16,7 @@ applications not using gio to access the gvfs filesystems.
        <flag name="afp">Enables support for accessing AFP (Apple Filing Protocol) network shares</flag>
        <flag name="archive">Enables support for accessing files in archives transparently via <pkg>app-arch/libarchive</pkg></flag>
        <flag name="bluray">Enable playback of Blu-ray filesystems using <pkg>media-libs/libbluray</pkg></flag>
+       <flag name="elogind">Use <pkg>sys-auth/elogind</pkg> for session tracking.</flag>
        <flag name="fuse">Enables fuse mount points in $HOME/.gvfs for legacy application access</flag>
        <flag name="gnome-online-accounts">Enable configuration panel for <pkg>net-libs/gnome-online-accounts</pkg> accounts</flag>
        <flag name="google">Enables support for accessing Google accounts via <pkg>dev-libs/libgdata</pkg></flag>