app-emulation/qemu: Add use flag jemalloc
authorHan Han <hanhanzhiyeqianke@gmail.com>
Sat, 27 Jul 2019 15:33:09 +0000 (23:33 +0800)
committerMatthias Maier <tamiko@gentoo.org>
Sun, 22 Sep 2019 02:34:08 +0000 (21:34 -0500)
Add flag jemalloc to enable or disable jemalloc memory jemalloc support
for qemu.

Signed-off-by: Han Han <hanhanzhiyeqianke@gmail.com>
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
app-emulation/qemu/metadata.xml
app-emulation/qemu/qemu-4.0.0-r50.ebuild
app-emulation/qemu/qemu-9999.ebuild

index 3439dfdd4e1516aa8a300ea83eec31e909460c12..4c468733de523cfcec0b9a020b7108d6f96d339f 100644 (file)
@@ -39,6 +39,7 @@
                <flag name="static">Build the User and Software MMU (system) targets as well as tools as static binaries</flag>
                <flag name="systemtap">Enable SystemTAP/DTrace tracing</flag>
                <flag name="tci">Enable the TCG Interpreter which can speed up or slowdown workloads depending on the host and guest CPUs being emulated. In the future it will be a runtime option but for now its compile time.</flag>
+               <flag name="jemalloc">Enable jemalloc allocator support</flag>
                <flag name="jpeg">Enable jpeg image support for the VNC console server</flag>
                <flag name="png">Enable png image support for the VNC console server</flag>
                <flag name="usb">Enable USB passthrough via <pkg>dev-libs/libusb</pkg></flag>
index d547b37ab845caea2581ab0b0d79f43197c85256..cc99fdbbcc18073e7406613fa4d1a59d9a4a8f8e 100644 (file)
@@ -28,7 +28,7 @@ HOMEPAGE="http://www.qemu.org http://www.linux-kvm.org"
 LICENSE="GPL-2 LGPL-2 BSD-2"
 SLOT="0"
 IUSE="accessibility +aio alsa bzip2 capstone +caps +curl debug doc
-       +fdt glusterfs gnutls gtk infiniband iscsi +jpeg kernel_linux
+       +fdt glusterfs gnutls gtk infiniband iscsi jemalloc +jpeg kernel_linux
        kernel_FreeBSD lzo ncurses nfs nls numa opengl +pin-upstream-blobs +png
        pulseaudio python rbd sasl +seccomp sdl selinux smartcard snappy
        spice ssh static static-user systemtap tci test usb usbredir vde
@@ -108,6 +108,7 @@ SOFTMMU_TOOLS_DEPEND="
                sys-fabric/librdmacm:=[static-libs(+)]
        )
        iscsi? ( net-libs/libiscsi )
+       jemalloc? ( dev-libs/jemalloc )
        jpeg? ( virtual/jpeg:0=[static-libs(+)] )
        lzo? ( dev-libs/lzo:2[static-libs(+)] )
        ncurses? (
@@ -436,6 +437,7 @@ qemu_src_configure() {
                $(conf_notuser gtk)
                $(conf_notuser infiniband rdma)
                $(conf_notuser iscsi libiscsi)
+               $(conf_notuser jemalloc jemalloc)
                $(conf_notuser jpeg vnc-jpeg)
                $(conf_notuser kernel_linux kvm)
                $(conf_notuser lzo)
index b26d0b2869df20dc6c478f446bc9cf6f5fae4b60..51deb16ff036452eafc151b2affd236a57aab549 100644 (file)
@@ -34,7 +34,7 @@ LICENSE="GPL-2 LGPL-2 BSD-2"
 SLOT="0"
 
 IUSE="accessibility +aio alsa bzip2 capstone +caps +curl debug doc
-       +fdt glusterfs gnutls gtk infiniband iscsi +jpeg kernel_linux
+       +fdt glusterfs gnutls gtk infiniband iscsi +jpeg jemalloc kernel_linux
        kernel_FreeBSD lzo ncurses nfs nls numa opengl +oss +pin-upstream-blobs
        +png pulseaudio python rbd sasl +seccomp sdl selinux smartcard snappy
        spice ssh static static-user systemtap tci test usb usbredir vde
@@ -114,6 +114,7 @@ SOFTMMU_TOOLS_DEPEND="
                sys-fabric/librdmacm:=[static-libs(+)]
        )
        iscsi? ( net-libs/libiscsi )
+       jemalloc? ( dev-libs/jemalloc )
        jpeg? ( virtual/jpeg:0=[static-libs(+)] )
        lzo? ( dev-libs/lzo:2[static-libs(+)] )
        ncurses? (
@@ -443,6 +444,7 @@ qemu_src_configure() {
                $(conf_notuser gtk)
                $(conf_notuser infiniband rdma)
                $(conf_notuser iscsi libiscsi)
+               $(conf_notuser jemalloc jemalloc)
                $(conf_notuser jpeg vnc-jpeg)
                $(conf_notuser kernel_linux kvm)
                $(conf_notuser lzo)