dev-libs/libgit2: Drop old
authorMichał Górny <mgorny@gentoo.org>
Mon, 19 Aug 2019 04:23:54 +0000 (06:23 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 19 Aug 2019 04:28:41 +0000 (06:28 +0200)
Bug: https://bugs.gentoo.org/692166
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-libs/libgit2/Manifest
dev-libs/libgit2/files/libgit2-0.26.8-disable-oom-tests-on-32bit.patch [deleted file]
dev-libs/libgit2/libgit2-0.26.8.ebuild [deleted file]
dev-libs/libgit2/libgit2-0.28.2.ebuild [deleted file]
dev-libs/libgit2/metadata.xml

index 9bc877f45ed186889c63086d9aa58ad50fdd32a0..648863661c711aea5508221e19fb10ffe3ef60a8 100644 (file)
@@ -1,3 +1 @@
-DIST libgit2-0.26.8.tar.gz 4742478 BLAKE2B 31326987961ed42740f6c0ddce6a80c278175899a62cabd65ce9eef60854553e6a91fd9947ca23945104d4e1b46f9ab0bb1a1a793d8dd87bed792528e5c32839 SHA512 efb9229b2882ac36910d75778d7431bec40f3529f2ad2dd6a950d5580ceb0d4dd798242a422ea6cbb880f515df4dfbb7055a65dd5a8106696d3d458851fca56e
-DIST libgit2-0.28.2.tar.gz 4987586 BLAKE2B cf791adb173050b4b153062ff5fdc923289462677ce34af1077d228a95c4d9d7e9b836aee44dc79f079f42c910c4b4548241ec7ff16665ce49e319ccd38d4c7a SHA512 0879c162e2e1dc00eadfbda22cd1f9d3a95b4ec2b653c108983f37c2f695140882de4d50d7cbc04ced247125a4e9fe6df16130e1267891aecdb2411d920db5c6
 DIST libgit2-0.28.3.tar.gz 4988580 BLAKE2B 93d87792b0aef6383845230880d749fa77f28ac8ece4564abf041ccbb672d17e6efb1ef9503879d45cf5f78b6f1e54dd2b2ab9eac0fb09ddb445310484bbd7fc SHA512 15444823b7d4885f7b8c3982f8905efc4a75913de016a9b2e0a24d5ce9746e6a549dffd5469036529557feff2ce7ece9328266eb312c80b96091ce0f65ee97ee
diff --git a/dev-libs/libgit2/files/libgit2-0.26.8-disable-oom-tests-on-32bit.patch b/dev-libs/libgit2/files/libgit2-0.26.8-disable-oom-tests-on-32bit.patch
deleted file mode 100644 (file)
index 40be2ae..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
-From 16b5a7baf67169ff12a9a2de9c2853c6f921317c Mon Sep 17 00:00:00 2001
-From: Edward Thomson <ethomson@edwardthomson.com>
-Date: Thu, 13 Sep 2018 13:27:07 +0100
-Subject: [PATCH] tests: don't run buf::oom on 32-bit systems
-
-On a 32-bit Linux systems, the value large enough to make malloc
-guarantee a failure is also large enough that valgrind considers it
-"fishy".  Skip this test on those systems entirely.
-
-[rebased for v0.26.8]
----
- tests/buf/oom.c | 14 +++++++++-----
- 1 file changed, 9 insertions(+), 5 deletions(-)
-
-diff --git a/tests/buf/oom.c b/tests/buf/oom.c
-index 16a03cc1a..86f5e7239 100644
---- a/tests/buf/oom.c
-+++ b/tests/buf/oom.c
-@@ -11,12 +11,8 @@
-  */
- #if defined(GIT_ARCH_64) && defined(__linux__)
- # define TOOBIG 0x0fffffffffffffff
--#elif defined(__linux__)
--# define TOOBIG 0x0fffffff
- #elif defined(GIT_ARCH_64)
- # define TOOBIG 0xffffffffffffff00
--#else
--# define TOOBIG 0xffffff00
- #endif
- /**
-@@ -25,13 +21,18 @@
-  * will fail.  And because the git_buf_grow() wrapper always
-  * sets mark_oom, the code in git_buf_try_grow() will free
-  * the internal buffer and set it to git_buf__oom.
-- * 
-+ *
-  * We initialized the internal buffer to (the static variable)
-  * git_buf__initbuf.  The purpose of this test is to make sure
-  * that we don't try to free the static buffer.
-+ *
-+ * Skip this test entirely on 32-bit platforms; a buffer large enough
-+ * to guarantee malloc failures is so large that valgrind considers
-+ * it likely to be an error.
-  */
- void test_buf_oom__grow(void)
- {
-+#ifdef GIT_ARCH_64
-       git_buf buf = GIT_BUF_INIT;
-       git_buf_clear(&buf);
-@@ -40,6 +41,9 @@ void test_buf_oom__grow(void)
-       cl_assert(git_buf_oom(&buf));
-       git_buf_free(&buf);
-+#else
-+    cl_skip();
-+#endif
- }
- void test_buf_oom__grow_by(void)
--- 
-2.19.1
-
diff --git a/dev-libs/libgit2/libgit2-0.26.8.ebuild b/dev-libs/libgit2/libgit2-0.26.8.ebuild
deleted file mode 100644 (file)
index 715f017..0000000
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit cmake-utils python-any-r1
-
-if [[ ${PV} == "9999" ]] ; then
-       EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
-       inherit git-r3
-else
-       SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="amd64 ~arm arm64 ~ppc x86 ~ppc-macos"
-fi
-
-DESCRIPTION="A linkable library for Git"
-HOMEPAGE="https://libgit2.github.com/"
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0/26"
-IUSE="+curl examples gssapi libressl +ssh test +threads trace"
-
-RDEPEND="
-       !libressl? ( dev-libs/openssl:0= )
-       libressl? ( dev-libs/libressl:0= )
-       sys-libs/zlib
-       net-libs/http-parser:=
-       curl? (
-               !libressl? ( net-misc/curl:=[curl_ssl_openssl(-)] )
-               libressl? ( net-misc/curl:=[curl_ssl_libressl(-)] )
-       )
-       gssapi? ( virtual/krb5 )
-       ssh? ( net-libs/libssh2 )
-"
-DEPEND="${RDEPEND}
-       ${PYTHON_DEPS}
-       virtual/pkgconfig
-"
-
-DOCS=( AUTHORS CONTRIBUTING.md CONVENTIONS.md README.md )
-
-PATCHES=(
-       # skip OOM tests on 32-bit systems
-       # https://bugs.gentoo.org/669892
-       # https://github.com/libgit2/libgit2/commit/415a8ae9c9b6ac18f0524b6af8e58408b426457d
-       "${FILESDIR}"/libgit2-0.26.8-disable-oom-tests-on-32bit.patch
-)
-
-src_configure() {
-       local mycmakeargs=(
-               -DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
-               -DBUILD_CLAR=$(usex test)
-               -DENABLE_TRACE=$(usex trace)
-               -DUSE_GSSAPI=$(usex gssapi)
-               -DUSE_SSH=$(usex ssh)
-               -DTHREADSAFE=$(usex threads)
-               -DCURL=$(usex curl)
-       )
-       cmake-utils_src_configure
-}
-
-src_test() {
-       if [[ ${EUID} -eq 0 ]] ; then
-               # repo::iterator::fs_preserves_error fails if run as root
-               # since root can still access dirs with 0000 perms
-               ewarn "Skipping tests: non-root privileges are required for all tests to pass"
-       else
-               local TEST_VERBOSE=1
-               cmake-utils_src_test -R offline
-       fi
-}
-
-src_install() {
-       cmake-utils_src_install
-
-       if use examples ; then
-               find examples -name '.gitignore' -delete || die
-               dodoc -r examples
-               docompress -x /usr/share/doc/${PF}/examples
-       fi
-}
diff --git a/dev-libs/libgit2/libgit2-0.28.2.ebuild b/dev-libs/libgit2/libgit2-0.28.2.ebuild
deleted file mode 100644 (file)
index 89a49f8..0000000
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit cmake-utils python-any-r1
-
-if [[ ${PV} == "9999" ]] ; then
-       EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
-       inherit git-r3
-else
-       SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~ppc-macos"
-fi
-
-DESCRIPTION="A linkable library for Git"
-HOMEPAGE="https://libgit2.github.com/"
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0/28"
-IUSE="examples gssapi libressl +ssh test +threads trace"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       !libressl? ( dev-libs/openssl:0= )
-       libressl? ( dev-libs/libressl:0= )
-       sys-libs/zlib
-       net-libs/http-parser:=
-       gssapi? ( virtual/krb5 )
-       ssh? ( net-libs/libssh2 )
-"
-DEPEND="${RDEPEND}
-       ${PYTHON_DEPS}
-       virtual/pkgconfig
-"
-
-S=${WORKDIR}/${P/_/-}
-
-src_configure() {
-       local mycmakeargs=(
-               -DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
-               -DBUILD_CLAR=$(usex test)
-               -DENABLE_TRACE=$(usex trace)
-               -DUSE_GSSAPI=$(usex gssapi)
-               -DUSE_SSH=$(usex ssh)
-               -DTHREADSAFE=$(usex threads)
-       )
-       cmake-utils_src_configure
-}
-
-src_test() {
-       if [[ ${EUID} -eq 0 ]] ; then
-               # repo::iterator::fs_preserves_error fails if run as root
-               # since root can still access dirs with 0000 perms
-               ewarn "Skipping tests: non-root privileges are required for all tests to pass"
-       else
-               local TEST_VERBOSE=1
-               cmake-utils_src_test -R offline
-       fi
-}
-
-src_install() {
-       cmake-utils_src_install
-       dodoc docs/*.{md,txt}
-
-       if use examples ; then
-               find examples -name '.gitignore' -delete || die
-               dodoc -r examples
-               docompress -x /usr/share/doc/${PF}/examples
-       fi
-}
index e090ecb97fe292c5271bf03d9d3c2df0928d30d5..341b4d4cf6d872846d980632993c2290f7bb1ac3 100644 (file)
@@ -15,8 +15,6 @@
                speed custom Git applications in any language which supports C bindings.
        </longdescription>
        <use>
-               <flag name="curl">Use <pkg>net-misc/curl</pkg> for HTTP support
-                       (otherwise, limited built-in implementation will be used)</flag>
                <flag name="gssapi">Enable GSSAPI support for SPNEGO auth</flag>
                <flag name="ssh">Enable SSH transport support</flag>
                <flag name="trace">Enable tracing support</flag>