net-misc/youtube-dl: Old.
authorJeroen Roovers <jer@gentoo.org>
Tue, 7 Aug 2018 09:54:12 +0000 (11:54 +0200)
committerJeroen Roovers <jer@gentoo.org>
Tue, 7 Aug 2018 09:54:50 +0000 (11:54 +0200)
Package-Manager: Portage-2.3.44, Repoman-2.3.10

net-misc/youtube-dl/Manifest
net-misc/youtube-dl/youtube-dl-2018.07.21.ebuild [deleted file]

index fe0cde9a60e3ff774d00b0e8a216644a35b755be..f43dcf79b0a5b19e88627e0321192666a1000c76 100644 (file)
@@ -1,4 +1,3 @@
 DIST youtube-dl-2017.11.15.tar.gz 2834012 BLAKE2B fd93e3923f99874be58681a886c09e31ac10063975ab636badf27e59b44743c72cddf05e3a431c49ffd0f7b40f9b005f4d90feff85d4ca889dee80833300b076 SHA512 e10c0d53db7fdfb02610b53f54046c0a9354b305ba05c5d00a43649a283a6449263f66ff56171d52cf18f906c6aeccc25dc48ea708b4b1bb2b8323b937abca96
-DIST youtube-dl-2018.07.21.tar.gz 3006144 BLAKE2B 63b0fdf38f9e510b163a1737136956c0d4c497b0e3f78caad01170711c359e2ee9638f6448992ff28760cac60d0496c1572a04939f95d060560bc399d3399a4e SHA512 d0c75b8d651a4c401dd706c3ce86882098a16e9bb3e72b3871b3fe5284a345fc04bf5f7a9165a12af63091660a68a9b81f80a523b2090da3556856d69a81b6bf
 DIST youtube-dl-2018.07.29.tar.gz 3012839 BLAKE2B 9550f03b74db95fe26310348113883763240a187d69f1f859fe516848f6d9647555113d12397b7d30f3b4c7799c930b373825b54f2db05ac72b3be0e6b7efad0 SHA512 a41b97b5dca0715a891ff77d8317939d2b86e495fe2ec1cca6aaea72da545f6cdd6c4cf605c2ebd004a0add049d5fb1ed17b6dab9d99fc349f378e37ff6be330
 DIST youtube-dl-2018.08.04.tar.gz 3015718 BLAKE2B e9b64bfa791fdd854b180f58ed81ceead89b5cd8a1d6f537eca54ff041151504bbd1ea125fbb8be9c5e05abcd9a1064c699211378dd53f67ff3aa653df59da4d SHA512 4a23dd644b039a8bc64d5d55821cc5470a29b3ce2c5ccea9eb2aa6ba753d675363e14b9ba959f6b0dfc62a97898032225c21eb4993fd742b273259d89ba99cba
diff --git a/net-misc/youtube-dl/youtube-dl-2018.07.21.ebuild b/net-misc/youtube-dl/youtube-dl-2018.07.21.ebuild
deleted file mode 100644 (file)
index 37bffad..0000000
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
-inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
-
-DESCRIPTION="Download videos from YouTube.com (and more sites...)"
-HOMEPAGE="https://rg3.github.com/youtube-dl/"
-SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="+offensive test"
-
-RDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-"
-DEPEND="
-       ${RDEPEND}
-       test? ( dev-python/nose[coverage(+)] )
-"
-
-S="${WORKDIR}/${PN}"
-
-python_prepare_all() {
-       if ! use offensive; then
-               sed -i -e "/..version../s|'$|+gentoo.no.offensive.sites'|g" \
-                       youtube_dl/version.py || die
-               # these have single line import statements
-               local xxx=(
-                       alphaporno anysex behindkink camwithher chaturbate eporner
-                       eroprofile extremetube foxgay goshgay hellporno hentaistigma
-                       hornbunny keezmovies lovehomeporn mofosex myvidster porn91 porncom
-                       pornflip pornhd pornotube pornovoisines pornoxo ruleporn sexu
-                       slutload spankbang spankwire sunporno thisav vporn watchindianporn
-                       xbef xnxx xtube xvideos xxxymovies youjizz youporn
-               )
-               # these have multi-line import statements
-               local mxxx=(
-                       drtuber fourtube motherless pornhub redtube tnaflix tube8 xhamster
-               )
-               # do single line imports
-               sed -i \
-                       -e $( printf '/%s/d;' ${xxx[@]} ) \
-                       youtube_dl/extractor/extractors.py \
-                       || die
-
-               # do multiple line imports
-               sed -i \
-                       -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
-                       youtube_dl/extractor/extractors.py \
-                       || die
-
-               sed -i \
-                       -e $( printf '/%s/d;' ${mxxx[@]} ) \
-                       youtube_dl/extractor/generic.py \
-                       || die
-
-               rm \
-                       $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
-                       $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
-                       test/test_age_restriction.py \
-                       || die
-       fi
-
-       eapply_user
-
-       distutils-r1_python_prepare_all
-}
-
-src_compile() {
-       distutils-r1_src_compile
-}
-
-python_test() {
-       emake test
-}
-
-python_install_all() {
-       dodoc README.txt
-       doman ${PN}.1
-
-       newbashcomp ${PN}.bash-completion ${PN}
-
-       insinto /usr/share/zsh/site-functions
-       newins youtube-dl.zsh _youtube-dl
-
-       insinto /usr/share/fish/completions
-       doins youtube-dl.fish
-
-       distutils-r1_python_install_all
-
-       rm -r "${ED}"/usr/etc || die
-       rm -r "${ED}"/usr/share/doc/youtube_dl || die
-}
-
-pkg_postinst() {
-       elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
-       elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
-       elog
-       elog "${PN} works fine on its own on most sites. However, if you want"
-       elog "to convert video/audio, you'll need avconf (media-video/libav) or"
-       elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
-       elog "videos can be retrieved in a higher quality format without sound."
-       elog "${PN} will detect whether avconv/ffmpeg is present and"
-       elog "automatically pick the best option."
-
-       elog
-       elog "Videos or video formats streamed via RTMP protocol can only be"
-       elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
-       elog "Downloading MMS and RTSP videos requires either mplayer"
-       elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
-}