media-libs/libopenmpt: New package
authorJames Le Cuirot <chewi@gentoo.org>
Sun, 8 Dec 2019 15:02:28 +0000 (15:02 +0000)
committerJames Le Cuirot <chewi@gentoo.org>
Sun, 8 Dec 2019 15:37:37 +0000 (15:37 +0000)
I have packaged openmpt123 separately. Both have many USE flags that
could be explained in the metadata but are more intuitive when
separated.

Closes: https://bugs.gentoo.org/598818
Package-Manager: Portage-2.3.81, Repoman-2.3.19
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
media-libs/libopenmpt/Manifest [new file with mode: 0644]
media-libs/libopenmpt/libopenmpt-0.4.10.ebuild [new file with mode: 0644]
media-libs/libopenmpt/metadata.xml [new file with mode: 0644]

diff --git a/media-libs/libopenmpt/Manifest b/media-libs/libopenmpt/Manifest
new file mode 100644 (file)
index 0000000..a169d54
--- /dev/null
@@ -0,0 +1 @@
+DIST libopenmpt-0.4.10+release.autotools.tar.gz 1471662 BLAKE2B c20ef4d26b583f5cbbed5e6d108ce6f55fef74726997267a56d16b8508fb46f26f62f934a98bcc20749da2ed2aef0bdd22931cc785806ec0b6c5daef593d196d SHA512 d7c46016eea59c21e3f948d8538a747d5fa6b29f160841b688878d8ce48859d014c3a036738074b3d260af6e662c36b03391aef511c1817a5ace81f60bf27dfc
diff --git a/media-libs/libopenmpt/libopenmpt-0.4.10.ebuild b/media-libs/libopenmpt/libopenmpt-0.4.10.ebuild
new file mode 100644 (file)
index 0000000..091bc25
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+MY_P="libopenmpt-${PV}+release.autotools"
+DESCRIPTION="Library to decode tracked music files (modules)"
+HOMEPAGE="https://lib.openmpt.org/libopenmpt/"
+SRC_URI="https://lib.openmpt.org/files/libopenmpt/src/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="examples mp3 ogg static-libs test vorbis zlib"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       mp3? ( media-sound/mpg123[${MULTILIB_USEDEP}] )
+       ogg? ( media-libs/libogg[${MULTILIB_USEDEP}] )
+       vorbis? ( media-libs/libvorbis[${MULTILIB_USEDEP}] )
+       zlib? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+ECONF_SOURCE="${S}"
+
+multilib_src_configure() {
+       # A lot of these optional dependencies relate to openmpt123, which
+       # we package separately, so we disable them here.
+       econf \
+               $(use_enable static-libs static) \
+               --disable-openmpt123 \
+               --disable-examples \
+               $(use_enable test tests) \
+               --disable-doxygen-doc \
+               $(use_with zlib) \
+               $(use_with mp3 mpg123) \
+               $(use_with ogg) \
+               $(use_with vorbis) \
+               $(use_with vorbis vorbisfile) \
+               --without-pulseaudio \
+               --without-portaudio \
+               --without-portaudiocpp \
+               --without-sdl2 \
+               --without-sdl \
+               --without-sndfile \
+               --without-flac
+}
+
+multilib_src_install_all() {
+       rm \
+               "${ED}"/usr/*/*.la \
+               "${ED}"/usr/share/doc/${P}/LICENSE || die
+
+       if ! use examples; then
+               rm -r "${ED}"/usr/share/doc/${P}/examples || die
+       fi
+}
diff --git a/media-libs/libopenmpt/metadata.xml b/media-libs/libopenmpt/metadata.xml
new file mode 100644 (file)
index 0000000..334fead
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>chewi@gentoo.org</email>
+               <name>James Le Cuirot</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">OpenMPT/openmpt</remote-id>
+       </upstream>
+</pkgmetadata>