sys-kernel/pf-sources: bump to 5.5-pf7
authorJoonas Niilola <juippis@gentoo.org>
Thu, 19 Mar 2020 06:42:12 +0000 (08:42 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 19 Mar 2020 06:42:37 +0000 (08:42 +0200)
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
sys-kernel/pf-sources/Manifest
sys-kernel/pf-sources/pf-sources-5.5_p7.ebuild [new file with mode: 0644]

index 441f7995f2bae42b5a98096eb1f314778aeed196..db0ce7d8bb6254c85600e2201b908d93a0cdab90 100644 (file)
@@ -15,3 +15,4 @@ DIST pf-sources-5.5_p3.patch 1305735 BLAKE2B 3b124c3fe3949ea18242558d57672f4f9f1
 DIST pf-sources-5.5_p4.patch 1489666 BLAKE2B 3906d23f42d4943acf3e75a5b47d94b808417338cffbf8e04dad825387188be678afa3eb7d264c687e483b91b82402370a2df7e72c82294cffc39d4a7c0429b5 SHA512 b0c9cad6a375205c65d32d435efede2dbb98cd6e077aa7ef4d0d33e9735f3937980c371b87a76d5595426b3dce3606bacdb69eb1c8baf14d435e2c9190035bc2
 DIST pf-sources-5.5_p5.patch 2147102 BLAKE2B 0f6aee4d3e59386e3acdf67ab7f931e45acb3d6d1b8aa39a914875da1bde2733d5b4bfc601635280f7f6fd0dcfbf1c6cdd77061a3e4230b128896da829b9e495 SHA512 7d60c3a18bec8642cc13594bdbb82c684d78d62636f9bbb9f2e791f7695476420c6d80256a4157a44e61f9d85c9405dd398587f935c33c77b8a2b92538855037
 DIST pf-sources-5.5_p6.patch 2597110 BLAKE2B 7ab0a9bb5b1787cb2488e418bc3b45edf2348e60f118f90e47025d540367a93a49c87fd2362fc3bb3e84d89bd8d0c2b8f63c6f79e969813ce398578bdef9bcc2 SHA512 5530fd6e874ee5f0ac03e558c475790ac4e0ff79e98aa2df272d223d9a3cebf49a1e90a08751a37b694cd6b643040d0ececeea66a7a855194fbd33b448cdf3c9
+DIST pf-sources-5.5_p7.patch 2978872 BLAKE2B 3b1e63dd0b3fdf1d880053576b8f4efa928292a7bde7f536ce551845bf2c33c74d008b3533428917a224cc0e959d5ebcd3bf09b2754f77183f6366b82a22d9eb SHA512 8da0e9085970dd5f3f641bcb9dff867db390dc49e278ef29ee6f84d2e99007d3403bc69f8e96280a6feccaf3f85731335a89e4888cf5df567429715baf5695fd
diff --git a/sys-kernel/pf-sources/pf-sources-5.5_p7.ebuild b/sys-kernel/pf-sources/pf-sources-5.5_p7.ebuild
new file mode 100644 (file)
index 0000000..2a683a5
--- /dev/null
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Define what default functions to run
+ETYPE="sources"
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Just get basic genpatches, -pf patch set already includes vanilla-linux
+# updates
+K_GENPATCHES_VER="1"
+
+# -pf already sets EXTRAVERSION to kernel Makefile
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security team
+K_SECURITY_UNSUPPORTED="1"
+
+# We want the very basic patches from gentoo-sources, experimental patch is
+# already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+inherit eutils kernel-2
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/-/wikis/README
+       https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="${KERNEL_URI}
+       https://github.com/pfactum/pf-kernel/compare/v${PV/_p*/}...v${PV/_p*/}-pf${PV/*_p/}.diff -> ${P}.patch
+       https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.base.tar.xz
+       https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.extras.tar.xz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PVR}-pf"
+
+PATCHES=( "${DISTDIR}/${P}.patch" )
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+       see: ${HOMEPAGE}."
+
+pkg_setup() {
+       ewarn ""
+       ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+       ewarn "If you need support, please contact the pf developers directly."
+       ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+       ewarn "the ebuilds. Thank you."
+       ewarn ""
+
+       kernel-2_pkg_setup
+}
+
+src_prepare() {
+       default
+       kernel-2_src_prepare
+}
+
+pkg_postinst() {
+       kernel-2_pkg_postinst
+
+       elog "Optional features:"
+       optfeature "Userspace KSM helper" sys-process/uksmd
+}