sci-biology/bamtools: Remove USE="static-libs"
authorDavid Seifert <soap@gentoo.org>
Wed, 13 Nov 2019 18:16:02 +0000 (10:16 -0800)
committerDavid Seifert <soap@gentoo.org>
Wed, 13 Nov 2019 18:16:02 +0000 (10:16 -0800)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
sci-biology/bamtools/bamtools-2.5.1.ebuild
sci-biology/bamtools/bamtools-9999.ebuild

index 84c9dc837233f507c8f6813179a1cc7229eefc36..b5affe9f0fa94b4dbb5ca2c15afba65344646408 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-inherit cmake-utils multibuild
+inherit cmake-utils
 
 DESCRIPTION="A programmer's API and an end-user's toolkit for handling BAM files"
 HOMEPAGE="https://github.com/pezmaster31/bamtools"
@@ -18,7 +18,6 @@ fi
 
 LICENSE="MIT"
 SLOT="0/${PV}" # no stable ABI yet
-IUSE="static-libs"
 
 RDEPEND="
        >=dev-libs/jsoncpp-1.8.0:=
@@ -26,35 +25,9 @@ RDEPEND="
 DEPEND="${RDEPEND}"
 BDEPEND="virtual/pkgconfig"
 
-pkg_setup() {
-       [[ ${MERGE_TYPE} != binary ]] &&
-               MULTIBUILD_VARIANTS=(
-                       $(usev static-libs)
-                       shared
-               )
-}
-
 src_prepare() {
        # delete bundled libs, just to be safe
-       rm -r src/third_party/{gtest-1.6.0,jsoncpp} || die
+       rm -rf src/third_party/{gtest-1.6.0,jsoncpp} || die
 
        cmake-utils_src_prepare
 }
-
-src_configure() {
-       my_configure() {
-               [[ ${MULTIBUILD_ID} == static-libs* ]] &&
-                       local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
-
-               cmake-utils_src_configure
-       }
-       multibuild_foreach_variant my_configure
-}
-
-src_compile() {
-       multibuild_foreach_variant cmake-utils_src_compile
-}
-
-src_install() {
-       multibuild_foreach_variant cmake-utils_src_install
-}
index 84c9dc837233f507c8f6813179a1cc7229eefc36..b5affe9f0fa94b4dbb5ca2c15afba65344646408 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-inherit cmake-utils multibuild
+inherit cmake-utils
 
 DESCRIPTION="A programmer's API and an end-user's toolkit for handling BAM files"
 HOMEPAGE="https://github.com/pezmaster31/bamtools"
@@ -18,7 +18,6 @@ fi
 
 LICENSE="MIT"
 SLOT="0/${PV}" # no stable ABI yet
-IUSE="static-libs"
 
 RDEPEND="
        >=dev-libs/jsoncpp-1.8.0:=
@@ -26,35 +25,9 @@ RDEPEND="
 DEPEND="${RDEPEND}"
 BDEPEND="virtual/pkgconfig"
 
-pkg_setup() {
-       [[ ${MERGE_TYPE} != binary ]] &&
-               MULTIBUILD_VARIANTS=(
-                       $(usev static-libs)
-                       shared
-               )
-}
-
 src_prepare() {
        # delete bundled libs, just to be safe
-       rm -r src/third_party/{gtest-1.6.0,jsoncpp} || die
+       rm -rf src/third_party/{gtest-1.6.0,jsoncpp} || die
 
        cmake-utils_src_prepare
 }
-
-src_configure() {
-       my_configure() {
-               [[ ${MULTIBUILD_ID} == static-libs* ]] &&
-                       local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
-
-               cmake-utils_src_configure
-       }
-       multibuild_foreach_variant my_configure
-}
-
-src_compile() {
-       multibuild_foreach_variant cmake-utils_src_compile
-}
-
-src_install() {
-       multibuild_foreach_variant cmake-utils_src_install
-}