sys-libs/llvm-libunwind: Use BDEPEND semi-properly
authorMichał Górny <mgorny@gentoo.org>
Tue, 17 Sep 2019 21:00:26 +0000 (23:00 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 17 Sep 2019 21:00:56 +0000 (23:00 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-libs/llvm-libunwind/llvm-libunwind-10.0.0.9999.ebuild
sys-libs/llvm-libunwind/llvm-libunwind-9.0.0.9999.ebuild

index 631dc758a7e95a0211038ea341b104117f7c8021..4f882571235f5e82220795c3b073b6a0f6ef7eb7 100644 (file)
@@ -24,7 +24,8 @@ RESTRICT="!test? ( test )"
 RDEPEND="!sys-libs/libunwind"
 # llvm-6 for new lit options
 DEPEND="
-       >=sys-devel/llvm-6
+       >=sys-devel/llvm-6"
+BDEPEND="
        test? ( >=sys-devel/clang-3.9.0
                $(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )"
 
index b381179b755a0070cfb744a21461925cf95d124e..1e3f2baa716b562b78dcc2a409a9c3866797a0f4 100644 (file)
@@ -25,7 +25,8 @@ RESTRICT="!test? ( test )"
 RDEPEND="!sys-libs/libunwind"
 # llvm-6 for new lit options
 DEPEND="
-       >=sys-devel/llvm-6
+       >=sys-devel/llvm-6"
+BDEPEND="
        test? ( >=sys-devel/clang-3.9.0
                $(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )"