dev-ml/ppx_core: convert to opam.eclass
authorAlexis Ballier <aballier@gentoo.org>
Fri, 22 Sep 2017 08:03:50 +0000 (10:03 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 22 Sep 2017 08:31:33 +0000 (10:31 +0200)
Package-Manager: Portage-2.3.10, Repoman-2.3.3

dev-ml/ppx_core/ppx_core-0.9.0-r1.ebuild

index 889a65390b0fb334485c871d8be0ba0132da98c4..18dc742c243d9d9ecc91492d865ce63cf8fbcaba 100644 (file)
@@ -3,6 +3,8 @@
 
 EAPI=6
 
+inherit opam
+
 DESCRIPTION="Standard library for ppx rewriters"
 HOMEPAGE="https://github.com/janestreet/ppx_core"
 SRC_URI="https://github.com/janestreet/ppx_core/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -13,7 +15,6 @@ KEYWORDS="~amd64 ~ppc"
 IUSE=""
 
 DEPEND="
-       dev-lang/ocaml:=
        dev-ml/base:=
        dev-ml/ocaml-compiler-libs:=
        dev-ml/ppx_ast:=
@@ -22,12 +23,4 @@ DEPEND="
        dev-ml/ocaml-migrate-parsetree:=
 "
 RDEPEND="${DEPEND}"
-DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
-
-src_install() {
-       opam-installer -i \
-               --prefix="${ED}/usr" \
-               --libdir="${D}/$(ocamlc -where)" \
-               --docdir="${ED}/usr/share/doc/${PF}" \
-               ${PN}.install || die
-}
+DEPEND="${DEPEND} dev-ml/jbuilder"