dev-util/mdds: 1.1.0 version bump, bug 572616
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>
Fri, 11 Dec 2015 00:48:52 +0000 (01:48 +0100)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Mon, 22 Feb 2016 17:04:34 +0000 (18:04 +0100)
mdds:1 installs side-by-side with mdds:0. At this point, LibreOffice live
both depends on mdds:1 and through libixion-0.9* indirectly pulls in :0.

Package-Manager: portage-2.2.24

dev-util/mdds/Manifest
dev-util/mdds/mdds-1.1.0.ebuild [new file with mode: 0644]
dev-util/mdds/mdds-9999.ebuild
dev-util/mdds/metadata.xml

index cd58451961d305f972be703f3606aa6485265ab0..405c02e69d23d6729ba241b5ce137a21b3630e21 100644 (file)
@@ -1,3 +1,4 @@
+DIST mdds-1.1.0.tar.bz2 258691 SHA256 4253ab93fe8bb579321a50e247f1f800191ab99fe2d8c6c181741b8bd3fb161f SHA512 928cb6dffacdb2fe9e67dde094bbd8191137cb58402172d0fc99ed8c7aa6069668c6b1f06e515366a0843325ea051e8e0650aa2142cbc94b107a748a399d7a47 WHIRLPOOL 79ec5589ad682712244cc235c8ec7f9626208526b43839f07fff9dfc96509e232fccce801664b2c50b00dcde656cb78e8ac1e5db2fde7c807bc5507af410a83b
 DIST mdds_0.10.3.tar.bz2 151389 SHA256 db10932dbe7e9b5b9b3f513bc8165ab7e29c3bf75702b3c3cfff6956c521e0c2 SHA512 52be0fe4eedc8a44f61944e078d8f0d2490bfea27451c5d4772b6d46d71562702d3b90b34c5721d8bdf6de2ea32a4a9126e310614bb36e0d573c047dfc9f3fcb WHIRLPOOL 17a461cf01f286ccb0e8b351e627dc870db5676a3698cf99f1520b01562138a8d74fa99ccca901d81b5f354abf95ff35d2a7957a3bf2dae16d92aee12e62f8b1
 DIST mdds_0.11.2.tar.bz2 154444 SHA256 cd0a0dc8b35d6582efad6898546c86714eb058696ba26b0e7f8914faa002a5ab SHA512 b0e00d50be9b8319dabfe7e607849af27a52be9b46d770849b919444b905bf198d99edcefe1be15e6018b79839443b3a709fe22b84ac11e2267f02bec5139633 WHIRLPOOL a505c4b746c7ffefe3ea74fd0eb7c2ae46b4c598e1136cf9e9cfe44a4c48db2bb1b84528a5f0a86cc1b7a5c9d5b7d82522bd7836ed5e4de61d9664a863e1b014
 DIST mdds_0.12.0.tar.bz2 152285 SHA256 2a22de23ca828886625120e9d40fccd6333458a1934a13d2c982b6f9403e5981 SHA512 462f6e3701eb7cce872ce0a76d826886eedccf5ca20293d03744b6d6d5ff1ef16770c6abce1c9118829e252e90783e206d281006d0d4e7e9b328ed9ae37264c1 WHIRLPOOL f86314644d80ae1b75a4cc1af6ebc4a3df3b65eac4244abc0fbf69893020509abae3be7e758d90a07eafffb866d67dcb75968b38a411e747d7f361a7d2905f0b
diff --git a/dev-util/mdds/mdds-1.1.0.ebuild b/dev-util/mdds/mdds-1.1.0.ebuild
new file mode 100644 (file)
index 0000000..754707a
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
+[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
+
+inherit eutils toolchain-funcs ${GITECLASS}
+
+DESCRIPTION="A collection of multi-dimensional data structure and indexing algorithm"
+HOMEPAGE="https://gitlab.com/mdds/mdds"
+[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/${PN}/src/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="1/${PV}"
+IUSE="doc valgrind"
+
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+COMMON_DEPEND="dev-libs/boost:="
+DEPEND="${COMMON_DEPEND}
+       doc? (
+               app-doc/doxygen
+               dev-python/sphinx
+       )"
+RDEPEND="${COMMON_DEPEND}"
+
+DOCS=() # buildsystem installs docs
+
+src_prepare(){
+       eapply_user
+       [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+       econf \
+               $(use_enable doc docs) \
+               $(use_enable valgrind memory_tests) \
+               --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
+
+src_compile() { :; }
+
+src_test() {
+       tc-export CXX
+       default
+}
index e0db9959c3b9c3748dec86a74f96c46166d681af..754707aed4971386584f5bd0cb0fdab8d97b2204 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=5
+EAPI=6
 
 EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
 [[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
@@ -11,27 +11,34 @@ inherit eutils toolchain-funcs ${GITECLASS}
 
 DESCRIPTION="A collection of multi-dimensional data structure and indexing algorithm"
 HOMEPAGE="https://gitlab.com/mdds/mdds"
-[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/${PN}/src/${P/-/_}.tar.bz2"
+[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/${PN}/src/${P}.tar.bz2"
 
 LICENSE="MIT"
-SLOT="0/${PV}"
-IUSE=""
+SLOT="1/${PV}"
+IUSE="doc valgrind"
 
 [[ ${PV} == 9999 ]] || \
 KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
 
-DEPEND="dev-libs/boost:="
-RDEPEND="${DEPEND}"
+COMMON_DEPEND="dev-libs/boost:="
+DEPEND="${COMMON_DEPEND}
+       doc? (
+               app-doc/doxygen
+               dev-python/sphinx
+       )"
+RDEPEND="${COMMON_DEPEND}"
 
-[[ ${PV} == 9999 ]] || S=${WORKDIR}/${P/-/_}
+DOCS=() # buildsystem installs docs
 
 src_prepare(){
+       eapply_user
        [[ ${PV} == 9999 ]] && eautoreconf
 }
 
 src_configure() {
        econf \
-               --with-hash-container=boost \
+               $(use_enable doc docs) \
+               $(use_enable valgrind memory_tests) \
                --docdir="${EPREFIX}/usr/share/doc/${PF}"
 }
 
index 4bf2727332a9a25e33f4e17b6c2aa90f1058a71c..c054dfb0bb86d46046d56fd60026ab86975296f0 100644 (file)
@@ -8,4 +8,7 @@
        <upstream>
                <remote-id type="google-code">multidimalgorithm</remote-id>
        </upstream>
+       <use>
+               <flag name="valgrind">Add support for memory debugging using <pkg>dev-util/valgrind</pkg></flag>
+       </use>
 </pkgmetadata>