net-libs/nghttp2: Bump to version 1.36.0
authorLars Wendler <polynomial-c@gentoo.org>
Fri, 18 Jan 2019 16:46:08 +0000 (17:46 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Fri, 18 Jan 2019 16:47:35 +0000 (17:47 +0100)
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-libs/nghttp2/Manifest
net-libs/nghttp2/nghttp2-1.36.0.ebuild [new file with mode: 0644]

index 474d229ec2c40a501d18783d01c557a8a563893b..1b0e7394aacb45860f1297bb596852bb06b4147a 100644 (file)
@@ -2,3 +2,4 @@ DIST nghttp2-1.33.0.tar.xz 1554776 BLAKE2B 1b995d6385188423acbcd7c8b3a626a622270
 DIST nghttp2-1.34.0.tar.xz 1612432 BLAKE2B b5a53d5ffdb68e509cebf50993c3b9de4e597ae9079db505db6e6df67c1eb5f4b095f18dec9f1b946f05b83f3db8ba15e5e5cd7efd4921a94350bd47533a9164 SHA512 5ddc4ab443c51ce286a656d2013421172fc37608f14c0a7ea02fa9e5a0dd155e162d5602b55f34dacc69709525a9a8110dc4c42d92607bbad1951075d094c6a0
 DIST nghttp2-1.35.0.tar.xz 1616224 BLAKE2B b594e386b9a9dcd62dd75686a9274b30d3b9be5b1f2aa4dccb6543bcece60cda931bd6e16c5122ac946159547c1aafa6a02f2f013a3b38837194d4cf9a14ba64 SHA512 4e209bb6e388ee9c3440a88eb28ecb4a69e0047b089e4d028bb911dd69518a970b5b06ed6fff06594adca53dccd42443733faad909d347dd8d8e919055356e2f
 DIST nghttp2-1.35.1.tar.xz 1614460 BLAKE2B 86e078cd0fc285f76df5096c34ee3142268772cf690ec7c9abef7cc3d873ac583a1da5e331ec46138e05b5867f56a9a4e98210395d75377ff37956307c7b049f SHA512 fcd3f79f913afbeee1c75003bb39df918e6122bbf728b3ad4192d5849d8fb96705e04f5505465d63f25a565b2f1da6abd8fabdebb6e3347500f7abd31980861d
+DIST nghttp2-1.36.0.tar.xz 1629020 BLAKE2B 7c116988c22801688c50d6d514ddb904920cc54d3c3d141137e6ed8b2182ef4e670f0a0fdebaeabfe0df8cdea4cfd1ee3fb083628f035201f104de6f3614dd25 SHA512 4e0d5c5cdb4f1b7e5f12790850237f36649af4aa9596033392725972e4e0e5a33bb78bd1aa0735e35e489b523b7e9a236a7b5847dfca69bd7583fcab36c13c76
diff --git a/net-libs/nghttp2/nghttp2-1.36.0.ebuild b/net-libs/nghttp2/nghttp2-1.36.0.ebuild
new file mode 100644 (file)
index 0000000..20f8918
--- /dev/null
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: Add python support.
+
+EAPI=7
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/nghttp2/nghttp2.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+SSL_DEPEND="
+       !libressl? ( >=dev-libs/openssl-1.0.2:0=[-bindist,${MULTILIB_USEDEP}] )
+       libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
+"
+RDEPEND="
+       cxx? (
+               ${SSL_DEPEND}
+               dev-libs/boost:=[${MULTILIB_USEDEP},threads]
+       )
+       hpack-tools? ( >=dev-libs/jansson-2.5 )
+       jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
+       utils? (
+               ${SSL_DEPEND}
+               >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+               >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+               net-dns/c-ares:=[${MULTILIB_USEDEP}]
+       )
+       xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+       local myeconfargs=(
+               --disable-examples
+               --disable-failmalloc
+               --disable-werror
+               --without-cython
+               --disable-python-bindings
+               $(use_enable cxx asio-lib)
+               $(use_enable debug)
+               $(multilib_native_use_enable hpack-tools)
+               $(use_enable static-libs static)
+               $(use_enable threads)
+               $(multilib_native_use_enable utils app)
+               $(multilib_native_use_with jemalloc)
+               $(multilib_native_use_with xml libxml2)
+       )
+       ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+       use static-libs || find "${ED%/}"/usr -name '*.la' -delete
+}