Version bump.
authorChristian Zoffoli <xmerlin@gentoo.org>
Mon, 13 Mar 2006 02:08:12 +0000 (02:08 +0000)
committerChristian Zoffoli <xmerlin@gentoo.org>
Mon, 13 Mar 2006 02:08:12 +0000 (02:08 +0000)
Package-Manager: portage-2.0.51.22-r3

net-misc/ucarp/ChangeLog
net-misc/ucarp/Manifest
net-misc/ucarp/files/digest-ucarp-1.2 [new file with mode: 0644]
net-misc/ucarp/ucarp-1.2.ebuild [new file with mode: 0644]

index a5a31aa2e37850de760ea8ded4277894ea123e8c..e2717c9ef0b8b8673cf14ec9bab3e81741e70e56 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for net-misc/ucarp
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ucarp/ChangeLog,v 1.6 2005/03/01 12:43:02 xmerlin Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ucarp/ChangeLog,v 1.7 2006/03/13 02:08:12 xmerlin Exp $
+
+*ucarp-1.2 (13 Mar 2006)
+
+  13 Mar 2006; Christian Zoffoli <xmerlin@gentoo.org> +ucarp-1.2.ebuild:
+  Version bump.
 
   01 Mar 2005; Christian Zoffoli <xmerlin@gentoo.org> +metadata.xml,
   ucarp-1.1.ebuild:
index 63c2ae90bc956f8b7dd06a1a46ae2c7641c7fe46..fd9cf27207c5e4741809329bf8ac47438d95ced5 100644 (file)
@@ -1,16 +1,18 @@
 -----BEGIN PGP SIGNED MESSAGE-----
 Hash: SHA1
 
+MD5 d81f161bf3a4000665b0e04bfe9a81cc ChangeLog 1233
+MD5 c6a4990c7e7c1c7c9c532bef426fc902 metadata.xml 222
 MD5 5861d7a2edbc5841da436ac004d87f06 ucarp-0.7.ebuild 715
 MD5 5e06c67e4ec89f51ad9e89b0ad77d614 ucarp-1.1.ebuild 1114
-MD5 385612308ee8c3a9ddb2530c9b90e117 ChangeLog 1117
-MD5 c6a4990c7e7c1c7c9c532bef426fc902 metadata.xml 222
+MD5 3279193f87924c0b99511e6e89f9226e ucarp-1.2.ebuild 1115
 MD5 705d7cc5a9540cf4265ba8890308ef58 files/digest-ucarp-0.7 61
 MD5 3f0a78b9bbdbe61fd16e25ceb4ff1627 files/digest-ucarp-1.1 61
+MD5 7c4276f1d0f60ecd1cadb356e1ad7148 files/digest-ucarp-1.2 61
 -----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
+Version: GnuPG v1.4.2 (GNU/Linux)
 
-iD8DBQFCJGOHgMUyd/cdjWsRArmPAJ4poaN+HRNCwnl+eTvYWeB4o6uUlQCfd6Pi
-JiyuhgTVqBPGwgciLf1chBI=
-=iCmK
+iD8DBQFEFOLegMUyd/cdjWsRAkFYAJ49C/jyYbbHtsu/bkDIOOoLEC4jpwCePzC1
+MW6IqDqPVZ2JRZBp8hTHoB4=
+=eAbu
 -----END PGP SIGNATURE-----
diff --git a/net-misc/ucarp/files/digest-ucarp-1.2 b/net-misc/ucarp/files/digest-ucarp-1.2
new file mode 100644 (file)
index 0000000..b3666e4
--- /dev/null
@@ -0,0 +1 @@
+MD5 b1bb22758f0fe2b3efe16976bab6cf6d ucarp-1.2.tar.gz 201534
diff --git a/net-misc/ucarp/ucarp-1.2.ebuild b/net-misc/ucarp/ucarp-1.2.ebuild
new file mode 100644 (file)
index 0000000..f522037
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ucarp/ucarp-1.2.ebuild,v 1.1 2006/03/13 02:08:12 xmerlin Exp $
+
+inherit eutils
+
+DESCRIPTION="UCARP allows a couple of hosts to share common virtual IP addresses in order to provide automatic failover. It is a portable userland implementation of the secure and patent-free Common Address Redundancy Protocol (CARP, OpenBSD's alternative to the VRRP).
+Strong points of the CARP protocol are : very low overhead, cryptographically signed messages, interoperability between different operating systems and no need for any dedicated extra network link between redundant hosts.
+"
+HOMEPAGE="http://www.ucarp.org"
+LICENSE="GPL-2"
+DEPEND="virtual/libpcap"
+SRC_URI="ftp://ftp.ucarp.org/pub/ucarp/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE=""
+
+src_compile() {
+       econf || die
+       emake || die "emake failed"
+}
+
+src_install() {
+       make DESTDIR=${D} install || die
+
+       dodoc README INSTALL NEWS ChangeLog || die
+       dodoc examples/linux/vip-up.sh examples/linux/vip-down.sh
+}