dev-python/hacking: 1.1.0 stable amd64/x86
authorMatthew Thode <prometheanfire@gentoo.org>
Mon, 28 Jan 2019 00:01:48 +0000 (18:01 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Mon, 28 Jan 2019 00:25:34 +0000 (18:25 -0600)
Package-Manager: Portage-2.3.51, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/hacking/Manifest
dev-python/hacking/hacking-0.13.0.ebuild [deleted file]
dev-python/hacking/hacking-1.1.0.ebuild

index 210dffc17212c12a303c47177044b244498a6380..184d9129504b51c6bd3a7a01f8f6b5ac4d4a9874 100644 (file)
@@ -1,5 +1,4 @@
 DIST hacking-0.10.3.tar.gz 41119 BLAKE2B fe43b31f356c9469925bf43ff381c1e24d6976961140e2e3f0988d2c693db87de98b27b38ce456b4fc681bfbaff428882e7fc072cd4511935585d789850b85a4 SHA512 020f58220d6c3d09dcc1b0ab886796087c9fe4e9eccae1e331f6f2056b5b106ffa4ba2545af086cf4ee53e21bcc124fef203c7bac36456ac86f09b4c6ff07417
-DIST hacking-0.13.0.tar.gz 49171 BLAKE2B 2784f7303dc985ba8d0cc0c9d91dc76ff9b6bc02c1bbf1381e0803e753c2a4aa0560acead7e653616a2316bbd3ac073142cfc078dddea36b39b2c5e5bbef0f8e SHA512 ca3fe0bef1c6348ee9497c136d002b04c9f67a766192d88456b749ff860528a887636b1f3db23fec336749dbf3e5bb413a1effd2261e42929d5826e54336e314
 DIST hacking-0.9.2.tar.gz 43956 BLAKE2B f4bad9ca0ffaaaf05d9f0b8536ccc72c51de4547de8d38ea31f9bae1ebbb52362d75fc286075b13631362fa00e3a7081db6a128584067896bf4daf7b32f4bfeb SHA512 76aa59b4cdfb8036d6471e35cba43d502de3a72edc3883a05822063cbb92eaa072cef3144d21ee82ac763c3385c65bc9dec4b66fda5a5a2090191ba5b6388d41
 DIST hacking-0.9.6.tar.gz 43287 BLAKE2B e67090fe103849fd9cb4cd4ea36065d49500448cc291ffa2c36273095a2de4a704af2f3a926aef0ffe4aa4689ef7f810f317f0ed46e9c7143039ab776b04bfe5 SHA512 e4225754a85ff474b724130a0c3d6a6b9c480a953ea35a18833378cf2a5df4687819f510b50a95f42890cc69836033a8af933bc0a5a4e330ae94532bcee189b4
 DIST hacking-1.1.0.tar.gz 55620 BLAKE2B 6a6f30ef8a1eef3aa1b1b630dd43e1d2e9adff1623d8db19a545f186f60ce367e4b820582893e6444b7d58573b4a70a47a30cdc8d2ce1202666cf6e1b0e7456f SHA512 d326995976c04469c9d164ff31d02471346af715730d97fee23261988100156c4598ea8968cb483e8f386ee3f94a6bdffb5f67d8a7dfc238f4607fb7fe09e128
diff --git a/dev-python/hacking/hacking-0.13.0.ebuild b/dev-python/hacking/hacking-0.13.0.ebuild
deleted file mode 100644 (file)
index 9e30c64..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="A client for the OpenStack Nova API"
-HOMEPAGE="https://github.com/openstack-dev/hacking"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/pbr-1.6[${PYTHON_USEDEP}]
-       test? (
-               >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
-               >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
-               >=dev-python/mock-1.0[${PYTHON_USEDEP}]
-               >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
-               >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
-               >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
-               >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
-               ${RDEPEND}
-       )
-       doc? (
-               >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
-               <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/oslo-sphinx[${PYTHON_USEDEP}]' python2_7 )
-       )"
-RDEPEND="
-       ~dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
-       ~dev-python/pyflakes-0.8.1[${PYTHON_USEDEP}]
-       <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
-       >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
-       ~dev-python/mccabe-0.2.1[${PYTHON_USEDEP}]
-       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
-       # Prevent d'loading and correct ?typo to oslosphinx in conf.py
-       sed -e 's:intersphinx_mapping:#&:' \
-               -e 's:oslosphinx:oslo.sphinx:' \
-               -i doc/source/conf.py || die
-       # relax deps
-       rm *requirements.txt hacking.egg-info/requires.txt || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && sphinx-build -b html -c doc/source/ doc/source/ doc/source/html
-}
-
-python_test() {
-       testr init || die "testr init died"
-       testr run || die "testsuite failed under ${EPYTHON}"
-       flake8 "${PN}"/tests || die "flake8 drew error on a run over ${PN}/tests folder"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/source/html/. )
-       distutils-r1_python_install_all
-}
index c78023fe00587ddee7a1831668f2c2014286cd67..6b5bc774fe4daf5f3268be0cd93ac89a37b62a4c 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="Apache-2.0"
 SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~hppa ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ~arm64 ~hppa ~ppc64 x86 ~amd64-linux ~x86-linux"
 IUSE="doc test"
 
 RDEPEND="