sci-electronics/kicad: Switch to PYTHON_MULTI_USEDEP API
authorMichał Górny <mgorny@gentoo.org>
Fri, 7 Feb 2020 18:59:18 +0000 (19:59 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 9 Feb 2020 16:35:23 +0000 (17:35 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sci-electronics/kicad/kicad-4.0.7-r1.ebuild [moved from sci-electronics/kicad/kicad-4.0.7.ebuild with 96% similarity]
sci-electronics/kicad/kicad-5.0.1.ebuild
sci-electronics/kicad/kicad-5.1.0-r1.ebuild
sci-electronics/kicad/kicad-5.1.2-r1.ebuild
sci-electronics/kicad/kicad-5.1.4.ebuild
sci-electronics/kicad/kicad-5.1.5-r1.ebuild [moved from sci-electronics/kicad/kicad-5.1.5.ebuild with 94% similarity]

similarity index 96%
rename from sci-electronics/kicad/kicad-4.0.7.ebuild
rename to sci-electronics/kicad/kicad-4.0.7-r1.ebuild
index 624172e8994a3d7583dcaf2d3f19e6c10df73320..a85b949bc42d4d052ec6de5d4014d8f7a6fc518c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -33,11 +33,13 @@ REQUIRED_USE="
        python? ( ${PYTHON_REQUIRED_USE} )"
 
 COMMON_DEPEND=">=x11-libs/wxGTK-3.0.2:${WX_GTK_VER}[X,opengl]
-       python? (
-               dev-python/wxpython:${WX_GTK_VER}[opengl,${PYTHON_USEDEP}]
-               ${PYTHON_DEPS}
-       )
-       >=dev-libs/boost-1.61:=[context,nls,threads,python?,${PYTHON_USEDEP}]
+       $(python_gen_cond_dep "
+               python? (
+                       dev-python/wxpython:${WX_GTK_VER}[opengl,\${PYTHON_MULTI_USEDEP}]
+                       ${PYTHON_DEPS}
+               )
+               >=dev-libs/boost-1.61:=[context,nls,threads,python?,\${PYTHON_MULTI_USEDEP}]
+       ")
        github? (
                libressl? ( dev-libs/libressl:0= )
                !libressl? ( dev-libs/openssl:0= )
index a9f2e30229b26cacf822f66226e41a34ce11b8bc..cb1d50631ac0e474baa5da6c993ff82e088b855d 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -23,11 +23,13 @@ REQUIRED_USE="
 "
 
 COMMON_DEPEND=">=x11-libs/wxGTK-3.0.2:${WX_GTK_VER}[X,opengl]
-       python? (
-               dev-python/wxpython:${WX_GTK_VER}[opengl,${PYTHON_USEDEP}]
-               ${PYTHON_DEPS}
-       )
-       >=dev-libs/boost-1.61:=[context,nls,threads,python?,${PYTHON_USEDEP}]
+       $(python_gen_cond_dep "
+               python? (
+                       dev-python/wxpython:${WX_GTK_VER}[opengl,\${PYTHON_MULTI_USEDEP}]
+                       ${PYTHON_DEPS}
+               )
+               >=dev-libs/boost-1.61:=[context,nls,threads,python?,\${PYTHON_MULTI_USEDEP}]
+       ")
        github? ( net-misc/curl:=[ssl] )
        media-libs/glew:0=
        media-libs/glm
index 6646e63fac8cf98ea783cfe7477aa391c66b6cf7..8c93a13852a007e9e00b73190897e73d9053bc65 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 # Can switch to EAPI=7 when wxwidgets eclass also supports it
@@ -24,11 +24,13 @@ REQUIRED_USE="
 "
 
 COMMON_DEPEND=">=x11-libs/wxGTK-3.0.2:${WX_GTK_VER}[X,opengl]
-       python? (
-               dev-python/wxpython:${WX_GTK_VER}[opengl,${PYTHON_USEDEP}]
-               ${PYTHON_DEPS}
-       )
-       >=dev-libs/boost-1.61:=[context,nls,threads,python?,${PYTHON_USEDEP}]
+       $(python_gen_cond_dep "
+               python? (
+                       dev-python/wxpython:${WX_GTK_VER}[opengl,\${PYTHON_MULTI_USEDEP}]
+                       ${PYTHON_DEPS}
+               )
+               >=dev-libs/boost-1.61:=[context,nls,threads,python?,\${PYTHON_MULTI_USEDEP}]
+       ")
        github? ( net-misc/curl:=[ssl] )
        media-libs/glew:0=
        media-libs/glm
index eaf36e9596e6c45fda7efd7e70ffc046669f7d3d..377f42f962a0878af4797f91afc18ee385f1e0bc 100644 (file)
@@ -24,11 +24,13 @@ REQUIRED_USE="
 "
 
 COMMON_DEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
-       python? (
-               dev-python/wxpython:4.0[${PYTHON_USEDEP}]
-               ${PYTHON_DEPS}
-       )
-       >=dev-libs/boost-1.61:=[context,nls,threads,python?,${PYTHON_USEDEP}]
+       $(python_gen_cond_dep "
+               python? (
+                       dev-python/wxpython:4.0[\${PYTHON_MULTI_USEDEP}]
+                       ${PYTHON_DEPS}
+               )
+               >=dev-libs/boost-1.61:=[context,nls,threads,python?,\${PYTHON_MULTI_USEDEP}]
+       ")
        github? ( net-misc/curl:=[ssl] )
        media-libs/glew:0=
        media-libs/glm
index b442e402be3216a67a2670cc58d0c054e07ecfb2..68c690312a8adb4efd0a9c42544a498355650b47 100644 (file)
@@ -24,11 +24,13 @@ REQUIRED_USE="
 "
 
 COMMON_DEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
-       python? (
-               dev-python/wxpython:4.0[${PYTHON_USEDEP}]
-               ${PYTHON_DEPS}
-       )
-       >=dev-libs/boost-1.61:=[context,nls,threads,python?,${PYTHON_USEDEP}]
+       $(python_gen_cond_dep "
+               python? (
+                       dev-python/wxpython:4.0[\${PYTHON_MULTI_USEDEP}]
+                       ${PYTHON_DEPS}
+               )
+               >=dev-libs/boost-1.61:=[context,nls,threads,python?,\${PYTHON_MULTI_USEDEP}]
+       ")
        github? ( net-misc/curl:=[ssl] )
        media-libs/glew:0=
        >=media-libs/glm-0.9.9.1
similarity index 94%
rename from sci-electronics/kicad/kicad-5.1.5.ebuild
rename to sci-electronics/kicad/kicad-5.1.5-r1.ebuild
index 46baaff613c721597c44c5a352767bddc62950fe..af08ef9e488ca88786c5df1bdc992e3765656b44 100644 (file)
@@ -24,7 +24,7 @@ REQUIRED_USE="
 "
 
 COMMON_DEPEND="
-       >=dev-libs/boost-1.61:=[context,nls,threads,python?,${PYTHON_USEDEP}]
+       >=dev-libs/boost-1.61:=[context,nls,threads]
        media-libs/freeglut
        media-libs/glew:0=
        >=media-libs/glm-0.9.9.1
@@ -39,7 +39,10 @@ COMMON_DEPEND="
        occ? ( >=sci-libs/opencascade-6.8.0:= )
        oce? ( sci-libs/oce )
        python? (
-               dev-python/wxpython:4.0[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep '
+                       >=dev-libs/boost-1.61:=[context,nls,threads,python,${PYTHON_MULTI_USEDEP}]
+                       dev-python/wxpython:4.0[${PYTHON_MULTI_USEDEP}]
+               ')
                ${PYTHON_DEPS}
        )
 "