gnome-base/gnome-session: Version bump
authorPacho Ramos <pacho@gentoo.org>
Sat, 14 Nov 2015 19:16:00 +0000 (20:16 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sat, 14 Nov 2015 19:45:22 +0000 (20:45 +0100)
Package-Manager: portage-2.2.24

gnome-base/gnome-session/Manifest
gnome-base/gnome-session/gnome-session-3.18.1.2.ebuild [new file with mode: 0644]

index 3cd2f940a17585a5496376593233d369ca2a4957..09fe87968cc0c9577667ae11de854b0351f14e28 100644 (file)
@@ -1,2 +1,3 @@
 DIST gnome-session-3.14.0.tar.xz 736128 SHA256 b1e6e805478b863eda58e61ecd0e13961f63dd76e2d49692affc5a1d00f2c184 SHA512 7a1b1bd229e38963d5e104fd9b649ab597b4026a59b87820c8517699e63cb066f2aa52b74eb30a052dc4017c30eb16dc16a779a14580af9c1e876edcdd9bd020 WHIRLPOOL a756904a53c7e84dee6d85a2066fe8993f338021e1c07d65c025b1cbae03fedaa169fd19c02203dfc962b69b99d8d3926c17324f15e62e7b6c7e633927140cfa
 DIST gnome-session-3.16.0.tar.xz 764808 SHA256 9b546d455edd9d681070a61c98a4164557f89ebbd66367a2aa528d807dfea99d SHA512 4f02e73ab632ce0c2b961f1d88d93ef62fb6ebfa39d98bf12e672ca7cd9680d07aeffcd3c8792eddcbd9b5e13b0ef87d064352d8f209b3befd8445c1ba17e485 WHIRLPOOL 18ae75ccf4c3b67dfb8b941552317f5739a9ac54d9e8ef2c220e388f2f91687bee05127dcdbd132137b8f7996585ce1ba2a82877cc00eb787d7c5e24d032faf2
+DIST gnome-session-3.18.1.2.tar.xz 758552 SHA256 b37d823d57ff2e3057401a426279954699cfe1e44e59a4cbdd941687ff928a45 SHA512 741da4ebdc6eccef35ee3e1be124785ad7e2e6de49c2fbb88568cff91c8cd5133e71064d8c74181052a9ce4df446fad7358bb61fc1d1a5746ab76a655d35f72a WHIRLPOOL 1c47dd8bc186c3a22519a306ec15f332d00824110202296508211cf0efb4f7def29d72795b6987e8795bd9b974758f8f269ed1fbfb646da3655f0e8429655def
diff --git a/gnome-base/gnome-session/gnome-session-3.18.1.2.ebuild b/gnome-base/gnome-session/gnome-session-3.18.1.2.ebuild
new file mode 100644 (file)
index 0000000..be683fa
--- /dev/null
@@ -0,0 +1,123 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="Gnome session manager"
+HOMEPAGE="https://git.gnome.org/browse/gnome-session"
+
+LICENSE="GPL-2 LGPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc elibc_FreeBSD ipv6 systemd"
+
+# x11-misc/xdg-user-dirs{,-gtk} are needed to create the various XDG_*_DIRs, and
+# create .config/user-dirs.dirs which is read by glib to get G_USER_DIRECTORY_*
+# xdg-user-dirs-update is run during login (see 10-user-dirs-update-gnome below).
+# gdk-pixbuf used in the inhibit dialog
+COMMON_DEPEND="
+       >=dev-libs/glib-2.46.0:2[dbus]
+       x11-libs/gdk-pixbuf:2
+       >=x11-libs/gtk+-3.18.0:3
+       >=dev-libs/json-glib-0.10
+       >=gnome-base/gnome-desktop-3.9.91:3=
+       elibc_FreeBSD? ( dev-libs/libexecinfo )
+
+       virtual/opengl
+       x11-libs/libSM
+       x11-libs/libICE
+       x11-libs/libXau
+       x11-libs/libX11
+       x11-libs/libXcomposite
+       x11-libs/libXext
+       x11-libs/libXrender
+       x11-libs/libXtst
+       x11-misc/xdg-user-dirs
+       x11-misc/xdg-user-dirs-gtk
+       x11-apps/xdpyinfo
+
+       systemd? ( >=sys-apps/systemd-183:0= )
+"
+# Pure-runtime deps from the session files should *NOT* be added here
+# Otherwise, things like gdm pull in gnome-shell
+# gnome-themes-standard is needed for the failwhale dialog themeing
+# sys-apps/dbus[X] is needed for session management
+RDEPEND="${COMMON_DEPEND}
+       gnome-base/gnome-settings-daemon
+       >=gnome-base/gsettings-desktop-schemas-0.1.7
+       >=x11-themes/gnome-themes-standard-2.91.92
+       sys-apps/dbus[X]
+       !systemd? (
+               sys-auth/consolekit
+               >=dev-libs/dbus-glib-0.76
+       )
+"
+DEPEND="${COMMON_DEPEND}
+       >=dev-lang/perl-5
+       >=sys-devel/gettext-0.10.40
+       dev-libs/libxslt
+       >=dev-util/intltool-0.40.6
+       virtual/pkgconfig
+       !<gnome-base/gdm-2.20.4
+       doc? (
+               app-text/xmlto
+               dev-libs/libxslt )
+"
+# gnome-common needed for eautoreconf
+# gnome-base/gdm does not provide gnome.desktop anymore
+
+src_configure() {
+       # 1. Avoid automagic on old upower releases
+       # 2. xsltproc is always checked due to man configure
+       #    switch, even if USE=-doc
+       # 3. Disable old gconf support as other distributions did long time
+       #    ago
+       gnome2_src_configure \
+               --disable-deprecation-flags \
+               --disable-gconf \
+               --enable-session-selector \
+               $(use_enable doc docbook-docs) \
+               $(use_enable ipv6) \
+               $(use_enable systemd) \
+               $(use_enable !systemd consolekit) \
+               UPOWER_CFLAGS="" \
+               UPOWER_LIBS=""
+               # gnome-session-selector pre-generated man page is missing
+               #$(usex !doc XSLTPROC=$(type -P true))
+}
+
+src_install() {
+       gnome2_src_install
+
+       dodir /etc/X11/Sessions
+       exeinto /etc/X11/Sessions
+       doexe "${FILESDIR}/Gnome"
+
+       insinto /usr/share/applications
+       newins "${FILESDIR}/defaults.list-r3" gnome-mimeapps.list
+
+       dodir /etc/X11/xinit/xinitrc.d/
+       exeinto /etc/X11/xinit/xinitrc.d/
+       newexe "${FILESDIR}/15-xdg-data-gnome-r1" 15-xdg-data-gnome
+
+       # This should be done here as discussed in bug #270852
+       newexe "${FILESDIR}/10-user-dirs-update-gnome-r1" 10-user-dirs-update-gnome
+
+       # Set XCURSOR_THEME from current dconf setting instead of installing
+       # default cursor symlink globally and affecting other DEs (bug #543488)
+       # https://bugzilla.gnome.org/show_bug.cgi?id=711703
+       newexe "${FILESDIR}/90-xcursor-theme-gnome" 90-xcursor-theme-gnome
+}
+
+pkg_postinst() {
+       gnome2_pkg_postinst
+
+       if ! has_version gnome-base/gdm && ! has_version kde-base/kdm; then
+               ewarn "If you use a custom .xinitrc for your X session,"
+               ewarn "make sure that the commands in the xinitrc.d scripts are run."
+       fi
+}