dev-perl/GeoIP2: Add w/ v=2.6.2
authorKent Fredric <kentnl@gentoo.org>
Tue, 4 Feb 2020 06:25:05 +0000 (19:25 +1300)
committerKent Fredric <kentnl@gentoo.org>
Wed, 5 Feb 2020 01:02:04 +0000 (14:02 +1300)
Provides access to GeoIP2 databases used for example by
SpamAssasssin to map IP addresses to geo locations.

Suggested by Tomáš Mózes

Closes: https://github.com/gentoo/gentoo/pull/13973
Closes: https://bugs.gentoo.org/675494
Package-Manager: Portage-2.3.86, Repoman-2.3.20
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/GeoIP2/GeoIP2-2.6.2.ebuild [new file with mode: 0644]
dev-perl/GeoIP2/Manifest [new file with mode: 0644]
dev-perl/GeoIP2/metadata.xml [new file with mode: 0644]

diff --git a/dev-perl/GeoIP2/GeoIP2-2.6.2.ebuild b/dev-perl/GeoIP2/GeoIP2-2.6.2.ebuild
new file mode 100644 (file)
index 0000000..1d22f4b
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MAXMIND
+DIST_VERSION=2.006002
+inherit perl-module
+
+DESCRIPTION="API for MaxMind's GeoIP2 web services and databases"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       virtual/perl-Data-Dumper
+       >=dev-perl/Data-Validate-IP-0.250.0
+       virtual/perl-Exporter
+       virtual/perl-Getopt-Long
+       dev-perl/HTTP-Message
+       dev-perl/JSON-MaybeXS
+       dev-perl/LWP-Protocol-https
+       dev-perl/libwww-perl
+       dev-perl/List-SomeUtils
+       virtual/perl-MIME-Base64
+       >=dev-perl/MaxMind-DB-Reader-1.0.0
+       dev-perl/Moo
+       dev-perl/Params-Validate
+       virtual/perl-Scalar-List-Utils
+       dev-perl/Sub-Quote
+       dev-perl/Throwable
+       dev-perl/Try-Tiny
+       dev-perl/URI
+       dev-perl/namespace-clean
+"
+BDEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+       test? (
+               virtual/perl-File-Spec
+               virtual/perl-IO-Compress
+               dev-perl/MaxMind-DB-Common
+               dev-perl/Path-Class
+               dev-perl/Test-Fatal
+               dev-perl/Test-Number-Delta
+               >=virtual/perl-Test-Simple-0.960.0
+       )
+"
diff --git a/dev-perl/GeoIP2/Manifest b/dev-perl/GeoIP2/Manifest
new file mode 100644 (file)
index 0000000..6454c80
--- /dev/null
@@ -0,0 +1 @@
+DIST GeoIP2-2.006002.tar.gz 249915 BLAKE2B c1635de576e0c7f0ebad85bb3d850d6fbc979108777c494ec1685b4ce68b87c895e46df904b9cde5712b9d6aa9f6b341b66c024459f6cf88546f2e6ef6732c0f SHA512 a552c6487b340aa928cfc6ce037724cf0fa98332b731388734bc2b25e7d1a31e2c45c0cd12b6c962b5b483172837587254d742fb04cbcec67586d92dae71e356
diff --git a/dev-perl/GeoIP2/metadata.xml b/dev-perl/GeoIP2/metadata.xml
new file mode 100644 (file)
index 0000000..e3f764d
--- /dev/null
@@ -0,0 +1,51 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="project">
+    <email>perl@gentoo.org</email>
+    <name>Gentoo Perl Project</name>
+  </maintainer>
+  <maintainer type="person">
+    <email>hydrapolic@gmail.com</email>
+    <name>Tomáš Mózes</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="cpan">GeoIP2</remote-id>
+    <remote-id type="cpan-module">GeoIP2</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Database::Reader</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Error::Generic</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Error::HTTP</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Error::IPAddressNotFound</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Error::Type</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Error::WebService</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Model::ASN</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Model::AnonymousIP</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Model::City</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Model::ConnectionType</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Model::Country</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Model::Domain</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Model::Enterprise</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Model::ISP</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Model::Insights</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Record::City</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Record::Continent</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Record::Country</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Record::Location</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Record::MaxMind</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Record::Postal</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Record::RepresentedCountry</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Record::Subdivision</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Record::Traits</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Role::Error::HTTP</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Role::HasIPAddress</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Role::HasLocales</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Role::Model</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Role::Model::Flat</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Role::Model::HasSubdivisions</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Role::Model::Location</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Role::Record::Country</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Role::Record::HasNames</remote-id>
+    <remote-id type="cpan-module">GeoIP2::Types</remote-id>
+    <remote-id type="cpan-module">GeoIP2::WebService::Client</remote-id>
+  </upstream>
+</pkgmetadata>