Remove old version
authorTristan Heaven <tristan@gentoo.org>
Mon, 9 Oct 2006 10:36:57 +0000 (10:36 +0000)
committerTristan Heaven <tristan@gentoo.org>
Mon, 9 Oct 2006 10:36:57 +0000 (10:36 +0000)
Package-Manager: portage-2.1.2_pre2-r6

games-emulation/psemu-peopssoftgpu/files/psemu-peopssoftgpu-1.17-fix-noxf86vm.patch [new file with mode: 0644]
games-emulation/psemu-peopssoftgpu/files/psemu-peopssoftgpu-1.17-makefile-cflags.patch [new file with mode: 0644]
games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.17.ebuild

diff --git a/games-emulation/psemu-peopssoftgpu/files/psemu-peopssoftgpu-1.17-fix-noxf86vm.patch b/games-emulation/psemu-peopssoftgpu/files/psemu-peopssoftgpu-1.17-fix-noxf86vm.patch
new file mode 100644 (file)
index 0000000..96ffcc9
--- /dev/null
@@ -0,0 +1,24 @@
+Make sure we can compile when video mode switching has been disabled.
+
+http://bugs.gentoo.org/show_bug.cgi?id=87716
+
+By Wormo <@gentoo.org>
+
+--- src/draw.c
++++ src/draw.c
+@@ -3847,6 +3847,7 @@
+ }
+ #endif
++#ifdef USE_XF86VM
+ // Selects the mode with the highest vertical refresh frequency
+ // from all modes with resolution iResX and iResY.
+ // Returns -1 if no mode is found.
+@@ -3871,6 +3872,7 @@
+     }
+     return bestmode;
+ }
++#endif
+ // Create display
diff --git a/games-emulation/psemu-peopssoftgpu/files/psemu-peopssoftgpu-1.17-makefile-cflags.patch b/games-emulation/psemu-peopssoftgpu/files/psemu-peopssoftgpu-1.17-makefile-cflags.patch
new file mode 100644 (file)
index 0000000..0624f0d
--- /dev/null
@@ -0,0 +1,13 @@
+--- src/makes/plg.mk
++++ src/makes/plg.mk
+@@ -4,1 +4,1 @@
+-CFLAGS = -g -Wall -fPIC -O4 -fomit-frame-pointer -ffast-math $(INCLUDE)
++CFLAGS = -Wall -fPIC $(OPTFLAGS) $(INCLUDE)
+--- src/makes/mk.fpse
++++ src/makes/mk.fpse
+@@ -7,1 +7,1 @@
+-INCLUDE += -I./fpse `gtk-config --cflags`
++INCLUDE += -I./fpse `gtk-config --cflags` `sdl-config --cflags`
+@@ -10,1 +10,1 @@
+-LIBS += -lSDL
++LIBS += `sdl-config --libs`
index a395c9d84b9b429dbf9c85fa59cf3d6ebaa7edfb..ffe7e3c787f5f83841c3744bff6f45b61bb31a84 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.17.ebuild,v 1.4 2006/07/10 23:04:16 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.17.ebuild,v 1.5 2006/10/09 10:36:57 nyhm Exp $
 
 inherit eutils games
 
@@ -19,11 +19,8 @@ DEPEND="${RDEPEND}
        dev-util/pkgconfig
        x86? ( dev-lang/nasm )
        amd64? ( dev-lang/nasm )
-       || ( ( x11-proto/xf86dgaproto
-                       x11-proto/xf86vidmodeproto
-               )
-               virtual/x11
-       )"
+       x11-proto/xf86dgaproto
+       x11-proto/xf86vidmodeproto"
 
 S=${WORKDIR}
 
@@ -32,8 +29,8 @@ src_unpack() {
        cd "${S}"
        edos2unix src/makes/mk.fpse
        epatch \
-               "${FILESDIR}"/${PN}-1.16-makefile-cflags.patch \
-               "${FILESDIR}"/${PN}-1.16-fix-noxf86vm.patch \
+               "${FILESDIR}"/${P}-makefile-cflags.patch \
+               "${FILESDIR}"/${P}-fix-noxf86vm.patch \
                "${FILESDIR}"/${P}-gcc41.patch
 
        if [[ ${ARCH} != "x86" ]] ; then