dev-python/xmlschema: Port to py39
authorMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 10:44:27 +0000 (12:44 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 12:58:24 +0000 (14:58 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/xmlschema/xmlschema-1.1.3.ebuild

index e1579bdefa23d09a287e3e3e0256f7c82b41a06f..39121bed8bc388775196be1e9725abb519b762d7 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
 inherit distutils-r1
 
 DESCRIPTION="An XML Schema validator and decoder"
@@ -19,7 +19,6 @@ RESTRICT="!test? ( test )"
 RDEPEND="
        =dev-python/elementpath-1.4*[${PYTHON_USEDEP}]"
 BDEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
                dev-python/lxml[${PYTHON_USEDEP}]
        )"