dev-ml/ocsigen-start: add missing dep on ocaml-imagemagick and drop now useless patch
authorAlexis Ballier <aballier@gentoo.org>
Wed, 4 Jan 2017 11:38:26 +0000 (12:38 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 4 Jan 2017 11:58:30 +0000 (12:58 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ml/ocsigen-start/files/magick.patch [deleted file]
dev-ml/ocsigen-start/ocsigen-start-0.99.ebuild
dev-ml/ocsigen-start/ocsigen-start-9999.ebuild

diff --git a/dev-ml/ocsigen-start/files/magick.patch b/dev-ml/ocsigen-start/files/magick.patch
deleted file mode 100644 (file)
index ee4f068..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: ocsigen-start-9999/Makefile.options
-===================================================================
---- ocsigen-start-9999.orig/Makefile.options
-+++ ocsigen-start-9999/Makefile.options
-@@ -39,7 +39,7 @@ TEMPLATE_NAME      := os.pgocaml
- # OCamlfind packages for the server
- SERVER_PACKAGES    := lwt.ppx js_of_ocaml.deriving.ppx calendar safepass \
--                      ocsigen-toolkit.server magick yojson
-+                      ocsigen-toolkit.server libMagick yojson
- SERVER_DB_PACKAGES := pgocaml pgocaml.syntax macaque.syntax calendar safepass
index 3439208e10f20d48e99bea16c73672b5b6a8205a..40c33e6883bb48cf65483c12c8a7c748abfab34c 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI=5
 
-inherit findlib eutils
+inherit findlib
 
 DESCRIPTION="Eliom Base Application with users, (pre)registration, notifications, etc."
 HOMEPAGE="https://github.com/ocsigen/ocsigen-start"
@@ -31,13 +31,10 @@ RDEPEND="dev-lang/ocaml:=
        dev-ml/ocsigen-toolkit:=
        dev-ml/ppx_deriving:=
        dev-ml/yojson:=
+       dev-ml/OCaml-ImageMagick:=
 "
 DEPEND="${RDEPEND}"
 
-src_prepare() {
-       epatch "${FILESDIR}/magick.patch"
-}
-
 src_install() {
        findlib_src_preinst
        DESTDIR="${ED}" OCAMLPATH="${OCAMLFIND_DESTDIR}" emake install
index 3439208e10f20d48e99bea16c73672b5b6a8205a..40c33e6883bb48cf65483c12c8a7c748abfab34c 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI=5
 
-inherit findlib eutils
+inherit findlib
 
 DESCRIPTION="Eliom Base Application with users, (pre)registration, notifications, etc."
 HOMEPAGE="https://github.com/ocsigen/ocsigen-start"
@@ -31,13 +31,10 @@ RDEPEND="dev-lang/ocaml:=
        dev-ml/ocsigen-toolkit:=
        dev-ml/ppx_deriving:=
        dev-ml/yojson:=
+       dev-ml/OCaml-ImageMagick:=
 "
 DEPEND="${RDEPEND}"
 
-src_prepare() {
-       epatch "${FILESDIR}/magick.patch"
-}
-
 src_install() {
        findlib_src_preinst
        DESTDIR="${ED}" OCAMLPATH="${OCAMLFIND_DESTDIR}" emake install