dev-games/physfs: Synced live ebuild.
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 3 Oct 2017 20:16:02 +0000 (22:16 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 3 Oct 2017 20:59:26 +0000 (22:59 +0200)
Package-Manager: Portage-2.3.11, Repoman-2.3.3

dev-games/physfs/physfs-9999.ebuild

index 174aa4f1c98e931ec5f88c2d5ff83f5932130d2c..27e3aeb6c95622ce99741c5432676f3c9df06e94 100644 (file)
@@ -16,10 +16,12 @@ fi
 
 LICENSE="ZLIB"
 SLOT="0"
-IUSE="doc grp hog mvl qpak static-libs wad +zip"
+IUSE="grp hog mvl qpak static-libs wad +zip"
 
 RDEPEND=""
-DEPEND="doc? ( app-doc/doxygen )"
+DEPEND=""
+
+DOCS=( docs/CHANGELOG.txt docs/CREDITS.txt docs/TODO.txt )
 
 src_prepare() {
        default
@@ -46,18 +48,3 @@ src_configure() {
 
        cmake-multilib_src_configure
 }
-
-src_compile() {
-       cmake-multilib_src_compile
-
-       if multilib_is_native_abi && use doc ; then
-               doxygen || die "doxygen failed"
-       fi
-}
-
-src_install() {
-       local DOCS=( docs/CHANGELOG.txt docs/CREDITS.txt docs/TODO.txt )
-       local HTML_DOCS=$(usex doc 'docs/html/*' '')
-
-       cmake-multilib_src_install
-}