dev-perl/Expect: Add dependency on dev-perl/IO-Stty (bug #355535) github/pr/135
authorKent Fredric <kentfredric@gmail.com>
Sun, 27 Sep 2015 07:18:50 +0000 (20:18 +1300)
committerKent Fredric <kentfredric@gmail.com>
Sun, 27 Sep 2015 07:18:50 +0000 (20:18 +1300)
Dependency added under default conditions and can be opt-out of with
USE=minimal for people who have truely tight tree requirements.

But should be installed by default as code paths can accidentally require it.

Package-Manager: portage-2.2.22

dev-perl/Expect/Expect-1.320.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-perl/Expect/Expect-1.320.0-r1.ebuild b/dev-perl/Expect/Expect-1.320.0-r1.ebuild
new file mode 100644 (file)
index 0000000..585829f
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SZABGAB
+MODULE_VERSION=1.32
+inherit perl-module
+
+DESCRIPTION="Expect for Perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test minimal"
+
+RDEPEND="
+       virtual/perl-Carp
+       virtual/perl-Exporter
+       virtual/perl-IO
+       >=dev-perl/IO-Tty-1.110.0
+       !minimal? (
+               dev-perl/IO-Stty
+       )
+"
+DEPEND="${RDEPEND}
+       >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+       test? (
+               virtual/perl-File-Temp
+               >=dev-perl/Test-Exception-0.320.0
+               virtual/perl-Test-Simple
+       )
+"
+
+SRC_TEST="do parallel"