net-im/pyicq-t: Move fixed -r6 to stable and remove old
authorTobias Klausmann <klausman@gentoo.org>
Sat, 24 Dec 2016 11:04:36 +0000 (12:04 +0100)
committerTobias Klausmann <klausman@gentoo.org>
Sat, 24 Dec 2016 11:05:55 +0000 (12:05 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

net-im/pyicq-t/pyicq-t-0.8.1.5-r4.ebuild [deleted file]
net-im/pyicq-t/pyicq-t-0.8.1.5-r5.ebuild [deleted file]
net-im/pyicq-t/pyicq-t-0.8.1.5-r6.ebuild

diff --git a/net-im/pyicq-t/pyicq-t-0.8.1.5-r4.ebuild b/net-im/pyicq-t/pyicq-t-0.8.1.5-r4.ebuild
deleted file mode 100644 (file)
index d5fd407..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-inherit eutils python-single-r1 systemd
-
-MY_P="${P/pyicq-t/pyicqt}"
-DESCRIPTION="Python based jabber transport for ICQ"
-HOMEPAGE="https://code.google.com/p/pyicqt/"
-SRC_URI="https://pyicqt.googlecode.com/files/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="webinterface"
-
-DEPEND="net-im/jabber-base"
-RDEPEND="${DEPEND}
-       dev-python/twisted-core[${PYTHON_USEDEP}]
-       dev-python/twisted-words[${PYTHON_USEDEP}]
-       dev-python/twisted-web[${PYTHON_USEDEP}]
-       webinterface? ( >=dev-python/nevow-0.4.1[${PYTHON_USEDEP}] )
-       dev-python/pillow[${PYTHON_USEDEP}]"
-
-src_prepare() {
-       epatch "${FILESDIR}/${P}-python26-warnings.diff"
-       epatch "${FILESDIR}/${P}-pillow-imaging.patch"
-}
-
-src_install() {
-       python_moduleinto ${PN}
-       cp PyICQt.py ${PN}.py || die
-       python_domodule ${PN}.py data tools src
-
-       insinto /etc/jabber
-       newins config_example.xml ${PN}.xml
-       fperms 600 /etc/jabber/${PN}.xml
-       fowners jabber:jabber /etc/jabber/${PN}.xml
-       fperms 755 "$(python_get_sitedir)/${PN}/${PN}.py"
-       sed -i \
-               -e "s:<spooldir>[^\<]*</spooldir>:<spooldir>/var/spool/jabber</spooldir>:" \
-               -e "s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \
-               "${ED}/etc/jabber/${PN}.xml" || die
-
-       newinitd "${FILESDIR}/${PN}-0.8-initd-r1" ${PN}
-       systemd_dounit "${FILESDIR}/${PN}.service"
-       sed -i -e "s:INSPATH:$(python_get_sitedir)/${PN}:" \
-               "${ED}/etc/init.d/${PN}" "${ED}/usr/lib/systemd/system/${PN}.service" || die
-
-       python_fix_shebang "${D}$(python_get_sitedir)/${PN}"
-}
diff --git a/net-im/pyicq-t/pyicq-t-0.8.1.5-r5.ebuild b/net-im/pyicq-t/pyicq-t-0.8.1.5-r5.ebuild
deleted file mode 100644 (file)
index a4d1d38..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="6"
-PYTHON_COMPAT=( python2_7 )
-inherit eutils python-single-r1 systemd
-
-MY_P="${P/pyicq-t/pyicqt}"
-DESCRIPTION="Python based jabber transport for ICQ"
-HOMEPAGE="https://code.google.com/p/pyicqt/"
-SRC_URI="https://pyicqt.googlecode.com/files/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="webinterface"
-
-DEPEND="net-im/jabber-base"
-RDEPEND="${DEPEND}
-       dev-python/twisted-core[${PYTHON_USEDEP}]
-       dev-python/twisted-words[${PYTHON_USEDEP}]
-       dev-python/twisted-web[${PYTHON_USEDEP}]
-       webinterface? ( >=dev-python/nevow-0.4.1[${PYTHON_USEDEP}] )
-       dev-python/pillow[${PYTHON_USEDEP}]"
-
-src_prepare() {
-       eapply "${FILESDIR}/${P}-python26-warnings.diff"
-       eapply "${FILESDIR}/${P}-pillow-imaging.patch"
-       eapply_user
-}
-
-src_install() {
-       python_moduleinto ${PN}
-       cp PyICQt.py ${PN}.py || die
-       python_domodule ${PN}.py data tools src
-
-       insinto /etc/jabber
-       newins config_example.xml ${PN}.xml
-       fperms 600 /etc/jabber/${PN}.xml
-       fowners jabber:jabber /etc/jabber/${PN}.xml
-       fperms 755 "$(python_get_sitedir)/${PN}/${PN}.py"
-       sed -i \
-               -e "s:<spooldir>[^\<]*</spooldir>:<spooldir>/var/spool/jabber</spooldir>:" \
-               -e "s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \
-               "${ED}/etc/jabber/${PN}.xml" || die
-
-       newinitd "${FILESDIR}/${PN}-0.8-initd-r1" ${PN}
-       systemd_dounit "${FILESDIR}/${PN}.service"
-       sed -i -e "s:INSPATH:$(python_get_sitedir)/${PN}:" \
-               "${ED}/etc/init.d/${PN}" "${ED}/usr/lib/systemd/system/${PN}.service" || die
-
-       python_fix_shebang "${D}$(python_get_sitedir)/${PN}"
-}
index 889ff1cff7137c5964f5d3c39b18ce4254e4327a..58c536a9a63611750d5031493b996166f71e4f33 100644 (file)
@@ -14,7 +14,7 @@ S="${WORKDIR}/${MY_P}"
 
 LICENSE="GPL-2"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
 IUSE="webinterface"
 
 DEPEND="net-im/jabber-base"