sys-process/supervise-scripts: EAPI bump
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Mon, 28 Jan 2019 00:04:43 +0000 (01:04 +0100)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Mon, 28 Jan 2019 00:04:43 +0000 (01:04 +0100)
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
sys-process/supervise-scripts/supervise-scripts-4.0-r1.ebuild [new file with mode: 0644]

diff --git a/sys-process/supervise-scripts/supervise-scripts-4.0-r1.ebuild b/sys-process/supervise-scripts/supervise-scripts-4.0-r1.ebuild
new file mode 100644 (file)
index 0000000..0d19d3c
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Starting and stopping daemontools managed services"
+HOMEPAGE="http://untroubled.org/supervise-scripts/"
+SRC_URI="http://untroubled.org/supervise-scripts/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND="virtual/daemontools"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+       echo "/usr/bin" > conf-bin
+       echo "/usr/share/man" > conf-man
+       default
+}
+
+src_install() {
+       emake PREFIX="${D}" install
+       use doc && dodoc *.html
+}