media-libs/harfbuzz: Removed old
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 7 Apr 2020 18:25:58 +0000 (20:25 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 7 Apr 2020 18:25:58 +0000 (20:25 +0200)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
media-libs/harfbuzz/Manifest
media-libs/harfbuzz/harfbuzz-2.6.1.ebuild [deleted file]

index 9773b7afb4e3938281d837658cd3d102c5280172..66b2d916e50248abe2a77284f6d1759acc968a15 100644 (file)
@@ -1,2 +1 @@
-DIST harfbuzz-2.6.1.tar.xz 5741372 BLAKE2B bb763eba23a37bd20d0ddb39824d5a0c655d6e098aea2e44b6943e7bd5cb1f9a5cd94e3de5520d962e3c476defac43af58f98d0a5b80e5c1506d00bc716ec876 SHA512 cea531ab9db0ae1b188ac56c3ea6e0344192c4321b97d4425f4a53e6bb34c88463a7453fd69fcadccb8574506c1fb5505422019e41a7938a04e7823e3f484c06
 DIST harfbuzz-2.6.4.tar.xz 5967468 BLAKE2B 24d215324a408a724f47a901c4a56605144d15373518bd52643ece83705d0c63582a80635ecef6a6d8d2f5f39c750076d553fb39aaa8c0dd41702ee910c32f24 SHA512 d8664bb64fda11ff7646693070637e3827f8b3d1de50e11ecf108ce4d19c878b26b2ba4cff278da6e6cc0cb431e1630d9eaa7c32a9bebb9655a7aa8dabf7114f
diff --git a/media-libs/harfbuzz/harfbuzz-2.6.1.ebuild b/media-libs/harfbuzz/harfbuzz-2.6.1.ebuild
deleted file mode 100644 (file)
index ec55a08..0000000
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit flag-o-matic libtool multilib-minimal python-any-r1 xdg-utils
-
-DESCRIPTION="An OpenType text shaping engine"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz"
-
-if [[ ${PV} = 9999 ]] ; then
-       EGIT_REPO_URI="https://anongit.freedesktop.org/git/harfbuzz.git"
-       inherit git-r3 autotools
-else
-       SRC_URI="https://www.freedesktop.org/software/${PN}/release/${P}.tar.xz"
-       KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-LICENSE="Old-MIT ISC icu"
-SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416
-
-IUSE="+cairo debug +glib +graphite icu +introspection static-libs test +truetype"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="introspection? ( glib )"
-
-RDEPEND="
-       cairo? ( x11-libs/cairo:= )
-       glib? ( >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}] )
-       graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
-       icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
-       introspection? ( >=dev-libs/gobject-introspection-1.34:= )
-       truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] )
-"
-DEPEND="${RDEPEND}
-       test? ( ${PYTHON_DEPS} )
-"
-BDEPEND="
-       dev-util/gtk-doc-am
-       virtual/pkgconfig
-"
-# eautoreconf requires gobject-introspection-common
-# ragel needed if regenerating *.hh files from *.rl
-if [[ ${PV} = 9999 ]] ; then
-       DEPEND+="
-               >=dev-libs/gobject-introspection-common-1.34
-               dev-util/ragel
-       "
-fi
-
-PATCHES=(
-       "${FILESDIR}"/${P}-gcc-9.patch
-)
-
-pkg_setup() {
-       use test && python-any-r1_pkg_setup
-       if ! use debug ; then
-               append-cppflags -DHB_NDEBUG
-       fi
-}
-
-src_prepare() {
-       default
-
-       xdg_environment_reset
-
-       if [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] ; then
-               # on Darwin/Solaris we need to link with g++, like automake defaults
-               # to, but overridden by upstream because on Linux this is not
-               # necessary, bug #449126
-               sed -i \
-                       -e 's/\<LINK\>/CXXLINK/' \
-                       src/Makefile.am || die
-               sed -i \
-                       -e '/libharfbuzz_la_LINK = /s/\<LINK\>/CXXLINK/' \
-                       src/Makefile.in || die
-               sed -i \
-                       -e '/AM_V_CCLD/s/\<LINK\>/CXXLINK/' \
-                       test/api/Makefile.in || die
-       fi
-
-       [[ ${PV} == 9999 ]] && eautoreconf
-       elibtoolize # for Solaris
-
-       # bug 618772
-       append-cxxflags -std=c++14
-}
-
-multilib_src_configure() {
-       # harfbuzz-gobject only used for instrospection, bug #535852
-       local myeconfargs=(
-               --without-coretext
-               --without-fontconfig #609300
-               --without-uniscribe
-               $(use_enable static-libs static)
-               $(multilib_native_use_with cairo)
-               $(use_with glib)
-               $(use_with introspection gobject)
-               $(use_with graphite graphite2)
-               $(use_with icu)
-               $(multilib_native_use_enable introspection)
-               $(use_with truetype freetype)
-       )
-       ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-
-       if multilib_is_native_abi; then
-               ln -s "${S}"/docs/html docs/html || die
-       fi
-}
-
-multilib_src_install_all() {
-       einstalldocs
-       find "${ED}" -name "*.la" -delete || die
-}