app-pda/libplist: fix for bug 567370 (configure fail on -lpython3.4)
authorStephen L Arnold <nerdboy@gentoo.org>
Thu, 31 Dec 2015 22:03:24 +0000 (14:03 -0800)
committerStephen L Arnold <nerdboy@gentoo.org>
Thu, 31 Dec 2015 22:12:03 +0000 (14:12 -0800)
Added to latest two versions for broader testing, fixes above bug plus
some duplicates.  Fix stolen from Arch (alertly pointed out by veremit).

Reported-by: (user) <candrews@integralblue.com>
Package-Manager: portage-2.2.26

app-pda/libplist/libplist-1.11-r2.ebuild
app-pda/libplist/libplist-1.12.ebuild

index 2f5331b864b2a64aae8c6c8b899487eddf404205..600f79c1a0414b67c0e2a602ee3dbf64e349d835 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=5
 PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
-inherit eutils python-r1
+inherit autotools eutils python-r1
 
 DESCRIPTION="Support library to deal with Apple Property Lists (Binary & XML)"
 HOMEPAGE="http://www.libimobiledevice.org/"
@@ -29,6 +29,11 @@ RESTRICT="test" # TODO: src_test() was dropped from 1.10 (cmake) -> 1.11 (autoto
 
 BUILD_DIR="${S}_build"
 
+src_prepare() {
+       sed -i -e 's/AC_PYTHON_DEVEL/AX_PYTHON_DEVEL/' "${S}"/m4/cython_python.m4
+       eautoreconf
+}
+
 src_configure() {
        local ECONF_SOURCE=${S}
        local myeconfargs=( $(use_enable static-libs static) )
index f674ed03a67696554d6dc76de0a263d2ded1edcb..bc3d53f8a9d81dfb02b7a5b8aed3e13c0cf9698b 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=5
 PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
-inherit eutils python-r1
+inherit autotools eutils python-r1
 
 DESCRIPTION="Support library to deal with Apple Property Lists (Binary & XML)"
 HOMEPAGE="http://www.libimobiledevice.org/"
@@ -29,6 +29,11 @@ RESTRICT="test" # TODO: src_test() was dropped from 1.10 (cmake) -> 1.11 (autoto
 
 BUILD_DIR="${S}_build"
 
+src_prepare() {
+       sed -i -e 's/AC_PYTHON_DEVEL/AX_PYTHON_DEVEL/' "${S}"/m4/cython_python.m4
+       eautoreconf
+}
+
 src_configure() {
        local ECONF_SOURCE=${S}
        local myeconfargs=( $(use_enable static-libs static) )